aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-06-12 09:46:09 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-06-12 09:46:09 +0000
commit5a1964dbcdc0128fad7ad6894a9b3683b8e997c8 (patch)
treee758d068d77a1912b656f82019bb6260b7ab9f96 /x11
parentcc6596753b50e5161161c7635e1daed11d676428 (diff)
downloadports-5a1964dbcdc0128fad7ad6894a9b3683b8e997c8.tar.gz
ports-5a1964dbcdc0128fad7ad6894a9b3683b8e997c8.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/gdm2/Makefile4
-rw-r--r--x11/gnome-applets/Makefile4
-rw-r--r--x11/gnome-desktop/Makefile4
-rw-r--r--x11/gnome-libs/Makefile2
-rw-r--r--x11/gnome-panel/Makefile4
-rw-r--r--x11/gnome-session/Makefile4
-rw-r--r--x11/gnomeapplets/Makefile4
-rw-r--r--x11/gnomeapplets2/Makefile4
-rw-r--r--x11/gnomecore/Makefile4
-rw-r--r--x11/gnomedesktop/Makefile4
-rw-r--r--x11/gnomelibs/Makefile2
-rw-r--r--x11/gnomemag/Makefile4
-rw-r--r--x11/gnomepanel/Makefile4
-rw-r--r--x11/gnomesession/Makefile4
-rw-r--r--x11/startup-notification/Makefile4
-rw-r--r--x11/xalf/Makefile4
-rw-r--r--x11/xscreensaver-gnome/Makefile4
-rw-r--r--x11/yelp/Makefile2
18 files changed, 3 insertions, 63 deletions
diff --git a/x11/gdm2/Makefile b/x11/gdm2/Makefile
index e3fe64b509bc..ab029bd1f11c 100644
--- a/x11/gdm2/Makefile
+++ b/x11/gdm2/Makefile
@@ -49,10 +49,6 @@ post-extract:
@${SED} -e "s,%%PREFIX%%,${PREFIX},g" \
${FILESDIR}/gdm.sh.sample > ${WRKSRC}/gdm.sh.sample
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
post-install:
.if !defined(PACKAGE_BUILDING)
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 5224fb320070..dec64e5483e3 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -36,8 +36,4 @@ PLIST_SUB= BATTERY="@comment "
PLIST_SUB= BATTERY=""
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.post.mk>
diff --git a/x11/gnome-desktop/Makefile b/x11/gnome-desktop/Makefile
index 63ade0c1b7d2..8ae160c83395 100644
--- a/x11/gnome-desktop/Makefile
+++ b/x11/gnome-desktop/Makefile
@@ -32,8 +32,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gnome-about.1
post-patch:
- @${REINPLACE_CMD} -E -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|GNOME_VENDOR=.*$$|GNOME_VENDOR="FreeBSD GNOME Project"| ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -E -e 's|GNOME_VENDOR=.*$$|GNOME_VENDOR="FreeBSD GNOME Project"|' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/x11/gnome-libs/Makefile b/x11/gnome-libs/Makefile
index 7bee2ee59ad2..e9f3e08cacdf 100644
--- a/x11/gnome-libs/Makefile
+++ b/x11/gnome-libs/Makefile
@@ -41,8 +41,6 @@ MAN1= dns-helper.1 gconfigger.1 gnome-bug.1 gnome-config.1 \
MAN5= gnome-mime.5
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/gnome-config.in ${WRKSRC}/libgnome/gnome-util.c
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index eeab7d719f29..f8d30ecc3b77 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -31,8 +31,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
MAN1= gnome-panel.1 gnome-panel-preferences.1
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/x11/gnome-session/Makefile b/x11/gnome-session/Makefile
index 051b3ac8b369..125b45fae2a9 100644
--- a/x11/gnome-session/Makefile
+++ b/x11/gnome-session/Makefile
@@ -29,8 +29,4 @@ MAN1= gnome-session.1 gnome-smproxy.1 gnome-wm.1 session-properties.1 \
gnome-session-save.1
MAN5= default.session.5
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/x11/gnomeapplets/Makefile b/x11/gnomeapplets/Makefile
index 5b47e24daac9..63563113ece2 100644
--- a/x11/gnomeapplets/Makefile
+++ b/x11/gnomeapplets/Makefile
@@ -45,8 +45,4 @@ PLIST_SUB= BATTERY=""
MAN1+= battery_applet.1
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.post.mk>
diff --git a/x11/gnomeapplets2/Makefile b/x11/gnomeapplets2/Makefile
index 5224fb320070..dec64e5483e3 100644
--- a/x11/gnomeapplets2/Makefile
+++ b/x11/gnomeapplets2/Makefile
@@ -36,8 +36,4 @@ PLIST_SUB= BATTERY="@comment "
PLIST_SUB= BATTERY=""
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.post.mk>
diff --git a/x11/gnomecore/Makefile b/x11/gnomecore/Makefile
index 9edb8fac4ca5..e9e3b1a9e6ac 100644
--- a/x11/gnomecore/Makefile
+++ b/x11/gnomecore/Makefile
@@ -38,8 +38,4 @@ MAN1= deskguide_applet.1 gmenu.1 gnome-about.1 gnome-convert.1 \
session-properties-capplet.1
MAN5= default.session.5
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/x11/gnomedesktop/Makefile b/x11/gnomedesktop/Makefile
index 63ade0c1b7d2..8ae160c83395 100644
--- a/x11/gnomedesktop/Makefile
+++ b/x11/gnomedesktop/Makefile
@@ -32,8 +32,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gnome-about.1
post-patch:
- @${REINPLACE_CMD} -E -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|GNOME_VENDOR=.*$$|GNOME_VENDOR="FreeBSD GNOME Project"| ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -E -e 's|GNOME_VENDOR=.*$$|GNOME_VENDOR="FreeBSD GNOME Project"|' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/x11/gnomelibs/Makefile b/x11/gnomelibs/Makefile
index 7bee2ee59ad2..e9f3e08cacdf 100644
--- a/x11/gnomelibs/Makefile
+++ b/x11/gnomelibs/Makefile
@@ -41,8 +41,6 @@ MAN1= dns-helper.1 gconfigger.1 gnome-bug.1 gnome-config.1 \
MAN5= gnome-mime.5
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/gnome-config.in ${WRKSRC}/libgnome/gnome-util.c
diff --git a/x11/gnomemag/Makefile b/x11/gnomemag/Makefile
index aa0db7faed98..b319d2e7b8c7 100644
--- a/x11/gnomemag/Makefile
+++ b/x11/gnomemag/Makefile
@@ -25,8 +25,4 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/x11/gnomepanel/Makefile b/x11/gnomepanel/Makefile
index eeab7d719f29..f8d30ecc3b77 100644
--- a/x11/gnomepanel/Makefile
+++ b/x11/gnomepanel/Makefile
@@ -31,8 +31,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
MAN1= gnome-panel.1 gnome-panel-preferences.1
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/x11/gnomesession/Makefile b/x11/gnomesession/Makefile
index 051b3ac8b369..125b45fae2a9 100644
--- a/x11/gnomesession/Makefile
+++ b/x11/gnomesession/Makefile
@@ -29,8 +29,4 @@ MAN1= gnome-session.1 gnome-smproxy.1 gnome-wm.1 session-properties.1 \
gnome-session-save.1
MAN5= default.session.5
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/x11/startup-notification/Makefile b/x11/startup-notification/Makefile
index 6a3f118224c8..98791038bb0d 100644
--- a/x11/startup-notification/Makefile
+++ b/x11/startup-notification/Makefile
@@ -30,8 +30,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/x11/xalf/Makefile b/x11/xalf/Makefile
index 61279360849a..1ac776ba871d 100644
--- a/x11/xalf/Makefile
+++ b/x11/xalf/Makefile
@@ -24,8 +24,4 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/x11/xscreensaver-gnome/Makefile b/x11/xscreensaver-gnome/Makefile
index df4a9cc1e4e7..b300b169837d 100644
--- a/x11/xscreensaver-gnome/Makefile
+++ b/x11/xscreensaver-gnome/Makefile
@@ -23,7 +23,7 @@ USE_XPM= yes
USE_MESA= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomehier libglade2
+USE_GNOME= gnomehier libglade2 gnomehack
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-pam --with-gl --with-gle --with-xpm --with-xml \
--with-hackdir=${PREFIX}/bin/xscreensaver-hacks \
@@ -67,8 +67,6 @@ MAN1= anemone.1 ant.1 apollonian.1 atlantis.1 attraction.1 blaster.1 \
xscreensaver-getimage.1 xscreensaver-gl-helper.1 xscreensaver.1
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|malloc[.]h|stdlib.h|g' \
${WRKSRC}/hacks/glx/extrusion.c
@${REINPLACE_CMD} -e 's| ||' \
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index 7b9d284cd255..0a110d1fe6f9 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -26,8 +26,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAKE_ENV= G_CHARSET_ALIAS="${LOCALBASE}/libdata/charset.alias"
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|\@prefix\@/share|\@datadir\@|g' \
${WRKSRC}/stylesheets/docbook/catalog.in