aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-28 07:15:17 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-28 07:15:17 +0000
commitd3a43fd95fce0a32528d2f288a8466ea585b68a2 (patch)
tree16d592b70bc264d4f3b9cd513b24797818c00b6a /x11
parent79a697ea8ac0972aa7967cf07baf35ff757508da (diff)
downloadports-d3a43fd95fce0a32528d2f288a8466ea585b68a2.tar.gz
ports-d3a43fd95fce0a32528d2f288a8466ea585b68a2.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/e17-module-devian/Makefile6
-rw-r--r--x11/e17-module-devian/distinfo6
-rw-r--r--x11/e17-module-devian/files/patch-configure11
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_config.c20
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_devian.c11
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_theme.c27
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_container.c20
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_data_file.c11
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_data_picture.c20
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_data_rss.c47
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_devian.c11
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_main.c11
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_source_file.c11
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_source_picture.c38
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_source_rss.c20
-rw-r--r--x11/e17-module-devian/pkg-plist7
16 files changed, 11 insertions, 266 deletions
diff --git a/x11/e17-module-devian/Makefile b/x11/e17-module-devian/Makefile
index a028d31456e6..5f4d9cdb1e9b 100644
--- a/x11/e17-module-devian/Makefile
+++ b/x11/e17-module-devian/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= devian
-PORTVERSION= 23062006
-PORTREVISION= 1
+PORTVERSION= 20060728
+PORTEPOCH= 1
CATEGORIES= x11
MASTER_SITES= http://mbsd.msk.ru/dist/
PKGNAMEPREFIX= e17-module-
@@ -26,4 +26,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+PLIST_SUB+= MODULE_ARCH=freebsd${OSREL}-${ARCH}
+
.include <bsd.port.mk>
diff --git a/x11/e17-module-devian/distinfo b/x11/e17-module-devian/distinfo
index ea3379bb2bd6..a556bbebfa34 100644
--- a/x11/e17-module-devian/distinfo
+++ b/x11/e17-module-devian/distinfo
@@ -1,3 +1,3 @@
-MD5 (devian-23062006.tar.bz2) = 92dca18d8f43356f079e8c9a6e2cc4dd
-SHA256 (devian-23062006.tar.bz2) = ecfea86715b388cd5e53c49a31ab70d492d04553c48d18e4a89b720d20e6ea40
-SIZE (devian-23062006.tar.bz2) = 1114625
+MD5 (devian-20060728.tar.bz2) = 0a89a14c06689bf77fd5eb485922e879
+SHA256 (devian-20060728.tar.bz2) = c3bbaf2fa67dcc2075635368ede0aae4a20c3f0d3b08ae60295aeb5ed1291875
+SIZE (devian-20060728.tar.bz2) = 1115532
diff --git a/x11/e17-module-devian/files/patch-configure b/x11/e17-module-devian/files/patch-configure
deleted file mode 100644
index c42dbe714bc9..000000000000
--- a/x11/e17-module-devian/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Fri Jun 23 16:35:39 2006
-+++ configure Fri Jun 23 16:35:51 2006
-@@ -21610,7 +21610,7 @@
-
-
-
--MODULE_ARCH="$host_os-$host_cpu"
-+MODULE_ARCH=""
-
-
- cat >>confdefs.h <<_ACEOF
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_config.c b/x11/e17-module-devian/files/patch-src__module__e_mod_config.c
deleted file mode 100644
index 5bfef32cd41d..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_config.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/module/e_mod_config.c.orig Thu Jul 6 23:32:07 2006
-+++ src/module/e_mod_config.c Thu Jul 6 23:32:25 2006
-@@ -100,7 +100,7 @@
- "has been upgraded<br>"
- "Your settings were removed<br>"
- "Sorry for the inconvenience<br><br>" "(%d -> %d)"), cfg_main->conf_version, CONFIG_VERSION);
-- e_module_dialog_show(_(MODULE_NAME " Module version " MODULE_VERSION), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module version " MODULE_VERSION), buf);
-
- cfg_main = NULL;
- }
-@@ -116,7 +116,7 @@
- "has been downgraded<br>"
- "Your settings were removed<br>"
- "Sorry for the inconvenience<br><br>" "(%d ->%d)"), cfg_main->conf_version, CONFIG_VERSION);
-- e_module_dialog_show(_(MODULE_NAME " Module version " MODULE_VERSION), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module version " MODULE_VERSION), buf);
- cfg_main = NULL;
- }
- }
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_devian.c b/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_devian.c
deleted file mode 100644
index cd4c580f3b49..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_devian.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/module/e_mod_config_dialog_devian.c.orig Thu Jul 6 23:32:48 2006
-+++ src/module/e_mod_config_dialog_devian.c Thu Jul 6 23:33:02 2006
-@@ -789,7 +789,7 @@
- snprintf(buf, sizeof(buf),
- _("<hilight>Rss '%s' is in use !</hilight><br><br>"
- "You can't delete it while its in use.<br><br>" "Owner is %s"), doc->name, doc->user->source->devian->id);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- }
- }
- #endif
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_theme.c b/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_theme.c
deleted file mode 100644
index 73338ca1ff69..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_theme.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/module/e_mod_config_dialog_theme.c.orig Thu Jul 6 23:33:17 2006
-+++ src/module/e_mod_config_dialog_theme.c Thu Jul 6 23:33:33 2006
-@@ -636,7 +636,7 @@
- if (!ecore_file_is_dir(themes_path))
- {
- snprintf(buf, sizeof(buf), _("<hilight>Directory %s doesnt exists.</hilight><br><br>" "No themes found !!!"), themes_path);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return NULL;
- }
-
-@@ -644,7 +644,7 @@
- if (ecore_list_is_empty(list) || !list)
- {
- snprintf(buf, sizeof(buf), _("<hilight>Directory %s is empty !</hilight><br><br>" "No themes found !!!"), themes_path);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return NULL;
- }
-
-@@ -701,5 +701,5 @@
- snprintf(buf, sizeof(buf),
- _("<hilight>Invalid theme</hilight><br><br>"
- "You have selected an invalid theme.<br>" "A valid theme has a dEvian icon in front of it."));
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- }
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_container.c b/x11/e17-module-devian/files/patch-src__module__e_mod_container.c
deleted file mode 100644
index 6f71799d61cd..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_container.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/module/e_mod_container.c.orig Thu Jul 6 23:33:42 2006
-+++ src/module/e_mod_container.c Thu Jul 6 23:33:53 2006
-@@ -248,7 +248,7 @@
- char buf[4096];
-
- snprintf(buf, sizeof(buf), _("<hilight>Invalid theme !</hilight><br><br>" "Failed to switch to %s theme"), *theme);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- evas_stringshare_del(*theme);
- *theme = evas_stringshare_add(DEVIAN_THEME_DEFAULT);
- DEVIANF(container_change) (devian, devian->conf->container_type);
-@@ -272,7 +272,7 @@
-
- snprintf(buf, sizeof(buf),
- _("<hilight>Invalid theme !</hilight><br><br>" "Failed to switch to %s theme"), *theme);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- evas_stringshare_del(*theme);
- *theme = evas_stringshare_add(DEVIAN_THEME_DEFAULT);
- DEVIANF(container_change) (devian, devian->conf->container_type);
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_data_file.c b/x11/e17-module-devian/files/patch-src__module__e_mod_data_file.c
deleted file mode 100644
index a4f3aab53a05..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_data_file.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/module/e_mod_data_file.c.orig Thu Jul 6 23:30:59 2006
-+++ src/module/e_mod_data_file.c Thu Jul 6 23:31:07 2006
-@@ -33,7 +33,7 @@
- snprintf(buf, sizeof(buf),
- _("<hilight>Can't open file %s</hilight><br><br>"
- "You can change the file in the dEvian's config panel"), source->devian->conf->file_path);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- }
-
- /* create the textblock */
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_data_picture.c b/x11/e17-module-devian/files/patch-src__module__e_mod_data_picture.c
deleted file mode 100644
index d8de6e37e18d..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_data_picture.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/module/e_mod_data_picture.c.orig Thu Jul 6 23:30:33 2006
-+++ src/module/e_mod_data_picture.c Thu Jul 6 23:30:56 2006
-@@ -402,7 +402,7 @@
- "They can be jpeg or png<br><br>"
- "After import, if you can remove these files and the pictures still can<br>"
- "be viewed, but you wont be able to set them as wallpaper anymore<br><br>"), dir);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return 0;
- }
-
-@@ -1199,7 +1199,7 @@
- DEVIANM->conf->sources_picture_data_import_thumbs_warn)
- {
- DEVIANM->conf->sources_picture_data_import_thumbs_warn = 0;
-- e_module_dialog_show(_(MODULE_NAME " Module Information"),
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Information"),
- _("<hilight>Creating thumbs</hilight><br><br>"
- "Some pictures are being thumbed in a <hilight>background task</hilight>.<br>"
- "It can take a while, but after, loading will be faster :)<br><br>"
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_data_rss.c b/x11/e17-module-devian/files/patch-src__module__e_mod_data_rss.c
deleted file mode 100644
index d0b0eae4bf2a..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_data_rss.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/module/e_mod_data_rss.c.orig Thu Jul 6 23:30:02 2006
-+++ src/module/e_mod_data_rss.c Thu Jul 6 23:30:29 2006
-@@ -280,7 +280,7 @@
- snprintf(buf, sizeof(buf),
- _("<hilight>Rss '%s' is aready in use !</hilight><br><br>"
- "You can't set a rss document to more than one dEvian<br><br>" "Url: %s"), doc->name, doc->url);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return -1;
- }
-
-@@ -561,7 +561,7 @@
- "<underline=on underline_color=#000>Url :</> %s<br>"
- "<underline=on underline_color=#000>Begining of the document dEvian get :</><br>%100.100s"),
- doc->name, doc->url, feed->buffer);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- }
- else
- {
-@@ -572,7 +572,7 @@
- "<underline=on underline_color=#000>Url :</> %s<br>"
- "<underline=on underline_color=#000>Begining of the document dEvian get :</><br>%100.100s<br>"
- "%100.100s"), doc->name, doc->url, feed->buffer, p);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- }
- }
- DEVIANF(container_loading_state_change) (feed->source->devian, 0);
-@@ -1009,7 +1009,7 @@
- {
- snprintf(buf, sizeof(buf),
- _("<hilight>Unable to open link</hilight><br><br>" "Article '%s' has no link associated !"), article->title);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return;
- }
-
-@@ -1029,7 +1029,7 @@
- _("<hilight>Viewer %s not found !</hilight><br><br>"
- "You can change the viewer for http in dEvian configuration panel\
- (Advanced view)"), DEVIANM->conf->viewer_http);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return;
- }
-
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_devian.c b/x11/e17-module-devian/files/patch-src__module__e_mod_devian.c
deleted file mode 100644
index 806f812f99b6..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_devian.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/module/e_mod_devian.c.orig Thu Jul 6 23:34:34 2006
-+++ src/module/e_mod_devian.c Thu Jul 6 23:34:41 2006
-@@ -443,7 +443,7 @@
-
- snprintf(buf, sizeof(buf),
- _("<hilight>Error !</hilight><br>" "Did not find <hilight>theme</hilight> %s group %s"), path, part);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return NULL;
- }
- DMAIN(("Edje loaded %s group %s", path, part));
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_main.c b/x11/e17-module-devian/files/patch-src__module__e_mod_main.c
deleted file mode 100644
index 4284969b62ab..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_main.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/module/e_mod_main.c.orig Thu Jul 6 23:28:34 2006
-+++ src/module/e_mod_main.c Thu Jul 6 23:28:50 2006
-@@ -48,7 +48,7 @@
- char buf[4096];
-
- snprintf(buf, sizeof(buf), _("Enlightenment %s Module - version " MODULE_VERSION), MODULE_NAME);
-- e_module_dialog_show(buf, _(
-+ e_module_dialog_show(m, buf, _(
- #ifndef HAVE_ALL
- "This module is part of dEvian module<br><br>"
- #ifdef HAVE_PICTURE
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_source_file.c b/x11/e17-module-devian/files/patch-src__module__e_mod_source_file.c
deleted file mode 100644
index 59bcfb49d150..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_source_file.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/module/e_mod_source_file.c.orig Thu Jul 6 23:29:46 2006
-+++ src/module/e_mod_source_file.c Thu Jul 6 23:29:54 2006
-@@ -24,7 +24,7 @@
- snprintf(buf, sizeof(buf),
- _("<hilight>dEvian's Log feature isn't stable yet !</hilight><br><br>"
- "It's disabled for now"));
-- e_module_dialog_show(_(MODULE_NAME " Module error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module error"), buf);
- return 0;
- }
- #endif
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_source_picture.c b/x11/e17-module-devian/files/patch-src__module__e_mod_source_picture.c
deleted file mode 100644
index e220b744198a..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_source_picture.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/module/e_mod_source_picture.c.orig Thu Jul 6 23:29:20 2006
-+++ src/module/e_mod_source_picture.c Thu Jul 6 23:29:41 2006
-@@ -174,7 +174,7 @@
- _("<hilight>File %s doesnt exists.</hilight><br><br>"
- "This file is in dEvian's picture list, but it seems you removed it from the disk<br>"
- "It cant be set as background, sorry."), file);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return 0;
- }
-
-@@ -201,7 +201,7 @@
- "%s is not an edje file !<br>"
- "dEvian need e17setroot util from e_utils package to set you're picture as background"
- "Please install it and try again"), file);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return 0;
- }
- }
-@@ -261,7 +261,7 @@
- _("<hilight>File %s doesnt exists !</hilight><br><br>"
- "This file is in dEvian's picture list, but it seems you removed it from the disk.<br>"
- "It cant be set opened in a viewer, sorry."), file);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return 0;
- }
-
-@@ -281,7 +281,7 @@
- _("<hilight>Viewer %s not found !</hilight><br><br>"
- "You can change the viewer for images in dEvian configuration panel (Advanced view)"),
- DEVIANM->conf->viewer_image);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return 0;
- }
-
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_source_rss.c b/x11/e17-module-devian/files/patch-src__module__e_mod_source_rss.c
deleted file mode 100644
index abef36a9889f..000000000000
--- a/x11/e17-module-devian/files/patch-src__module__e_mod_source_rss.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/module/e_mod_source_rss.c.orig Thu Jul 6 23:28:58 2006
-+++ src/module/e_mod_source_rss.c Thu Jul 6 23:29:14 2006
-@@ -108,7 +108,7 @@
- snprintf(buf, sizeof(buf),
- _("<hilight>Unable to open link</hilight><br><br>"
- "Feed '%s' has no link associated !"), source->devian->conf->rss_doc->name);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return 0;
- }
-
-@@ -128,7 +128,7 @@
- _("<hilight>Viewer %s not found !</hilight><br><br>"
- "You can change the viewer for http in DEVIANN configuration panel (Advanced view)"),
- DEVIANM->conf->viewer_http);
-- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
-+ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
- return 0;
- }
-
diff --git a/x11/e17-module-devian/pkg-plist b/x11/e17-module-devian/pkg-plist
index bf0c951b8aff..239a0488863f 100644
--- a/x11/e17-module-devian/pkg-plist
+++ b/x11/e17-module-devian/pkg-plist
@@ -1,11 +1,12 @@
lib/enlightenment/modules/devian/dEvian.jpg
-lib/enlightenment/modules/devian/module.a
+lib/enlightenment/modules/devian/%%MODULE_ARCH%%/module.a
+lib/enlightenment/modules/devian/%%MODULE_ARCH%%/module.la
+lib/enlightenment/modules/devian/%%MODULE_ARCH%%/module.so
lib/enlightenment/modules/devian/module.eap
-lib/enlightenment/modules/devian/module.la
-lib/enlightenment/modules/devian/module.so
lib/enlightenment/modules/devian/module_icon.png
lib/enlightenment/modules/devian/themes/blue_eyed.edj
lib/enlightenment/modules/devian/themes/clean.edj
lib/enlightenment/modules/devian/themes/minimal.edj
@dirrm lib/enlightenment/modules/devian/themes
+@dirrm lib/enlightenment/modules/devian/%%MODULE_ARCH%%
@dirrm lib/enlightenment/modules/devian