aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-13 19:43:05 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-13 19:43:05 +0000
commitd3dcdceb98155edaba1f963eb36a2dd2eb01c772 (patch)
tree2a4996fefd30e2564e43ab8adc2639b86ea64637 /x11
parent241057eb009eabf6328ba53867f1f2d1da57068d (diff)
downloadports-d3dcdceb98155edaba1f963eb36a2dd2eb01c772.tar.gz
ports-d3dcdceb98155edaba1f963eb36a2dd2eb01c772.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/gnome-applets/Makefile1
-rw-r--r--x11/gnome-applets/files/patch-cpufreq-freebsd14
2 files changed, 12 insertions, 3 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index b4ef495ae345..0e7ac305bf96 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnome-applets
PORTVERSION= 2.30.0
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/x11/gnome-applets/files/patch-cpufreq-freebsd b/x11/gnome-applets/files/patch-cpufreq-freebsd
index a597e6725bd0..15e75f5340bd 100644
--- a/x11/gnome-applets/files/patch-cpufreq-freebsd
+++ b/x11/gnome-applets/files/patch-cpufreq-freebsd
@@ -217,9 +217,9 @@
void
cpufreq_utils_display_error (const gchar *message,
---- cpufreq/src/cpufreq-monitor-sysctl.c.orig Wed Feb 28 14:03:58 2007
-+++ cpufreq/src/cpufreq-monitor-sysctl.c Wed Feb 28 14:28:47 2007
-@@ -0,0 +1,176 @@
+--- cpufreq/src/cpufreq-monitor-sysctl.c.orig 2010-05-13 11:27:57.000000000 +0200
++++ cpufreq/src/cpufreq-monitor-sysctl.c 2010-05-13 11:36:13.000000000 +0200
+@@ -0,0 +1,184 @@
+/*
+ * Copyright (C) 2001, 2002 Free Software Foundation
+ *
@@ -305,6 +305,9 @@
+ fmax = atoi ((gchar *) list->data);
+ fmin = atoi ((gchar *) g_list_nth_data (list, (g_list_length (list) - 1)));
+
++ g_list_foreach (list, (GFunc) g_free, NULL);
++ g_list_free (list);
++
+ g_object_get (G_OBJECT (monitor), "cpu", &mon_cpu, NULL);
+ len = sizeof (ifreq);
+ freq_oid = g_strdup_printf ("dev.cpu.%d.freq", 0);
@@ -330,6 +333,8 @@
+ "max-frequency", fmax,
+ NULL);
+
++ g_free (governer);
++
+ return TRUE;
+}
+
@@ -357,7 +362,10 @@
+
+ levels = g_malloc (len);
+ if (sysctl (mib, 4, levels, &len, NULL, 0) == -1)
++ {
++ g_free(levels);
+ return NULL;
++ }
+
+ levelsp = g_strsplit (levels, " ", 0);
+ g_free (levels);