aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-10-24 17:55:16 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-10-24 17:55:16 +0000
commite68cab40e8b81d039421118c574cd8a47f0564f4 (patch)
tree15a2c493876ed15196e7def847ae557f430955c8 /x11
parenteb9ac74756506542389cabd0df05fb6fe5cc85de (diff)
downloadports-e68cab40e8b81d039421118c574cd8a47f0564f4.tar.gz
ports-e68cab40e8b81d039421118c574cd8a47f0564f4.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xidle/Makefile31
-rw-r--r--x11/xidle/distinfo2
-rw-r--r--x11/xidle/pkg-descr6
4 files changed, 40 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 4076864f6a5b..6bd481621877 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -227,6 +227,7 @@
SUBDIR += xfishtank
SUBDIR += xfree86_xkb_xml
SUBDIR += xgrab
+ SUBDIR += xidle
SUBDIR += xinput
SUBDIR += xkbctrl
SUBDIR += xkbset
diff --git a/x11/xidle/Makefile b/x11/xidle/Makefile
new file mode 100644
index 000000000000..d71b3459c2d6
--- /dev/null
+++ b/x11/xidle/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xidle
+# Date created: 2005-10-24
+# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xidle
+PORTVERSION= 24102005
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= novel
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= Run a program on X inactivity
+
+USE_BZIP2= yes
+USE_GETOPT_LONG=yes
+USE_X_PREFIX= yes
+CFLAGS+= -I${X11BASE}/include -D__dead=static
+MAKE_ARGS+= X11LIBDIR="${X11BASE}/lib" \
+ CFLAGS="${CFLAGS}"
+
+PLIST_FILES= bin/xidle
+MAN1= xidle.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xidle ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xidle.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/x11/xidle/distinfo b/x11/xidle/distinfo
new file mode 100644
index 000000000000..f824a7ad6a5b
--- /dev/null
+++ b/x11/xidle/distinfo
@@ -0,0 +1,2 @@
+MD5 (xidle-24102005.tar.bz2) = 6d4067b5adac594aa5917f2265cc02ee
+SIZE (xidle-24102005.tar.bz2) = 4886
diff --git a/x11/xidle/pkg-descr b/x11/xidle/pkg-descr
new file mode 100644
index 000000000000..5ffd09e8aa1a
--- /dev/null
+++ b/x11/xidle/pkg-descr
@@ -0,0 +1,6 @@
+xidle uses the XScreenSaver(3) extension to receive inactivity events
+when a timeout is specified, running a specific program after the elapsed
+time. xidle also monitors the very corner of the given position for
+pointer activity and runs a program if the pointer sits there for more
+than the specified number of seconds. This behavior is always present,
+whether -timeout is specified or not.