aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-18 21:05:53 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-18 21:05:53 +0000
commit5c0834bd1bc5660b5c11f55977b2ab5f3e747e59 (patch)
tree9852518a2e2f6eb1e7a6f38029c2282c7d12abea /x11
parentede8070bcdee4ce278e9c2ff2ec2bdc51ecd27b9 (diff)
downloadports-5c0834bd1bc5660b5c11f55977b2ab5f3e747e59.tar.gz
ports-5c0834bd1bc5660b5c11f55977b2ab5f3e747e59.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/mate-desktop/Makefile11
-rw-r--r--x11/mate-desktop/pkg-plist2
-rw-r--r--x11/mate-menus/Makefile10
-rw-r--r--x11/mate-menus/pkg-plist5
-rw-r--r--x11/mate-panel/Makefile10
-rw-r--r--x11/mate-panel/pkg-plist2
-rw-r--r--x11/mate-screensaver/Makefile4
-rw-r--r--x11/mate-screensaver/pkg-plist1
8 files changed, 20 insertions, 25 deletions
diff --git a/x11/mate-desktop/Makefile b/x11/mate-desktop/Makefile
index a797a0b8fe9a..7989f7b0225a 100644
--- a/x11/mate-desktop/Makefile
+++ b/x11/mate-desktop/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mate-desktop
PORTVERSION= 1.6.1
+PORTREVISION= 1
CATEGORIES= x11 mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -15,14 +16,12 @@ LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
PORTSCOUT= limitw:1,even
-USES= bison gettext gmake pathfix pkgconfig
-USE_XZ= yes
+USES= bison gettext gmake libtool pathfix pkgconfig tar:xz
USE_MATE= docutils
USE_XORG= x11 xrandr
-USE_GNOME= gnomehier gdkpixbuf2 glib20 gtk20 intlhack ltverhack
+USE_GNOME= gnomehier gdkpixbuf2 glib20 gtk20 intlhack
USE_PYTHON= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk=2.0 \
--disable-gtk-doc \
@@ -30,6 +29,7 @@ CONFIGURE_ARGS= --with-gtk=2.0 \
--disable-desktop-docs
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.mate.accessibility-keyboard.gschema.xml \
org.mate.accessibility-startup.gschema.xml \
@@ -49,7 +49,4 @@ GLIB_SCHEMAS= org.mate.accessibility-keyboard.gschema.xml \
org.mate.thumbnailers.gschema.xml \
org.mate.typing-break.gschema.xml
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmate-desktop-2.so.17
-
.include <bsd.port.mk>
diff --git a/x11/mate-desktop/pkg-plist b/x11/mate-desktop/pkg-plist
index 70c156cc6e77..c58ebf22da8a 100644
--- a/x11/mate-desktop/pkg-plist
+++ b/x11/mate-desktop/pkg-plist
@@ -8,9 +8,9 @@ include/mate-desktop-2.0/libmateui/mate-rr-config.h
include/mate-desktop-2.0/libmateui/mate-rr-labeler.h
include/mate-desktop-2.0/libmateui/mate-rr.h
lib/libmate-desktop-2.a
-lib/libmate-desktop-2.la
lib/libmate-desktop-2.so
lib/libmate-desktop-2.so.17
+lib/libmate-desktop-2.so.17.1.4
libdata/pkgconfig/mate-desktop-2.0.pc
man/man1/mate-about.1.gz
share/MateConf/gsettings/mate-desktop.convert
diff --git a/x11/mate-menus/Makefile b/x11/mate-menus/Makefile
index 1c926554a566..1df944784d72 100644
--- a/x11/mate-menus/Makefile
+++ b/x11/mate-menus/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mate-menus
PORTVERSION= 1.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -13,17 +13,17 @@ COMMENT= Implementation of the FreeDesktop Desktop Menu Spec
PORTSCOUT= limitw:1,even
-USES= gettext gmake pathfix pkgconfig
-USE_XZ= yes
-USE_MATE= autogen common:build intlhack ltverhack
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USE_MATE= autogen common:build intlhack
USE_GNOME= glib20 gnomehier introspection:build
USE_PYTHON= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= aclocal:env autoconf:env automake:env libtool libtoolize:env
+USE_AUTOTOOLS= aclocal:env autoconf:env automake:env libtoolize:env
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PATHFIX_MAKEFILEIN= Makefile.*
+INSTALL_TARGET= install-strip
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share/mate|${LOCALBASE}/share/mate|g' \
diff --git a/x11/mate-menus/pkg-plist b/x11/mate-menus/pkg-plist
index 346a4e8759d2..534a32f286b2 100644
--- a/x11/mate-menus/pkg-plist
+++ b/x11/mate-menus/pkg-plist
@@ -1,13 +1,12 @@
etc/xdg/menus/mate-applications.menu
etc/xdg/menus/mate-settings.menu
include/mate-menus/matemenu-tree.h
+lib/girepository-1.0/MateMenu-2.0.typelib
lib/libmate-menu.a
-lib/libmate-menu.la
lib/libmate-menu.so
lib/libmate-menu.so.2
-lib/girepository-1.0/MateMenu-2.0.typelib
+lib/libmate-menu.so.2.4.9
%%PYTHON_SITELIBDIR%%/matemenu.a
-%%PYTHON_SITELIBDIR%%/matemenu.la
%%PYTHON_SITELIBDIR%%/matemenu.so
libdata/pkgconfig/libmate-menu.pc
share/gir-1.0/MateMenu-2.0.gir
diff --git a/x11/mate-panel/Makefile b/x11/mate-panel/Makefile
index cf1f5acbee7e..0092fed196e6 100644
--- a/x11/mate-panel/Makefile
+++ b/x11/mate-panel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mate-panel
PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -17,16 +17,14 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
PORTSCOUT= limitw:1,even
-USES= gettext gmake pathfix pkgconfig
-USE_XZ= yes
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
USE_MATE= desktop docutils libmateweather libmatewnck menus
USE_XORG= ice sm x11 xau xrandr
USE_GNOME= cairo dconf gdkpixbuf2 glib20 gnomehier gtk20 \
- intlhack introspection:build librsvg2 ltverhack pango
+ intlhack introspection:build librsvg2 pango
USE_PYTHON= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-network-manager \
--disable-gtk-doc \
@@ -35,6 +33,7 @@ CONFIGURE_ARGS= --disable-network-manager \
INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
+INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.mate.panel.applet.clock.gschema.xml \
org.mate.panel.applet.fish.gschema.xml \
@@ -47,6 +46,5 @@ GLIB_SCHEMAS= org.mate.panel.applet.clock.gschema.xml \
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/mate-panel/modules
- @${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/libmate-panel-applet-4.so.1
.include <bsd.port.mk>
diff --git a/x11/mate-panel/pkg-plist b/x11/mate-panel/pkg-plist
index 320d5e84122d..9061ffd46a17 100644
--- a/x11/mate-panel/pkg-plist
+++ b/x11/mate-panel/pkg-plist
@@ -6,9 +6,9 @@ include/mate-panel-4.0/libmate-panel-applet/mate-panel-applet-gsettings.h
include/mate-panel-4.0/libmate-panel-applet/mate-panel-applet.h
lib/girepository-1.0/MatePanelApplet-4.0.typelib
lib/libmate-panel-applet-4.a
-lib/libmate-panel-applet-4.la
lib/libmate-panel-applet-4.so
lib/libmate-panel-applet-4.so.1
+lib/libmate-panel-applet-4.so.1.0.1
lib/mate-panel/clock-applet
lib/mate-panel/fish-applet
lib/mate-panel/notification-area-applet
diff --git a/x11/mate-screensaver/Makefile b/x11/mate-screensaver/Makefile
index ec098d48bb57..9c2cdcb5de65 100644
--- a/x11/mate-screensaver/Makefile
+++ b/x11/mate-screensaver/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mate-screensaver
PORTVERSION= 1.6.1
+PORTREVISION= 1
CATEGORIES= x11 mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -16,9 +17,8 @@ LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
PORTSCOUT= limitw:1,even
-USES= gettext gmake pathfix pkgconfig
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
USE_GL= gl
-USE_XZ= yes
USE_MATE= desktop libmatekbd menus
USE_XORG= ice sm x11 xext xtst xxf86misc xxf86vm xscrnsaver
USE_GNOME= glib20 gnomehier gtk20 intlhack
diff --git a/x11/mate-screensaver/pkg-plist b/x11/mate-screensaver/pkg-plist
index c6b5d5637a20..fdb8fa3cbc22 100644
--- a/x11/mate-screensaver/pkg-plist
+++ b/x11/mate-screensaver/pkg-plist
@@ -165,5 +165,6 @@ share/pixmaps/mate-logo-white.svg
@dirrmtry share/desktop-directories
@dirrmtry share/backgrounds/cosmos
@dirrmtry share/backgrounds
+@dirrmtry share/applications/screensavers
@dirrm libexec/mate-screensaver
@dirrmtry etc/xdg/menus