aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorDejan Lesjak <lesi@FreeBSD.org>2005-03-18 20:30:04 +0000
committerDejan Lesjak <lesi@FreeBSD.org>2005-03-18 20:30:04 +0000
commita28953dc2d173c9d923c1ca57d3cd76fe74ed188 (patch)
tree595ad1e836116a7629ba5f3b1c1f7a9971963f25 /x11
parent4b8ba5ca0585617b82c8e97b82814f7d6e0ae727 (diff)
downloadports-a28953dc2d173c9d923c1ca57d3cd76fe74ed188.tar.gz
ports-a28953dc2d173c9d923c1ca57d3cd76fe74ed188.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/libICE/Makefile10
-rw-r--r--x11/libICE/pkg-plist1
-rw-r--r--x11/libSM/Makefile10
-rw-r--r--x11/libSM/pkg-plist1
-rw-r--r--x11/libXcursor/Makefile10
-rw-r--r--x11/libXcursor/pkg-plist1
-rw-r--r--x11/libXfont/Makefile10
-rw-r--r--x11/libXfont/pkg-plist1
-rw-r--r--x11/panoramixext/Makefile10
-rw-r--r--x11/panoramixext/pkg-plist1
-rw-r--r--x11/printext/Makefile11
-rw-r--r--x11/printext/pkg-plist1
-rw-r--r--x11/randrext/Makefile10
-rw-r--r--x11/randrext/pkg-plist1
-rw-r--r--x11/renderext/Makefile10
-rw-r--r--x11/renderext/pkg-plist1
-rw-r--r--x11/resourceext/Makefile10
-rw-r--r--x11/resourceext/pkg-plist1
-rw-r--r--x11/xextensions/Makefile10
-rw-r--r--x11/xextensions/pkg-plist1
20 files changed, 101 insertions, 10 deletions
diff --git a/x11/libICE/Makefile b/x11/libICE/Makefile
index 37c8671d24cb..54804bc1d7c7 100644
--- a/x11/libICE/Makefile
+++ b/x11/libICE/Makefile
@@ -29,4 +29,12 @@ USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/libICE/pkg-plist b/x11/libICE/pkg-plist
index 1cd16b2ffaba..70f3203b41b7 100644
--- a/x11/libICE/pkg-plist
+++ b/x11/libICE/pkg-plist
@@ -10,3 +10,4 @@ lib/libICE.la
lib/libICE.so
lib/libICE.so.6
libdata/pkgconfig/ice.pc
+%%NEWMTREE%%@dirrm include/X11/ICE
diff --git a/x11/libSM/Makefile b/x11/libSM/Makefile
index f092977a6c65..50fbc75f42a4 100644
--- a/x11/libSM/Makefile
+++ b/x11/libSM/Makefile
@@ -29,4 +29,12 @@ USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/libSM/pkg-plist b/x11/libSM/pkg-plist
index aebcd74ac57b..9facfbb580a0 100644
--- a/x11/libSM/pkg-plist
+++ b/x11/libSM/pkg-plist
@@ -6,3 +6,4 @@ lib/libSM.la
lib/libSM.so
lib/libSM.so.6
libdata/pkgconfig/sm.pc
+%%NEWMTREE%%@dirrm include/X11/SM
diff --git a/x11/libXcursor/Makefile b/x11/libXcursor/Makefile
index 59e0b37fd97b..2409ff398345 100644
--- a/x11/libXcursor/Makefile
+++ b/x11/libXcursor/Makefile
@@ -35,4 +35,12 @@ MAN3= Xcursor.3
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/libXcursor/pkg-plist b/x11/libXcursor/pkg-plist
index bfbe4c49ada2..e48cebfa64ae 100644
--- a/x11/libXcursor/pkg-plist
+++ b/x11/libXcursor/pkg-plist
@@ -4,3 +4,4 @@ lib/libXcursor.la
lib/libXcursor.so
lib/libXcursor.so.1
libdata/pkgconfig/xcursor.pc
+%%NEWMTREE%%@dirrm include/X11/Xcursor
diff --git a/x11/libXfont/Makefile b/x11/libXfont/Makefile
index c469f839c602..f539d17cf1d9 100644
--- a/x11/libXfont/Makefile
+++ b/x11/libXfont/Makefile
@@ -28,4 +28,12 @@ CONFIGURE_ARGS= --enable-freetype
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/libXfont/pkg-plist b/x11/libXfont/pkg-plist
index 9f5fdb9a1c25..e3a1735d1674 100644
--- a/x11/libXfont/pkg-plist
+++ b/x11/libXfont/pkg-plist
@@ -13,3 +13,4 @@ lib/libXfont.la
lib/libXfont.so
lib/libXfont.so.1
libdata/pkgconfig/xfont.pc
+%%NEWMTREE%%@dirrm include/X11/fonts
diff --git a/x11/panoramixext/Makefile b/x11/panoramixext/Makefile
index dd18038b3917..70067598b5ac 100644
--- a/x11/panoramixext/Makefile
+++ b/x11/panoramixext/Makefile
@@ -22,4 +22,12 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_GNOME= gnomehack
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/panoramixext/pkg-plist b/x11/panoramixext/pkg-plist
index aa2cf3c67f11..07eea2b5f045 100644
--- a/x11/panoramixext/pkg-plist
+++ b/x11/panoramixext/pkg-plist
@@ -1,3 +1,4 @@
include/X11/extensions/panoramiXext.h
include/X11/extensions/panoramiXproto.h
libdata/pkgconfig/panoramixext.pc
+%%NEWMTREE%%@unexec rmdir %D/include/X11/extensions 2>/dev/null || true
diff --git a/x11/printext/Makefile b/x11/printext/Makefile
index a445056b7be6..f3a7aee0048e 100644
--- a/x11/printext/Makefile
+++ b/x11/printext/Makefile
@@ -27,7 +27,16 @@ NO_BUILD= yes
DEST=${PREFIX}/include/X11/extensions
do-install:
+ ${MKDIR} ${DEST}
${INSTALL_DATA} ${WRKSRC}/Print.h ${DEST}
${INSTALL_DATA} ${WRKSRC}/Printstr.h ${DEST}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/printext/pkg-plist b/x11/printext/pkg-plist
index 8b1ac7295114..1b313ce50faf 100644
--- a/x11/printext/pkg-plist
+++ b/x11/printext/pkg-plist
@@ -1,2 +1,3 @@
include/X11/extensions/Print.h
include/X11/extensions/Printstr.h
+%%NEWMTREE%%@unexec rmdir %D/include/X11/extensions 2>/dev/null || true
diff --git a/x11/randrext/Makefile b/x11/randrext/Makefile
index 0100ed2092d3..73b4dcd1e0ff 100644
--- a/x11/randrext/Makefile
+++ b/x11/randrext/Makefile
@@ -22,4 +22,12 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
NO_BUILD= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/randrext/pkg-plist b/x11/randrext/pkg-plist
index 2ecaf1511edf..1b90cc35b183 100644
--- a/x11/randrext/pkg-plist
+++ b/x11/randrext/pkg-plist
@@ -3,3 +3,4 @@ include/X11/extensions/randrproto.h
libdata/pkgconfig/randr.pc
%%DOCSDIR%%/protocol
@dirrm %%DOCSDIR%%
+%%NEWMTREE%%@unexec rmdir %D/include/X11/extensions 2>/dev/null || true
diff --git a/x11/renderext/Makefile b/x11/renderext/Makefile
index ca4b5a2b099b..4ef86b0c7e80 100644
--- a/x11/renderext/Makefile
+++ b/x11/renderext/Makefile
@@ -23,4 +23,12 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/renderext/pkg-plist b/x11/renderext/pkg-plist
index 812c1f146733..3aa1fa5a134e 100644
--- a/x11/renderext/pkg-plist
+++ b/x11/renderext/pkg-plist
@@ -4,3 +4,4 @@ libdata/pkgconfig/render.pc
%%DOCSDIR%%/library
%%DOCSDIR%%/protocol
@dirrm %%DOCSDIR%%
+%%NEWMTREE%%@unexec rmdir %D/include/X11/extensions 2>/dev/null || true
diff --git a/x11/resourceext/Makefile b/x11/resourceext/Makefile
index 7cfa50a222e8..c82986ec7468 100644
--- a/x11/resourceext/Makefile
+++ b/x11/resourceext/Makefile
@@ -24,4 +24,12 @@ USE_GMAKE= yes
NO_BUILD= yes
USE_GNOME= gnomehack
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/resourceext/pkg-plist b/x11/resourceext/pkg-plist
index 17abb504967a..c799fc83f252 100644
--- a/x11/resourceext/pkg-plist
+++ b/x11/resourceext/pkg-plist
@@ -1,2 +1,3 @@
include/X11/extensions/XResproto.h
libdata/pkgconfig/resourceext.pc
+%%NEWMTREE%%@unexec rmdir %D/include/X11/extensions 2>/dev/null || true
diff --git a/x11/xextensions/Makefile b/x11/xextensions/Makefile
index 3907fdea0c03..10de5b88c80b 100644
--- a/x11/xextensions/Makefile
+++ b/x11/xextensions/Makefile
@@ -26,4 +26,12 @@ USE_GMAKE= yes
NO_BUILD= yes
USE_GNOME= gnomehack
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/xextensions/pkg-plist b/x11/xextensions/pkg-plist
index 1ca1ee624999..98bfc8c3fd5e 100644
--- a/x11/xextensions/pkg-plist
+++ b/x11/xextensions/pkg-plist
@@ -52,3 +52,4 @@ include/X11/extensions/xtestext1.h
include/X11/extensions/xteststr.h
libdata/pkgconfig/xextensions.pc
@dirrm share/doc/xextensions
+%%NEWMTREE%%@unexec rmdir %D/include/X11/extensions 2>/dev/null || true