aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-07-01 09:35:34 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-07-01 09:35:34 +0000
commitc20b634c6fad92bfce55db212ca71eadd459712a (patch)
tree09a606e896dfc3928cd878e8f04aa5a1932b92f2 /x11
parent67859d23fd949d96a0710f2f97d03608916fae83 (diff)
downloadports-c20b634c6fad92bfce55db212ca71eadd459712a.tar.gz
ports-c20b634c6fad92bfce55db212ca71eadd459712a.zip
Update to version 1.0.3 (now requires GNU make to build).
Reported by: portscout
Notes
Notes: svn path=/head/; revision=505560
Diffstat (limited to 'x11')
-rw-r--r--x11/hsetroot/Makefile6
-rw-r--r--x11/hsetroot/distinfo6
-rw-r--r--x11/hsetroot/files/patch-Makefile20
3 files changed, 12 insertions, 20 deletions
diff --git a/x11/hsetroot/Makefile b/x11/hsetroot/Makefile
index 6f230cdc2967..8c61a4c293d2 100644
--- a/x11/hsetroot/Makefile
+++ b/x11/hsetroot/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= hsetroot
-PORTVERSION= 1.0.2
-PORTREVISION= 14
+PORTVERSION= 1.0.3
CATEGORIES= x11
MAINTAINER= danfe@FreeBSD.org
@@ -16,9 +15,8 @@ RUN_DEPENDS= xrandr:x11/xrandr
USE_GITHUB= yes
GH_ACCOUNT= himdel
-GH_TAGNAME= 47d887b
-USES= pkgconfig
+USES= gmake pkgconfig
USE_XORG= x11
PLIST_FILES= bin/hsetroot
diff --git a/x11/hsetroot/distinfo b/x11/hsetroot/distinfo
index a0852829ea3c..09a0cf0f2ea2 100644
--- a/x11/hsetroot/distinfo
+++ b/x11/hsetroot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1455408551
-SHA256 (himdel-hsetroot-1.0.2-47d887b_GH0.tar.gz) = 5d84b6f34e9c6d2e33a6bbe7a41be5b3100782603b1a4b07e8705a204b39d9be
-SIZE (himdel-hsetroot-1.0.2-47d887b_GH0.tar.gz) = 5827
+TIMESTAMP = 1561725415
+SHA256 (himdel-hsetroot-1.0.3_GH0.tar.gz) = ab40a7723080f72bbaf55be546c62f69d5e73d3ccdfa8bb7b6995e8c1798242a
+SIZE (himdel-hsetroot-1.0.3_GH0.tar.gz) = 6509
diff --git a/x11/hsetroot/files/patch-Makefile b/x11/hsetroot/files/patch-Makefile
index 042418fa0368..c50e99880d5c 100644
--- a/x11/hsetroot/files/patch-Makefile
+++ b/x11/hsetroot/files/patch-Makefile
@@ -1,28 +1,22 @@
---- Makefile.orig 2016-02-14 00:09:11 UTC
+--- Makefile.orig 2019-06-28 12:36:55 UTC
+++ Makefile
-@@ -1,4 +1,4 @@
--CC=gcc
-+CC?=gcc
-
- CFLAGS?=-g -O2 -Wall
- LDFLAGS?=
-@@ -9,14 +9,17 @@ LDFLAGS+=`pkg-config x11 --libs`
- CFLAGS+=`pkg-config imlib2 --cflags`
- LDFLAGS+=`pkg-config imlib2 --libs`
+@@ -18,16 +18,16 @@ LDFLAGS+=$(shell $(PKG_CONFIG) x11 --libs)
+ CFLAGS+=$(shell $(PKG_CONFIG) imlib2 --cflags)
+ LDFLAGS+=$(shell $(PKG_CONFIG) imlib2 --libs)
+all: hsetroot
+
hsetroot: hsetroot.o outputs_xrandr.o
-+ $(CC) $(LDFLAGS) -o $@ $>
hsetroot.o: hsetroot.c outputs.h
-outputs.o: outputs.c outputs.h
-+outputs_xrandr.o: outputs_xrandr.c outputs.h
+-
+ outputs_xrandr.o: outputs_xrandr.c outputs.h
install: hsetroot
- install -st /usr/local/bin/ hsetroot
-+ $(BSD_INSTALL_PROGRAM) $> $(DESTDIR)$(PREFIX)/bin
++ $(BSD_INSTALL_PROGRAM) $^ $(DESTDIR)$(PREFIX)/bin
clean:
rm -f hsetroot *.o