aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-05-31 14:49:26 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-05-31 14:49:26 +0000
commitebb04f49c21a7da2953675b331eb7c9b1cb7d35b (patch)
tree334e2b5d414b5b4e2d6139fd6873cb1dfd72552a /x11
parent1884ff8c5075f3e906d1bd2d422dba3269b523d8 (diff)
downloadports-ebb04f49c21a7da2953675b331eb7c9b1cb7d35b.tar.gz
ports-ebb04f49c21a7da2953675b331eb7c9b1cb7d35b.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/fbdesk/Makefile15
-rw-r--r--x11/ggiterm/Makefile7
2 files changed, 12 insertions, 10 deletions
diff --git a/x11/fbdesk/Makefile b/x11/fbdesk/Makefile
index f2880127bf62..7791119678fe 100644
--- a/x11/fbdesk/Makefile
+++ b/x11/fbdesk/Makefile
@@ -19,7 +19,8 @@ LICENSE= MIT
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
-OPTIONS= IMLIB2 "Imlib2 (pixmap themes) support" On
+OPTIONS_DEFINE= IMLIB2 DOCS
+OPTIONS_DEFAULT= IMLIB2
USE_XORG= xext xft xpm xrender
WANT_EFL= yes
@@ -29,20 +30,20 @@ MAKE_JOBS_SAFE= yes
PORTDOCS= ChangeLog INSTALL README
PLIST_FILES= bin/fbdesk
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_IMLIB2)
-CONFIGURE_ARGS+= --disable-imlib2
-.else
+.if ${PORT_OPTIONS:MIMLIB2}
USE_EFL+= imlib2
+.else
+CONFIGURE_ARGS+= --disable-imlib2
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/ggiterm/Makefile b/x11/ggiterm/Makefile
index 6bf69c2db63e..a58d3070ee7e 100644
--- a/x11/ggiterm/Makefile
+++ b/x11/ggiterm/Makefile
@@ -24,7 +24,8 @@ LDFLAGS+= ${PTHREAD_LIBS}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SUB_FILES= pkg-message
-OPTIONS= FREETYPE "Build with Freetype support" on
+OPTIONS_DEFINE= FREETYPE DOCS
+OPTIONS_DEFAULT= FREETYPE
PORTDOCS= AUTHORS README
@@ -34,7 +35,7 @@ PORTDOCS= AUTHORS README
BROKEN= fails to build with new utmpx
.endif
-.if !defined(WITHOUT_FREETYPE)
+.if ${PORT_OPTIONS:MFREETYPE}
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
USE_ICONV= yes
CONFIGURE_ARGS+=--with-ft-prefix=${LOCALBASE}
@@ -46,7 +47,7 @@ MAN1= ggiterm.1
post-install:
@${INSTALL_DATA} ${WRKSRC}/ggiterm.termcap ${DATADIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}