aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-04 20:04:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-04 20:04:38 +0000
commit437140d5ee7767647a4a8852a15ec4a5795de676 (patch)
tree2443a6cb032d8f429ce900c305a7375c8e455d9e /x11
parente4a16c160872cdf202f5fc612a2542966e0ac3af (diff)
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/qt4-inputmethods/Makefile1
-rw-r--r--x11/qt4-inputmethods/distinfo6
-rw-r--r--x11/qt4-opengl/Makefile4
-rw-r--r--x11/qt4-opengl/distinfo6
-rw-r--r--x11/qt4-opengl/pkg-plist8
5 files changed, 16 insertions, 9 deletions
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
index bf080ba6cd91..8d1e80aaffbb 100644
--- a/x11/qt4-inputmethods/Makefile
+++ b/x11/qt4-inputmethods/Makefile
@@ -22,6 +22,7 @@ USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build corelib gui
QT_NONSTANDARD= yes
QT_DIST= yes
+MAKE_JOBS_SAFE= yes
HAS_CONFIGURE= yes
diff --git a/x11/qt4-inputmethods/distinfo b/x11/qt4-inputmethods/distinfo
index 1756af8b04d9..27b0949354e8 100644
--- a/x11/qt4-inputmethods/distinfo
+++ b/x11/qt4-inputmethods/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 376c003317c4417326ba2116370227d0
-SHA256 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 79ea9fb46d75c3759e3e98ab0064a47eaa5bdbbc2a53d923d60bd8e9cd0bc5c6
-SIZE (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 112939803
+MD5 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = d8bcc070a58db25c228b7729ffad4550
+SHA256 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 4e4c8619335cac14ba0c52d1555fab549a562fb774c1c08dcbd2be9de38120a2
+SIZE (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 125803421
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index ab1fe269efac..0e5fd03abf36 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -8,6 +8,7 @@
PORTNAME= opengl
PORTVERSION= ${QT4_VERSION}
+PORTREVISION=0
CATEGORIES?= x11
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -26,6 +27,7 @@ HAS_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/lib/qt4
USE_GL= glu
USE_XORG= x11
+MAKE_JOBS_SAFE= yes
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
@@ -45,6 +47,8 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
+CONFIGURE_ARGS+= -I../../include/Qt -I../../include
+
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${MKDIR} ${WRKSRC}/../../mkspecs
diff --git a/x11/qt4-opengl/distinfo b/x11/qt4-opengl/distinfo
index 1756af8b04d9..27b0949354e8 100644
--- a/x11/qt4-opengl/distinfo
+++ b/x11/qt4-opengl/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 376c003317c4417326ba2116370227d0
-SHA256 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 79ea9fb46d75c3759e3e98ab0064a47eaa5bdbbc2a53d923d60bd8e9cd0bc5c6
-SIZE (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 112939803
+MD5 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = d8bcc070a58db25c228b7729ffad4550
+SHA256 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 4e4c8619335cac14ba0c52d1555fab549a562fb774c1c08dcbd2be9de38120a2
+SIZE (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 125803421
diff --git a/x11/qt4-opengl/pkg-plist b/x11/qt4-opengl/pkg-plist
index 3e75ee660e2f..90b1da42fde6 100644
--- a/x11/qt4-opengl/pkg-plist
+++ b/x11/qt4-opengl/pkg-plist
@@ -3,6 +3,7 @@ include/qt4/Qt/qgl.h
include/qt4/Qt/qglcolormap.h
include/qt4/Qt/qglframebufferobject.h
include/qt4/Qt/qglpixelbuffer.h
+include/qt4/Qt/glgc_shader_source.h
include/qt4/QtOpenGL/QGLColormap
include/qt4/QtOpenGL/QGLContext
include/qt4/QtOpenGL/QGLFormat
@@ -18,13 +19,14 @@ include/qt4/QtOpenGL/qgl.h
include/qt4/QtOpenGL/qglcolormap.h
include/qt4/QtOpenGL/qglframebufferobject.h
include/qt4/QtOpenGL/qglpixelbuffer.h
+include/qt4/QtOpenGL/glgc_shader_source.h
lib/qt4/libQtOpenGL.la
lib/qt4/libQtOpenGL.prl
lib/qt4/libQtOpenGL.so
lib/qt4/libQtOpenGL.so.4
-lib/qt4/libQtOpenGL.so.4.4
-lib/qt4/libQtOpenGL.so.4.4.3
-%%DEBUG%%lib/qt4/libQtOpenGL.so.4.4.3.debug
+lib/qt4/libQtOpenGL.so.4.5
+lib/qt4/libQtOpenGL.so.4.5.2
+%%DEBUG%%lib/qt4/libQtOpenGL.so.4.5.2.debug
libdata/pkgconfig/QtOpenGL.pc
@dirrm include/qt4/QtOpenGL
@dirrmtry include/qt4/Qt