aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2017-12-07 09:46:41 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2017-12-07 09:46:41 +0000
commit64b3db6963eff8699b3b79820daac71a3815b06b (patch)
tree9e0a99470783b9c28877b8a794a486a12e46b26e /x11
parenta706b97cb68d54f801de869ac47c2b5810a8436f (diff)
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/tilda/Makefile1
-rw-r--r--x11/tilda/files/patch-tilda.c13
2 files changed, 12 insertions, 2 deletions
diff --git a/x11/tilda/Makefile b/x11/tilda/Makefile
index 320587d5e7e4..f91da3c5d2a6 100644
--- a/x11/tilda/Makefile
+++ b/x11/tilda/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tilda
PORTVERSION= 1.3.3
DISTVERSIONPREFIX= ${PORTNAME}-
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= rodrigo@FreeBSD.org
diff --git a/x11/tilda/files/patch-tilda.c b/x11/tilda/files/patch-tilda.c
index 87f7cca00a83..c215f05d14d5 100644
--- a/x11/tilda/files/patch-tilda.c
+++ b/x11/tilda/files/patch-tilda.c
@@ -1,5 +1,5 @@
---- src/tilda.c.orig 2015-12-16 12:11:58 UTC
-+++ src/tilda.c
+--- src/tilda.c.orig 2017-09-08 22:19:35.318278000 +0300
++++ src/tilda.c 2017-09-08 22:21:22.752550000 +0300
@@ -12,6 +12,7 @@
* You should have received a copy of the GNU Library General Public
* License along with this library. If not, see <http://www.gnu.org/licenses/>.
@@ -8,3 +8,12 @@
#define _POSIX_SOURCE /* feature test macro for signal functions */
#define _XOPEN_SOURCE /* feature test macro for popen */
+@@ -230,7 +231,7 @@
+ static GSList *getPids() {
+ GSList *pids = NULL;
+ FILE *ps_output;
+- const gchar ps_command[] = "ps -C tilda -o pid=";
++ const gchar ps_command[] = "pgrep tilda";
+ gchar buf[16]; /* Really shouldn't need more than 6 */
+
+ if ((ps_output = popen (ps_command, "r")) == NULL) {