aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2006-03-20 00:11:46 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2006-03-20 00:11:46 +0000
commitd596967f05064e534f274494716f61ea5e4425ca (patch)
tree1aaa8d2f232988a5f8578ac4f7331566447681f4 /x11
parent2129ef23f1c7edb98496699cf9ff00b1c84866ee (diff)
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libsynaptics/Makefile24
-rw-r--r--x11/libsynaptics/distinfo3
-rw-r--r--x11/libsynaptics/pkg-descr7
-rw-r--r--x11/libsynaptics/pkg-plist12
5 files changed, 47 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 311ebc2c863f..a8781f46841b 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -124,6 +124,7 @@
SUBDIR += libgnomemm
SUBDIR += libgnomemm26
SUBDIR += libsx
+ SUBDIR += libsynaptics
SUBDIR += libxfce4mcs
SUBDIR += libxfce4util
SUBDIR += libxkbfile
diff --git a/x11/libsynaptics/Makefile b/x11/libsynaptics/Makefile
new file mode 100644
index 000000000000..470b3105815f
--- /dev/null
+++ b/x11/libsynaptics/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: libsynaptics
+# Date created: Sun Mar 19 21:20:25 CET 2006
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsynaptics
+PORTVERSION= 0.14.4d
+CATEGORIES= x11
+MASTER_SITES= http://qsynaptics.sourceforge.net/
+
+MAINTAINER= markus@FreeBSD.org
+COMMENT= Library to access the Xorg/XFree86 Synaptics TouchPad Driver
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/x11/libsynaptics/distinfo b/x11/libsynaptics/distinfo
new file mode 100644
index 000000000000..8afaf5e33f43
--- /dev/null
+++ b/x11/libsynaptics/distinfo
@@ -0,0 +1,3 @@
+MD5 (libsynaptics-0.14.4d.tar.bz2) = 1df76861480200343d7de52237e54249
+SHA256 (libsynaptics-0.14.4d.tar.bz2) = b2b7088d58fabba1d8a1be2ab21b8c8290cf91342e2d66bfe8d7ee09a299fe9d
+SIZE (libsynaptics-0.14.4d.tar.bz2) = 218980
diff --git a/x11/libsynaptics/pkg-descr b/x11/libsynaptics/pkg-descr
new file mode 100644
index 000000000000..10d750a9557c
--- /dev/null
+++ b/x11/libsynaptics/pkg-descr
@@ -0,0 +1,7 @@
+libsynaptics is a library to access the Xorg/XFree86 Synaptics TouchPad
+Driver. Programs that want to access the touchpad should make use of this
+library and will thereby not interfere with each other. Available parameters
+can be read and written and the version of the installed driver can be
+determined.
+
+WWW: http://qsynaptics.sourceforge.net/
diff --git a/x11/libsynaptics/pkg-plist b/x11/libsynaptics/pkg-plist
new file mode 100644
index 000000000000..324b447e979b
--- /dev/null
+++ b/x11/libsynaptics/pkg-plist
@@ -0,0 +1,12 @@
+include/synaptics/Shm_0_14_4
+include/synaptics/pad.h
+include/synaptics/synaptics.h
+include/synaptics/syndebug.h
+include/synaptics/synparams.h
+include/synaptics/synshm.h
+include/synaptics/version.h
+lib/libsynaptics.a
+lib/libsynaptics.la
+lib/libsynaptics.so
+lib/libsynaptics.so.0
+@dirrm include/synaptics