aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-06-19 14:08:34 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-06-19 14:08:34 +0000
commit2af5bc22297961e6ed3857407fab98f3b4460090 (patch)
tree65bf4ec8977b421687e74ccbc7ab04fd2023cb2a /x11
parent45e461a4b567154f88557ab63f5a70c26049ac24 (diff)
downloadports-2af5bc22297961e6ed3857407fab98f3b4460090.tar.gz
ports-2af5bc22297961e6ed3857407fab98f3b4460090.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/flruler/Makefile46
-rw-r--r--x11/flruler/distinfo3
-rw-r--r--x11/flruler/files/patch-Makefile30
-rw-r--r--x11/flruler/pkg-descr9
5 files changed, 89 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 9819d76090e8..560e7eeff604 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -66,6 +66,7 @@
SUBDIR += fireflies
SUBDIR += fixesproto
SUBDIR += florence
+ SUBDIR += flruler
SUBDIR += fluxbg
SUBDIR += fpc-x11
SUBDIR += fstobdf
diff --git a/x11/flruler/Makefile b/x11/flruler/Makefile
new file mode 100644
index 000000000000..daf9005da4cb
--- /dev/null
+++ b/x11/flruler/Makefile
@@ -0,0 +1,46 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= flruler
+PORTVERSION= 1.05
+CATEGORIES= x11
+MASTER_SITES= http://seriss.com/people/erco/fltk/flruler/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= On-screen pixel ruler
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libfltk.a:x11-toolkits/fltk
+
+USES= gmake perl5
+USE_PERL5= build
+USE_XORG= x11 xcursor xext xfixes xft xinerama
+
+PLIST_FILES= bin/flruler man/man1/flruler.1.gz \
+ share/icons/hicolor/128x128/apps/flruler.png
+PORTDOCS= *
+
+DESKTOP_ENTRIES= "Flruler" "${COMMENT}" "${PORTNAME}.png" \
+ "${PORTNAME}" "Utility;" false
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+# New windows won't get created with zero width and height for some reason
+ @${REINPLACE_CMD} -e 's/,0,0/,1,1/' ${WRKSRC}/flruler.C
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/docs/${PORTNAME}.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/128x128/apps
+ ${INSTALL_DATA} ${WRKSRC}/misc/flruler-icon.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/128x128/apps/${PORTNAME}.png
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} CHANGES.txt TODO.txt \
+ docs/${PORTNAME}.html ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11/flruler/distinfo b/x11/flruler/distinfo
new file mode 100644
index 000000000000..70af7fb1c748
--- /dev/null
+++ b/x11/flruler/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470190812
+SHA256 (flruler-1.05.tar.gz) = ece02a65bb408eaa83e46e0359bb1d8c07852b331f6f59975d8ae06c7197faaf
+SIZE (flruler-1.05.tar.gz) = 25842
diff --git a/x11/flruler/files/patch-Makefile b/x11/flruler/files/patch-Makefile
new file mode 100644
index 000000000000..2026b700cfa5
--- /dev/null
+++ b/x11/flruler/files/patch-Makefile
@@ -0,0 +1,30 @@
+--- Makefile.orig 2016-08-03 02:19:58 UTC
++++ Makefile
+@@ -2,15 +2,13 @@
+ SHELL=/bin/sh
+ VERSION=$(shell awk '/^[0-9]*\.[^ \t]/ {print $$1; exit(0);}' CHANGES.txt)
+
+-FLTK_DIR=/usr/local/src/fltk-1.3.x-svn
+-
+ # FLTK BUILD
+-CXX = $(shell $(FLTK_DIR)/fltk-config --cxx)
+-CC = $(shell $(FLTK_DIR)/fltk-config --cxx)
++CXX = $(shell fltk-config --cxx)
++CC = $(shell fltk-config --cxx)
+ DEBUG = -g
+-CXXFLAGS = $(shell $(FLTK_DIR)/fltk-config --cxxflags ) -I. -DVERSION=\"$(VERSION)\" -Wall
++CXXFLAGS = $(shell fltk-config --cxxflags ) -I. -DVERSION=\"$(VERSION)\" -Wall
+ CFLAGS = -Wall
+-LDLIBS = $(shell $(FLTK_DIR)/fltk-config --ldstaticflags )
++LDLIBS = $(shell fltk-config --ldstaticflags )
+ LINK = $(CXX)
+ OS = $(shell uname -s)
+
+@@ -30,7 +28,6 @@ all: flruler docs
+
+ flruler: flruler.o
+ $(LINK) flruler.o -o flruler $(LDLIBS)
+- strip flruler
+ ifeq ($(OS),Darwin)
+ echo Creating flruler.app
+ rm -rf flruler.app
diff --git a/x11/flruler/pkg-descr b/x11/flruler/pkg-descr
new file mode 100644
index 000000000000..1022cc79a305
--- /dev/null
+++ b/x11/flruler/pkg-descr
@@ -0,0 +1,9 @@
+A program for measuring the pixel size of on-screen elements. Intended for
+GUI debugging to verify widget separations and sizes, though may also be
+used for general computer graphics debugging purposes, including measuring
+pixel distances of images, web applications, etc.
+
+You can easily make copies of the ruler and reoriented it via either the
+keyboard or mouse.
+
+WWW: http://seriss.com/people/erco/fltk/flruler/