aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2012-06-02 13:12:06 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2012-06-02 13:12:06 +0000
commit841a52b7d5eba54d6cbc5dbdefe808be9ea9f206 (patch)
treef178c09c41552a49ec75fbbce54024c79d2d7ad5 /x11
parent6ad2427b44b6b4a7df91e930e82bf201d8e3f150 (diff)
downloadports-841a52b7d5eba54d6cbc5dbdefe808be9ea9f206.tar.gz
ports-841a52b7d5eba54d6cbc5dbdefe808be9ea9f206.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/mlterm/Makefile22
-rw-r--r--x11/mlterm/distinfo4
-rw-r--r--x11/mlterm/files/patch-kiklib:configure16
-rw-r--r--x11/mlterm/pkg-plist7
4 files changed, 16 insertions, 33 deletions
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 4421f8c87ccf..f90f476ffb56 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= mlterm
-PORTVERSION= 3.1.0
-PORTREVISION= 1
+PORTVERSION= 3.1.2
CATEGORIES= x11
MASTER_SITES= SF/${PORTNAME}/01release/${PORTNAME}-${PORTVERSION}
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Multilingual X11 terminal emulator
-LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
+LIB_DEPENDS= Xft:${PORTSDIR}/x11-fonts/libXft
USE_XORG= sm
USE_GNOME= gtk20 lthack vte
@@ -23,7 +22,7 @@ LIBTOOLFILES= configure kiklib/configure mkf/configure
USE_PERL5_BUILD=yes
USE_GETTEXT= yes
CONFIGURE_ARGS= --with-imagelib=gdk-pixbuf2 --enable-utmp \
- --mandir="${LOCALBASE}/man" --enable-optimize-redrawing \
+ --enable-optimize-redrawing \
--with-tools="mlclient,mlconfig,mlterm-menu,mlcc,w3mmlconfig,mlimgloader" \
--disable-iiimf
CONFIGURE_ENV= LIBS="${LIBS} -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl"
@@ -40,7 +39,7 @@ OPTIONS= FRIBIDI "Use Fribidi for BiDi rendering" off \
.if defined(WITH_FRIBIDI)
CONFIGURE_ARGS+= --enable-fribidi
-LIB_DEPENDS+= fribidi.3:${PORTSDIR}/converters/fribidi
+LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
PLIST_SUB+= FRIBIDI=""
.else
CONFIGURE_ARGS+= --disable-fribidi
@@ -50,7 +49,7 @@ PLIST_SUB+= FRIBIDI="@comment "
.if defined(WITH_UIM)
CONFIGURE_ARGS+= --enable-uim
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
-LIB_DEPENDS+= uim.8:${PORTSDIR}/textproc/uim
+LIB_DEPENDS+= uim:${PORTSDIR}/textproc/uim
PLIST_SUB+= UIM=""
.else
CONFIGURE_ARGS+= --disable-uim
@@ -60,7 +59,7 @@ PLIST_SUB+= UIM="@comment "
.if defined(WITH_M17NLIB)
CONFIGURE_ARGS+= --enable-m17nlib
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
-LIB_DEPENDS+= m17n.4:${PORTSDIR}/devel/m17n-lib
+LIB_DEPENDS+= m17n:${PORTSDIR}/devel/m17n-lib
PLIST_SUB+= M17NLIB=""
.else
CONFIGURE_ARGS+= --disable-m17nlib
@@ -70,7 +69,7 @@ PLIST_SUB+= M17NLIB="@comment "
.if defined(WITH_SCIM)
CONFIGURE_ARGS+= --enable-scim
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
-LIB_DEPENDS+= scim-1.0.10:${PORTSDIR}/textproc/scim
+LIB_DEPENDS+= scim-1.0:${PORTSDIR}/textproc/scim
PLIST_SUB+= SCIM=""
.else
CONFIGURE_ARGS+= --disable-scim
@@ -80,7 +79,7 @@ PLIST_SUB+= SCIM="@comment "
.if defined(WITH_IBUS)
CONFIGURE_ARGS+= --enable-ibus
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
-LIB_DEPENDS+= ibus-1.0.400:${PORTSDIR}/textproc/ibus
+LIB_DEPENDS+= ibus-1.0:${PORTSDIR}/textproc/ibus
PLIST_SUB+= IBUS=""
.else
CONFIGURE_ARGS+= --disable-ibus
@@ -90,19 +89,18 @@ PLIST_SUB+= IBUS="@comment "
.if defined(WITH_CAIRO)
CONFIGURE_ARGS+= --with-type-engines="xcore,xft,cairo"
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
PLIST_SUB+= CAIRO=""
.else
CONFIGURE_ARGS+= --with-type-engines="xcore,xft"
PLIST_SUB+= CAIRO="@comment "
.endif
-
.if ${OSVERSION} >= 900004
MAKE_ENV= LIBS_LOCAL=-lutempter
.else
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
-LIB_DEPENDS+= utempter.0:${PORTSDIR}/sysutils/libutempter
+LIB_DEPENDS+= utempter:${PORTSDIR}/sysutils/libutempter
.endif
USE_LDCONFIG= yes
diff --git a/x11/mlterm/distinfo b/x11/mlterm/distinfo
index 3bbb3044e080..846cb115cbdf 100644
--- a/x11/mlterm/distinfo
+++ b/x11/mlterm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mlterm-3.1.0.tar.gz) = 4c07c74db87f4daf7b513aa3c50a56343c589476519d181e2461b9acfcb1d8a5
-SIZE (mlterm-3.1.0.tar.gz) = 4342792
+SHA256 (mlterm-3.1.2.tar.gz) = f04cb8cb2439020a5ab3c5afd5f1e12bbafa2d94e49014bf03d0a86cbf8a78f0
+SIZE (mlterm-3.1.2.tar.gz) = 4349401
diff --git a/x11/mlterm/files/patch-kiklib:configure b/x11/mlterm/files/patch-kiklib:configure
deleted file mode 100644
index 01d00f5c6f8a..000000000000
--- a/x11/mlterm/files/patch-kiklib:configure
+++ /dev/null
@@ -1,16 +0,0 @@
---- kiklib/configure.orig 2011-01-15 19:55:43.000000000 +0900
-+++ kiklib/configure 2011-01-15 19:57:54.000000000 +0900
-@@ -19928,6 +19928,13 @@
- echo ""
- fi
- fi
-+
-+case $host_os in
-+ freebsd*)
-+ kik_cv_pty=bsd
-+ ;;
-+esac
-+
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $kik_cv_pty" >&5
- $as_echo "$kik_cv_pty" >&6; }
- PTY_NAME="${kik_cv_pty}"
diff --git a/x11/mlterm/pkg-plist b/x11/mlterm/pkg-plist
index e39eb9ed4fd6..0e8b6e033764 100644
--- a/x11/mlterm/pkg-plist
+++ b/x11/mlterm/pkg-plist
@@ -84,9 +84,9 @@ lib/mlterm/libsample2.so
lib/mlterm/libtype_xft.a
lib/mlterm/libtype_xft.la
lib/mlterm/libtype_xft.so
-libexec/mlconfig
-libexec/mlimgloader
-libexec/mlterm-menu
+libexec/mlterm/mlconfig
+libexec/mlterm/mlimgloader
+libexec/mlterm/mlterm-menu
libexec/w3mmlconfig/mlconfig-data.pl
libexec/w3mmlconfig/mlconfig.cgi
%%PORTDOCS%%share/doc/ja/mlterm/README.ja
@@ -98,5 +98,6 @@ share/locale/zh_TW/LC_MESSAGES/mlconfig.mo
@dirrm etc/mlterm
@dirrm lib/mkf
@dirrm lib/mlterm
+@dirrm libexec/mlterm
@dirrm libexec/w3mmlconfig
%%PORTDOCS%%@dirrm share/doc/ja/mlterm