aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2012-12-26 08:43:25 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2012-12-26 08:43:25 +0000
commitcdc53d2309615c02e5ffc542196bb239ba37be3f (patch)
treeaf30c40aced3c04e00bf3f670843bf766c492599 /x11
parent062c9f80397438377a1bba86ccf1639ff485cda8 (diff)
downloadports-cdc53d2309615c02e5ffc542196bb239ba37be3f.tar.gz
ports-cdc53d2309615c02e5ffc542196bb239ba37be3f.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Terminal/Makefile4
-rw-r--r--x11/Terminal/files/patch-Terminal.glade32
-rw-r--r--x11/Terminal/files/patch-terminal__terminal-preferences-dialog.c26
-rw-r--r--x11/Terminal/files/patch-terminal__terminal-preferences.c31
-rw-r--r--x11/Terminal/files/patch-terminal__terminal-private.h17
-rw-r--r--x11/Terminal/files/patch-terminal__terminal-screen.c47
6 files changed, 155 insertions, 2 deletions
diff --git a/x11/Terminal/Makefile b/x11/Terminal/Makefile
index 5d9f3140bea6..92bdb76b195f 100644
--- a/x11/Terminal/Makefile
+++ b/x11/Terminal/Makefile
@@ -1,9 +1,9 @@
-# Created by: Matt Lancereau <ports@FreeBSD.org>
+# Created by: Matt Lancereau
# $FreeBSD$
PORTNAME= Terminal
PORTVERSION= 0.4.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/apps/${PORTNAME:L}/${PORTVERSION:R}
diff --git a/x11/Terminal/files/patch-Terminal.glade b/x11/Terminal/files/patch-Terminal.glade
new file mode 100644
index 000000000000..d2403b82ac43
--- /dev/null
+++ b/x11/Terminal/files/patch-Terminal.glade
@@ -0,0 +1,32 @@
+--- ./Terminal.glade.orig 2011-06-21 20:32:31.000000000 +0000
++++ ./Terminal.glade 2012-12-23 22:33:31.000000000 +0000
+@@ -488,20 +488,6 @@
+ </packing>
+ </child>
+ <child>
+- <object class="GtkCheckButton" id="font-anti-alias">
+- <property name="label" translatable="yes">Enab_le anti-aliasing for the terminal font</property>
+- <property name="visible">True</property>
+- <property name="can_focus">True</property>
+- <property name="receives_default">False</property>
+- <property name="tooltip_text" translatable="yes">Enable this option if you want Terminal to use anti-aliasing when rendering text in terminal windows. Disabling this option can impressively speed up terminal rendering performance and reduce the overall system load on slow systems.</property>
+- <property name="use_underline">True</property>
+- <property name="draw_indicator">True</property>
+- </object>
+- <packing>
+- <property name="position">1</property>
+- </packing>
+- </child>
+- <child>
+ <object class="GtkCheckButton" id="font-allow-bold">
+ <property name="label" translatable="yes">Allow bold te_xt</property>
+ <property name="visible">True</property>
+@@ -512,7 +498,7 @@
+ <property name="draw_indicator">True</property>
+ </object>
+ <packing>
+- <property name="position">2</property>
++ <property name="position">1</property>
+ </packing>
+ </child>
+ </object>
diff --git a/x11/Terminal/files/patch-terminal__terminal-preferences-dialog.c b/x11/Terminal/files/patch-terminal__terminal-preferences-dialog.c
new file mode 100644
index 000000000000..9ab8c62d6261
--- /dev/null
+++ b/x11/Terminal/files/patch-terminal__terminal-preferences-dialog.c
@@ -0,0 +1,26 @@
+--- ./terminal/terminal-preferences-dialog.c.orig 2011-06-21 20:32:31.000000000 +0000
++++ ./terminal/terminal-preferences-dialog.c 2012-12-23 22:37:02.000000000 +0000
+@@ -96,9 +96,6 @@
+ "shortcuts-no-mnemonics", "shortcuts-no-menukey",
+ "binding-backspace", "binding-delete",
+ "background-mode", "background-image-style"
+-#if TERMINAL_HAS_ANTI_ALIAS_SETTING
+- , "font-anti-alias"
+-#endif
+ };
+ const gchar *props_color[] = { "color-foreground", "color-cursor",
+ "color-background", "tab-activity-color",
+@@ -167,13 +164,6 @@
+ BIND_PROPERTIES ("tab-activity-timeout", "value");
+ BIND_PROPERTIES ("background-darkness", "value");
+
+-#if !TERMINAL_HAS_ANTI_ALIAS_SETTING
+- /* hide anti alias setting */
+- object = gtk_builder_get_object (GTK_BUILDER (dialog), "font-anti-alias");
+- terminal_return_if_fail (G_IS_OBJECT (object));
+- gtk_widget_hide (GTK_WIDGET (object));
+-#endif
+-
+ /* reset comparibility button */
+ object = gtk_builder_get_object (GTK_BUILDER (dialog), "reset-compatibility");
+ terminal_return_if_fail (G_IS_OBJECT (object));
diff --git a/x11/Terminal/files/patch-terminal__terminal-preferences.c b/x11/Terminal/files/patch-terminal__terminal-preferences.c
new file mode 100644
index 000000000000..81a72a70d513
--- /dev/null
+++ b/x11/Terminal/files/patch-terminal__terminal-preferences.c
@@ -0,0 +1,31 @@
+--- ./terminal/terminal-preferences.c.orig 2011-06-21 20:32:31.000000000 +0000
++++ ./terminal/terminal-preferences.c 2012-12-23 22:38:40.000000000 +0000
+@@ -101,9 +101,6 @@
+ PROP_COMMAND_UPDATE_RECORDS,
+ PROP_COMMAND_LOGIN_SHELL,
+ PROP_FONT_ALLOW_BOLD,
+-#if TERMINAL_HAS_ANTI_ALIAS_SETTING
+- PROP_FONT_ANTI_ALIAS,
+-#endif
+ PROP_FONT_NAME,
+ PROP_MISC_ALWAYS_SHOW_TABS,
+ PROP_MISC_BELL,
+@@ -980,18 +977,6 @@
+ TRUE,
+ EXO_PARAM_READWRITE));
+
+-#if TERMINAL_HAS_ANTI_ALIAS_SETTING
+- /**
+- * TerminalPreferences:font-anti-alias:
+- **/
+- g_object_class_install_property (gobject_class,
+- PROP_FONT_ANTI_ALIAS,
+- g_param_spec_boolean ("font-anti-alias",
+- "font-anti-alias",
+- "FontAntiAlias",
+- TRUE,
+- EXO_PARAM_READWRITE));
+-#endif
+
+ /**
+ * TerminalPreferences:font-name:
diff --git a/x11/Terminal/files/patch-terminal__terminal-private.h b/x11/Terminal/files/patch-terminal__terminal-private.h
new file mode 100644
index 000000000000..8059c28d4473
--- /dev/null
+++ b/x11/Terminal/files/patch-terminal__terminal-private.h
@@ -0,0 +1,17 @@
+--- ./terminal/terminal-private.h.orig 2011-06-21 20:32:31.000000000 +0000
++++ ./terminal/terminal-private.h 2012-12-23 22:39:59.000000000 +0000
+@@ -24,14 +24,6 @@
+
+ G_BEGIN_DECLS
+
+-/* whether anti-alias is enabled in the application. this settings will
+- * be removed in vte 1.0 and there is no other way to set this. */
+-#ifndef NDEBUG
+-#define TERMINAL_HAS_ANTI_ALIAS_SETTING (FALSE)
+-#else
+-#define TERMINAL_HAS_ANTI_ALIAS_SETTING (TRUE)
+-#endif
+-
+ /* returns true if string contains text */
+ #define IS_STRING(string) ((string) != NULL && *(string) != '\0')
+
diff --git a/x11/Terminal/files/patch-terminal__terminal-screen.c b/x11/Terminal/files/patch-terminal__terminal-screen.c
new file mode 100644
index 000000000000..1d3e749d6dfd
--- /dev/null
+++ b/x11/Terminal/files/patch-terminal__terminal-screen.c
@@ -0,0 +1,47 @@
+--- ./terminal/terminal-screen.c.orig 2011-06-21 20:32:31.000000000 +0000
++++ ./terminal/terminal-screen.c 2012-12-23 22:42:46.000000000 +0000
+@@ -285,7 +285,6 @@
+ "swapped-signal::notify::color-palette15", G_CALLBACK (terminal_screen_update_colors), screen,
+ "swapped-signal::notify::color-palette16", G_CALLBACK (terminal_screen_update_colors), screen,
+ "swapped-signal::notify::font-allow-bold", G_CALLBACK (terminal_screen_update_font), screen,
+- "swapped-signal::notify::font-anti-alias", G_CALLBACK (terminal_screen_update_font), screen,
+ "swapped-signal::notify::font-name", G_CALLBACK (terminal_screen_update_font), screen,
+ "swapped-signal::notify::misc-bell", G_CALLBACK (terminal_screen_update_misc_bell), screen,
+ "swapped-signal::notify::misc-cursor-blinks", G_CALLBACK (terminal_screen_update_misc_cursor_blinks), screen,
+@@ -848,10 +847,6 @@
+ static void
+ terminal_screen_update_font (TerminalScreen *screen)
+ {
+-#if TERMINAL_HAS_ANTI_ALIAS_SETTING
+- VteTerminalAntiAlias antialias;
+- gboolean font_anti_alias;
+-#endif
+ gboolean font_allow_bold;
+ gchar *font_name;
+
+@@ -861,9 +856,6 @@
+
+ g_object_get (G_OBJECT (screen->preferences),
+ "font-allow-bold", &font_allow_bold,
+-#if TERMINAL_HAS_ANTI_ALIAS_SETTING
+- "font-anti-alias", &font_anti_alias,
+-#endif
+ "font-name", &font_name,
+ NULL);
+
+@@ -871,15 +863,7 @@
+ {
+ vte_terminal_set_allow_bold (VTE_TERMINAL (screen->terminal), font_allow_bold);
+
+-#if TERMINAL_HAS_ANTI_ALIAS_SETTING
+- antialias = font_anti_alias
+- ? VTE_ANTI_ALIAS_USE_DEFAULT
+- : VTE_ANTI_ALIAS_FORCE_DISABLE;
+- vte_terminal_set_font_from_string_full (VTE_TERMINAL (screen->terminal),
+- font_name, antialias);
+-#else
+ vte_terminal_set_font_from_string (VTE_TERMINAL (screen->terminal), font_name);
+-#endif
+
+ g_free (font_name);
+ }