aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-09-07 08:28:13 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-09-07 08:28:13 +0000
commit25ec1c992759f2cf0f2f2f135852f52ff6f33f71 (patch)
tree15ec03df76d8478e2e7b95220ecfdaccce511127 /x11
parentf764b7ec744f962acee3e003bf02cb1e8cd25f2b (diff)
downloadports-25ec1c992759f2cf0f2f2f135852f52ff6f33f71.tar.gz
ports-25ec1c992759f2cf0f2f2f135852f52ff6f33f71.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/gpctool/Makefile8
-rw-r--r--x11/gpctool/files/patch-includes6
-rw-r--r--x11/tycoon/Makefile4
3 files changed, 12 insertions, 6 deletions
diff --git a/x11/gpctool/Makefile b/x11/gpctool/Makefile
index cbd037648ebb..47898b8cbe8a 100644
--- a/x11/gpctool/Makefile
+++ b/x11/gpctool/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gpctool
PORTVERSION= 1.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 math graphics
MASTER_SITES= ftp://ftp.cs.man.ac.uk/pub/toby/gpc/
DISTNAME= gpct${PORTVERSION:S/.//g}
@@ -16,7 +16,7 @@ MAINTAINER= mi@aldan.algebra.com
COMMENT= Evaluation tool for the Generic Polygon Clipper library
LIB_DEPENDS= gpc:${PORTSDIR}/devel/libgpc \
- formsGL:${PORTSDIR}/x11-toolkits/xforms
+ formsGL.2:${PORTSDIR}/x11-toolkits/xforms
USE_ZIP= yes
USE_GL= yes
@@ -29,4 +29,8 @@ MAKEFILE= ${FILESDIR}/BSDmakefile
EXTRACT_BEFORE_ARGS=-qoa
EXTRACT_AFTER_ARGS=-d ${WRKDIR} -x ${DISTNAME}/gpc.? ${DISTNAME}/gl.c
+post-patch:
+ ${REINPLACE_CMD} -e 's|FALSE|false|g' \
+ ${WRKSRC}/callbacks.c ${WRKSRC}/graphics.c
+
.include <bsd.port.mk>
diff --git a/x11/gpctool/files/patch-includes b/x11/gpctool/files/patch-includes
index 8935df38be81..3ed8ea7c2c1a 100644
--- a/x11/gpctool/files/patch-includes
+++ b/x11/gpctool/files/patch-includes
@@ -17,7 +17,7 @@
--- callbacks.c Tue Jul 4 10:28:09 2000
+++ callbacks.c Sat Oct 22 02:51:38 2005
-@@ -30,7 +30,6 @@
+@@ -30,7 +30,7 @@
-#include "forms.h"
@@ -25,15 +25,17 @@
-#include "gpctool.h"
+#include <forms.h>
+#include <stdlib.h>
++#include <stdbool.h>
#include "appl.h"
/*
--- graphics.c Tue Jul 4 10:28:10 2000
+++ graphics.c Sat Oct 22 02:53:08 2005
-@@ -30,5 +30,5 @@
+@@ -30,5 +30,6 @@
-#include "gpc.h"
+#include <gpc.h>
++#include <stdbool.h>
#include "appl.h"
#include <float.h>
@@ -37,4 +37,5 @@
diff --git a/x11/tycoon/Makefile b/x11/tycoon/Makefile
index 36080c21df29..a178ed2c51bb 100644
--- a/x11/tycoon/Makefile
+++ b/x11/tycoon/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tycoon
PORTVERSION= 1.07o
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= X11/desktop
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= X11/desktop
MAINTAINER= ports@FreeBSD.org
COMMENT= A nifty set of desktop apps, including floating buttons
-LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= forms.2:${PORTSDIR}/x11-toolkits/xforms
USE_IMAKE= yes
USE_XORG= xaw