aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-10-19 18:16:15 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-10-19 18:16:15 +0000
commita5f9cc91c28e33d61678c2ad38bb9108ec2e58f4 (patch)
tree07d6b1b1d632ab65321d268042b2ca4bc8531aaa /x11
parentb997ee32c898a372f1adc43d6637b8c37f2f5065 (diff)
downloadports-a5f9cc91c28e33d61678c2ad38bb9108ec2e58f4.tar.gz
ports-a5f9cc91c28e33d61678c2ad38bb9108ec2e58f4.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/arandr/Makefile6
-rw-r--r--x11/avant-window-navigator/Makefile3
-rw-r--r--x11/gnome-applets/Makefile2
-rw-r--r--x11/gnome-desktop/Makefile3
-rw-r--r--x11/gnome-panel/Makefile3
-rw-r--r--x11/gnome2/Makefile2
-rw-r--r--x11/gtstarter/Makefile3
-rw-r--r--x11/guake/Makefile3
-rw-r--r--x11/hotwire-shell/Makefile5
-rw-r--r--x11/keybinder/Makefile2
-rw-r--r--x11/libxcb/Makefile3
-rw-r--r--x11/metisse/Makefile3
-rw-r--r--x11/ooxcb/Makefile5
-rw-r--r--x11/rox-wallpaper/Makefile2
-rw-r--r--x11/terminator/Makefile4
-rw-r--r--x11/tint/Makefile2
-rw-r--r--x11/wbarconf/Makefile3
-rw-r--r--x11/workrave/Makefile3
-rw-r--r--x11/xcb-proto/Makefile2
-rw-r--r--x11/xpyb/Makefile3
20 files changed, 24 insertions, 38 deletions
diff --git a/x11/arandr/Makefile b/x11/arandr/Makefile
index 2ab91dca3150..7ac2de86b170 100644
--- a/x11/arandr/Makefile
+++ b/x11/arandr/Makefile
@@ -19,10 +19,8 @@ RUN_DEPENDS= xrandr>0:${PORTSDIR}/x11/xrandr \
OPTIONS_DEFINE= DOCS
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-
-USES+= gettext desktop-file-utils
+USE_PYTHON= distutils
+USES+= gettext desktop-file-utils python
PORTDOCS= ChangeLog NEWS README TODO
diff --git a/x11/avant-window-navigator/Makefile b/x11/avant-window-navigator/Makefile
index 11f7872613e3..ef1bea92daef 100644
--- a/x11/avant-window-navigator/Makefile
+++ b/x11/avant-window-navigator/Makefile
@@ -17,9 +17,8 @@ LIB_DEPENDS= libwnck-1.so:${PORTSDIR}/x11-toolkits/libwnck \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
GNU_CONFIGURE= yes
-USES= gettext gmake libtool pathfix pkgconfig
+USES= gettext gmake libtool pathfix pkgconfig python
USE_GNOME= glib20 gtk20 pygtk2
-USE_PYTHON= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_XORG= x11 xproto xcomposite xrender
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 56373bbff855..9bb769b53b53 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -63,7 +63,7 @@ WITH_GNOME= yes
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USES+= python
USE_GNOME+= pygnomedesktop
PLIST_SUB+= PYTHON=""
.else
diff --git a/x11/gnome-desktop/Makefile b/x11/gnome-desktop/Makefile
index 2e67e767e33c..ee6ce119501d 100644
--- a/x11/gnome-desktop/Makefile
+++ b/x11/gnome-desktop/Makefile
@@ -18,11 +18,10 @@ USES= tar:bzip2
LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
-USES+= bison gettext gmake libtool:keepla pathfix pkgconfig
+USES+= bison gettext gmake libtool:keepla pathfix pkgconfig python:2
USE_XORG= xpm
USE_GNOME= gnomeprefix intlhack gnomedocutils gconf2 pygtk2 \
referencehack
-USE_PYTHON= 2
INSTALLS_OMF= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index 9e9b1ddb49b8..be8f762bfd9a 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -23,12 +23,11 @@ LIB_DEPENDS= libgweather.so:${PORTSDIR}/net/libgweather \
CONFLICTS= gnome-panel-3.[0-9]*
USE_XORG= ice sm x11 xau xrandr
-USE_PYTHON= 2
INSTALLS_OMF= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-USES+= gettext gmake libtool:keepla pathfix pkgconfig
+USES+= gettext gmake libtool:keepla pathfix pkgconfig python:2
USE_GNOME= gnomeprefix intlhack gnomedesktop libwnck gnomemenus \
gnomedocutils referencehack librsvg2
GNU_CONFIGURE= yes
diff --git a/x11/gnome2/Makefile b/x11/gnome2/Makefile
index 1af4bd430ccd..c2b3c0bf243e 100644
--- a/x11/gnome2/Makefile
+++ b/x11/gnome2/Makefile
@@ -61,7 +61,7 @@ NO_MTREE= yes
NO_INSTALL= yes
.if !defined(GNOME_SLAVE)
-USE_PYTHON= yes
+USES+= python
.endif
.if !defined(GNOME_SLAVE) || ${.CURDIR:T}=="gnome2-lite"
diff --git a/x11/gtstarter/Makefile b/x11/gtstarter/Makefile
index 75b918cecb3b..48b32dac955d 100644
--- a/x11/gtstarter/Makefile
+++ b/x11/gtstarter/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= http://webonaut.com/distfiles/${PORTNAME}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Start gnome-terminal from a list of configured profiles (incl. Applet)
-USES= tar:bzip2
-USE_PYTHON= yes
+USES= python tar:bzip2
USE_GNOME= pygnome2 pygnomeextras gnomeprefix
do-build:
diff --git a/x11/guake/Makefile b/x11/guake/Makefile
index 717efc54082a..7c8535ceaf6a 100644
--- a/x11/guake/Makefile
+++ b/x11/guake/Makefile
@@ -47,8 +47,7 @@ REINPLACE_FILES= guake guake-prefs prefs.py
#USE_GITHUB= yes
USE_GNOME= gtk20 pygnome2
-USE_PYTHON= 2
-USES= desktop-file-utils gmake libtool pkgconfig
+USES= desktop-file-utils gmake libtool pkgconfig python:2
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/x11/hotwire-shell/Makefile b/x11/hotwire-shell/Makefile
index 66da221aa53d..c8922853de29 100644
--- a/x11/hotwire-shell/Makefile
+++ b/x11/hotwire-shell/Makefile
@@ -20,9 +20,8 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/p
${PYXML}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
USE_GNOME= pygnome2 pygtk2 pygtksourceview
INSTALLS_ICONS= yes
diff --git a/x11/keybinder/Makefile b/x11/keybinder/Makefile
index 1c234bb7131c..9e8acbeca343 100644
--- a/x11/keybinder/Makefile
+++ b/x11/keybinder/Makefile
@@ -28,7 +28,7 @@ LUA_DESC= Lua bindings
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= 2
+USES+= python:2
USE_GNOME+= pygtk2
.else
CONFIGURE_ARGS+= --disable-python
diff --git a/x11/libxcb/Makefile b/x11/libxcb/Makefile
index 1f6ec6b5118e..f466523d0a22 100644
--- a/x11/libxcb/Makefile
+++ b/x11/libxcb/Makefile
@@ -21,10 +21,9 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:${PORTSDIR}/devel/l
CONFIGURE_ARGS+= --disable-build-docs --without-doxygen --enable-xinput
XORG_CAT= lib
-USES= gmake
+USES= gmake python:2,build
USE_GNOME= libxslt:build
USE_XORG= xau xdmcp
-USE_PYTHON_BUILD=2
OPTIONS_DEFINE= DOCS
diff --git a/x11/metisse/Makefile b/x11/metisse/Makefile
index 9dc00ea63811..487653916ac7 100644
--- a/x11/metisse/Makefile
+++ b/x11/metisse/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libNucleo.so:${PORTSDIR}/x11-toolkits/nucleo \
libpng15.so:${PORTSDIR}/graphics/png
RUN_DEPENDS= ${LOCALBASE}/libdata/xorg/fonts:${PORTSDIR}/x11-fonts/xorg-fonts
-USES= gettext libtool pathfix pkgconfig shebangfix tar:bzip2
+USES= gettext libtool pathfix pkgconfig python shebangfix tar:bzip2
SHEBANG_FILES= ${WRKSRC}/fvwm-insitu/bin/fvwm-convert-2.4.in \
${WRKSRC}/fvwm-insitu/bin/fvwm-convert-2.6.in \
${WRKSRC}/fvwm-insitu/bin/fvwm-menu-desktop.in \
@@ -36,7 +36,6 @@ perl_OLD_CMD= @PERL@
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-fontdir=${LOCALBASE}/lib/X11/fonts
USE_LDCONFIG= yes
-USE_PYTHON= yes
USE_XORG= xcursor xft xinerama xpm xrender xt xtst
WANT_GNOME= yes
MAKE_ARGS= METISSE_DOC_DIR="${DOCSDIR}"
diff --git a/x11/ooxcb/Makefile b/x11/ooxcb/Makefile
index 486af9138f7e..b1ef35587d15 100644
--- a/x11/ooxcb/Makefile
+++ b/x11/ooxcb/Makefile
@@ -11,8 +11,7 @@ MAINTAINER= gahr@FreeBSD.org
COMMENT= Python binding to the X server using xcb
USE_XORG= xcb
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/x11/rox-wallpaper/Makefile b/x11/rox-wallpaper/Makefile
index 0e004d67d6e2..b7770d154769 100644
--- a/x11/rox-wallpaper/Makefile
+++ b/x11/rox-wallpaper/Makefile
@@ -13,7 +13,7 @@ COMMENT= Wallpaper management tool for the ROX desktop
RUN_DEPENDS= ${LOCALBASE}/bin/rox:${PORTSDIR}/x11-fm/rox-filer \
${LOCALBASE}/lib/ROX-Lib2/python/rox/__init__.py:${PORTSDIR}/devel/py-roxlib
-USE_PYTHON= yes
+USES= python
WRKSRC= ${WRKDIR}/Wallpaper
diff --git a/x11/terminator/Makefile b/x11/terminator/Makefile
index 9acbfb0c3330..8ce3c813125a 100644
--- a/x11/terminator/Makefile
+++ b/x11/terminator/Makefile
@@ -19,8 +19,8 @@ OPTIONS_DEFINE= NLS GCONF
GCONF_DESC= Use GNOME Terminal settings
OPTIONS_DEFAULT= NLS GCONF
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= Terminator
INSTALLS_ICONS= yes
diff --git a/x11/tint/Makefile b/x11/tint/Makefile
index d8fbf45f179e..e1b6dac44f8d 100644
--- a/x11/tint/Makefile
+++ b/x11/tint/Makefile
@@ -35,7 +35,7 @@ DOCS= AUTHORS ChangeLog README
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYCONF}
-USE_PYTHON= yes
+USES+= python
USE_GNOME= gtk20 pygtk2
CMAKE_ARGS+= -DENABLE_TINT2CONF:BOOL=ON
PYCONF_SRC= ${WRKSRC}/src/tint2conf
diff --git a/x11/wbarconf/Makefile b/x11/wbarconf/Makefile
index d640802dde32..f5651a0162af 100644
--- a/x11/wbarconf/Makefile
+++ b/x11/wbarconf/Makefile
@@ -15,8 +15,7 @@ LICENSE= GPLv3
RUN_DEPENDS= wbar:${PORTSDIR}/x11/wbar
USE_GNOME= pygobject pygtk2 gtk20
-USE_PYTHON= yes
-USES= gettext desktop-file-utils shebangfix
+USES= gettext desktop-file-utils python shebangfix
SHEBANG_LANG= python
SHEBANG_FILES= ${WRKSRC}/wbarconf
python_OLD_CMD= /usr/bin/env python2
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index b03f83be924f..04382dd70d07 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -15,10 +15,9 @@ LICENSE= GPLv3 # (or later)
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cheetah>0:${PORTSDIR}/devel/py-cheetah
LIB_DEPENDS= libgdome.so:${PORTSDIR}/textproc/gdome2
-USES= gettext gmake pathfix pkgconfig
+USES= gettext gmake pathfix pkgconfig python
USE_XORG= recordproto x11 xext xmu xscrnsaver xtst
USE_GNOME= intlhack gconf2 gnomehier gtkmm24
-USE_PYTHON= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules --enable-gconf --disable-gnome3 \
--disable-indicator
diff --git a/x11/xcb-proto/Makefile b/x11/xcb-proto/Makefile
index 55bc268166bd..b776713b8ed3 100644
--- a/x11/xcb-proto/Makefile
+++ b/x11/xcb-proto/Makefile
@@ -13,7 +13,7 @@ COMMENT= The X protocol C-language Binding (XCB) protocol
BUILD_DEPENDS= xmllint:${PORTSDIR}/textproc/libxml2
XORG_CAT= proto
-USE_PYTHON= 2
+USES= python:2
DATADIR= ${PREFIX}/share/xcb
diff --git a/x11/xpyb/Makefile b/x11/xpyb/Makefile
index 103671ecbddc..248c2b93040b 100644
--- a/x11/xpyb/Makefile
+++ b/x11/xpyb/Makefile
@@ -15,8 +15,7 @@ COMMENT= Python bindings to access X Window System protocol via libxcb
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-proto.pc:${PORTSDIR}/x11/xcb-proto \
xcb-proto>=1.7.1:${PORTSDIR}/x11/xcb-proto
-USES= libtool pathfix pkgconfig tar:bzip2
-USE_PYTHON= yes
+USES= libtool pathfix pkgconfig python tar:bzip2
USE_XORG= xcb
PORTDOCS= README COPYING INSTALL NEWS XcbPythonBinding.txt