aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-04-24 07:35:40 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-04-24 07:35:40 +0000
commit08c99f3ad5e81fd0d89c32e9337608d9a9bb4e35 (patch)
tree83aac97dcee746842718f1f34dfa58caca71df28 /x11
parent91696069c0e8874f735d4e30d164e5f922dd9819 (diff)
downloadports-08c99f3ad5e81fd0d89c32e9337608d9a9bb4e35.tar.gz
ports-08c99f3ad5e81fd0d89c32e9337608d9a9bb4e35.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/gnome-desktop/Makefile3
-rw-r--r--x11/gnome-libs/Makefile5
-rw-r--r--x11/gnome-menus/Makefile3
-rw-r--r--x11/gsynaptics/Makefile3
-rw-r--r--x11/libgnome/Makefile3
-rw-r--r--x11/rsibreak-kde4/Makefile3
-rw-r--r--x11/yakuake-kde4/Makefile3
7 files changed, 8 insertions, 15 deletions
diff --git a/x11/gnome-desktop/Makefile b/x11/gnome-desktop/Makefile
index 319adff81d82..06be5c686831 100644
--- a/x11/gnome-desktop/Makefile
+++ b/x11/gnome-desktop/Makefile
@@ -19,10 +19,9 @@ USE_BZIP2= yes
LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
USE_XORG= xpm
-USES= bison pathfix
+USES= bison pathfix gettext
USE_GNOME= gnomeprefix intlhack gnomedocutils gconf2 pygtk2 \
ltverhack referencehack
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_PYTHON= yes
INSTALLS_OMF= yes
diff --git a/x11/gnome-libs/Makefile b/x11/gnome-libs/Makefile
index 0e1a23bac1ae..c71599f6ca4e 100644
--- a/x11/gnome-libs/Makefile
+++ b/x11/gnome-libs/Makefile
@@ -16,14 +16,13 @@ BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
-USES= charsetfix
+USES= charsetfix gettext
USE_BZIP2= yes
USE_XORG= xpm ice x11
USE_PERL5= yes
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomehier gnomeprefix esound gtk12 imlib libxml orbit
-USE_GETTEXT= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-test-gnome
diff --git a/x11/gnome-menus/Makefile b/x11/gnome-menus/Makefile
index 404447e01d69..5b9148bf764e 100644
--- a/x11/gnome-menus/Makefile
+++ b/x11/gnome-menus/Makefile
@@ -14,11 +14,10 @@ COMMENT= Implementation of the FreeDesktop Desktop Menu Spec
BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-USE_GETTEXT= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack glib20 ltverhack
-USES= pkgconfig
+USES= pkgconfig gettext
USE_AUTOTOOLS= libtool
USE_PYTHON= yes
USE_LDCONFIG= yes
diff --git a/x11/gsynaptics/Makefile b/x11/gsynaptics/Makefile
index f7bca55e05e8..0497c382f61e 100644
--- a/x11/gsynaptics/Makefile
+++ b/x11/gsynaptics/Makefile
@@ -13,9 +13,8 @@ LICENSE= GPLv2
RUN_DEPENDS= xf86-input-synaptics>0:${PORTSDIR}/x11-drivers/xf86-input-synaptics
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig gettext
USE_GNOME= gconf2 libglade2 gnomedocutils
-USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index c5a1668b25d4..6dc7f12da71c 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -20,11 +20,10 @@ BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
LIB_DEPENDS= canberra-gtk.0:${PORTSDIR}/audio/libcanberra
RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix intlhack esound libbonobo \
gnomevfs2 ltverhack referencehack
-USES= bison pathfix
+USES= bison pathfix gettext
USE_XORG= xpm
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
diff --git a/x11/rsibreak-kde4/Makefile b/x11/rsibreak-kde4/Makefile
index ef28b98d55ee..47f05a248b86 100644
--- a/x11/rsibreak-kde4/Makefile
+++ b/x11/rsibreak-kde4/Makefile
@@ -13,8 +13,7 @@ COMMENT= KDE RSI prevention tool
LATEST_LINK= ${PORTNAME}-kde4
USE_BZIP2= yes
-USE_GETTEXT= yes
-USES= cmake
+USES= cmake gettext
USE_QT4= qmake_build moc_build rcc_build uic_build
USE_KDE4= kdehier kdeprefix kdelibs automoc4
INSTALLS_ICONS= yes
diff --git a/x11/yakuake-kde4/Makefile b/x11/yakuake-kde4/Makefile
index 693c97083a98..3e45cbf3424d 100644
--- a/x11/yakuake-kde4/Makefile
+++ b/x11/yakuake-kde4/Makefile
@@ -14,10 +14,9 @@ COMMENT= Drop-down terminal emulator for KDE
LICENSE= GPLv2
USE_XZ= yes
-USES= cmake
+USES= cmake gettext
USE_KDE4= automoc4 kdelibs kdeprefix
USE_QT4= qmake_build moc_build rcc_build uic_build
-USE_GETTEXT= yes
INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes