aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-07-21 22:10:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-07-21 22:10:19 +0000
commit2b42caf5abdc766ce009fc75c88381c637134e30 (patch)
tree8b6d3392ade23daf371addfcc28b4801c5293940 /x11
parentb7e57efe5cbf04280382d1cabe60a86694ad0dfc (diff)
downloadports-2b42caf5abdc766ce009fc75c88381c637134e30.tar.gz
ports-2b42caf5abdc766ce009fc75c88381c637134e30.zip
x11/grim: partially revert r542791
2020Q3 has wlroots 0.10.1 with old rotate behavior, making grim 1.3.1 take inverted screenshots. Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2020Q3/; revision=542812
Diffstat (limited to 'x11')
-rw-r--r--x11/grim/Makefile1
-rw-r--r--x11/grim/files/patch-wlroots-0.1013
2 files changed, 14 insertions, 0 deletions
diff --git a/x11/grim/Makefile b/x11/grim/Makefile
index c90171a71ba3..7664ae0cc01e 100644
--- a/x11/grim/Makefile
+++ b/x11/grim/Makefile
@@ -3,6 +3,7 @@
PORTNAME= grim
DISTVERSIONPREFIX= v
DISTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= jbeich@FreeBSD.org
diff --git a/x11/grim/files/patch-wlroots-0.10 b/x11/grim/files/patch-wlroots-0.10
new file mode 100644
index 000000000000..c4b073a3ef6c
--- /dev/null
+++ b/x11/grim/files/patch-wlroots-0.10
@@ -0,0 +1,13 @@
+Revert https://github.com/emersion/grim/commit/8f9d60885ce2
+
+--- render.c.orig 2020-07-21 18:11:14 UTC
++++ render.c
+@@ -104,7 +104,7 @@ cairo_surface_t *render(struct grim_state *state, stru
+ cairo_matrix_translate(&matrix,
+ (double)output->geometry.width / 2,
+ (double)output->geometry.height / 2);
+- cairo_matrix_rotate(&matrix, get_output_rotation(output->transform));
++ cairo_matrix_rotate(&matrix, -get_output_rotation(output->transform));
+ cairo_matrix_scale(&matrix,
+ (double)raw_output_width / output_width * output_flipped_x,
+ (double)raw_output_height / output_height * output_flipped_y);