aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-06-24 13:10:49 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-06-24 13:10:49 +0000
commit647dd4341b470fda8d14fd7ea1976c2cd9f7ac5a (patch)
tree026f6d30742949ae18f2993b45e8dd6b34eb97fc /x11
parent42250e01f22317f11646c9d37ca53a29115c490e (diff)
downloadports-647dd4341b470fda8d14fd7ea1976c2cd9f7ac5a.tar.gz
ports-647dd4341b470fda8d14fd7ea1976c2cd9f7ac5a.zip
x11/mate-panel: make X11/Wayland optional
Notes
Notes: svn path=/head/; revision=540061
Diffstat (limited to 'x11')
-rw-r--r--x11/mate-panel/Makefile28
-rw-r--r--x11/mate-panel/distinfo2
-rw-r--r--x11/mate-panel/pkg-plist12
3 files changed, 29 insertions, 13 deletions
diff --git a/x11/mate-panel/Makefile b/x11/mate-panel/Makefile
index 15ceab66dbc6..9c67876a45ae 100644
--- a/x11/mate-panel/Makefile
+++ b/x11/mate-panel/Makefile
@@ -7,6 +7,9 @@ CATEGORIES= x11 mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
+PATCH_SITES= https://github.com/mate-desktop/${PORTNAME}/commit/
+PATCHFILES+= f4c44ad563ff.patch:-p1 # https://github.com/mate-desktop/mate-panel/pull/1104
+
MAINTAINER= gnome@FreeBSD.org
COMMENT= Panel component for the MATE Desktop
@@ -19,17 +22,16 @@ LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LIB
BUILD_DEPENDS= itstool:textproc/itstool
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib \
- libstartup-notification-1.so:x11/startup-notification \
- libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell
+ libstartup-notification-1.so:x11/startup-notification
PORTSCOUT= limitw:1,even
USES= gettext gmake gnome libtool localbase mate pathfix pkgconfig \
tar:xz xorg
USE_MATE= desktop libmateweather menus
-USE_XORG= ice sm x11 xau xrandr
+USE_XORG= ice sm
USE_GNOME= cairo dconf gnomeprefix gtk30 intltool \
- introspection:build librsvg2 libwnck3
+ introspection:build librsvg2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
@@ -37,9 +39,6 @@ INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.mate.panel.applet.clock.gschema.xml \
org.mate.panel.applet.fish.gschema.xml \
- org.mate.panel.applet.notification-area.gschema.xml \
- org.mate.panel.applet.window-list.gschema.xml \
- org.mate.panel.applet.workspace-switcher.gschema.xml \
org.mate.panel.enums.xml \
org.mate.panel.gschema.xml \
org.mate.panel.menubar.gschema.xml \
@@ -47,5 +46,20 @@ GLIB_SCHEMAS= org.mate.panel.applet.clock.gschema.xml \
org.mate.panel.toplevel.gschema.xml
OPTIONS_DEFINE= DOCS
+OPTIONS_MULTI= GUI
+OPTIONS_MULTI_GUI= WAYLAND X11
+OPTIONS_DEFAULT= WAYLAND X11
+OPTIONS_SUB= yes
+
+WAYLAND_LIB_DEPENDS= libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell
+WAYLAND_CONFIGURE_ENABLE= wayland
+
+X11_USE= GNOME=libwnck3 XORG=x11,xau,xrandr
+X11_CONFIGURE_ENABLE= x11
+X11_VARS= GLIB_SCHEMAS+=org.mate.panel.applet.notification-area.gschema.xml \
+ GLIB_SCHEMAS+=org.mate.panel.applet.window-list.gschema.xml \
+ GLIB_SCHEMAS+=org.mate.panel.applet.workspace-switcher.gschema.xml
+X11_CONFIGURE_ENV_OFF= WNCKLET_CFLAGS=" " WNCKLET_LIBS=" " \
+ XRANDR_CFLAGS=" " XRANDR_LIBS=" "
.include <bsd.port.mk>
diff --git a/x11/mate-panel/distinfo b/x11/mate-panel/distinfo
index 0b2bfbb1f57a..0e15e8471775 100644
--- a/x11/mate-panel/distinfo
+++ b/x11/mate-panel/distinfo
@@ -1,3 +1,5 @@
TIMESTAMP = 1591974472
SHA256 (mate/mate-panel-1.24.0.tar.xz) = 369e088806b72c4035c4342de0f16301d9b5d8b8ba5ad16350bba2892f0830c3
SIZE (mate/mate-panel-1.24.0.tar.xz) = 3040068
+SHA256 (mate/f4c44ad563ff.patch) = b1a985e32adb1605414962381a11aab1255d3dbfec14f7c1edaf5846f91d2d0d
+SIZE (mate/f4c44ad563ff.patch) = 768
diff --git a/x11/mate-panel/pkg-plist b/x11/mate-panel/pkg-plist
index 3b10746eb58e..6d162484184f 100644
--- a/x11/mate-panel/pkg-plist
+++ b/x11/mate-panel/pkg-plist
@@ -12,16 +12,16 @@ lib/libmate-panel-applet-4.so.1.0.1
libdata/pkgconfig/libmatepanelapplet-4.0.pc
libexec/clock-applet
libexec/fish-applet
-libexec/notification-area-applet
-libexec/wnck-applet
+%%X11%%libexec/notification-area-applet
+%%X11%%libexec/wnck-applet
man/man1/mate-desktop-item-edit.1.gz
man/man1/mate-panel-test-applets.1.gz
man/man1/mate-panel.1.gz
share/applications/mate-panel.desktop
share/dbus-1/services/org.mate.panel.applet.ClockAppletFactory.service
share/dbus-1/services/org.mate.panel.applet.FishAppletFactory.service
-share/dbus-1/services/org.mate.panel.applet.NotificationAreaAppletFactory.service
-share/dbus-1/services/org.mate.panel.applet.WnckletFactory.service
+%%X11%%share/dbus-1/services/org.mate.panel.applet.NotificationAreaAppletFactory.service
+%%X11%%share/dbus-1/services/org.mate.panel.applet.WnckletFactory.service
%%PORTDOCS%%%%DOCSDIR%%-applet/applet-popups.html
%%PORTDOCS%%%%DOCSDIR%%-applet/applet-porting.html
%%PORTDOCS%%%%DOCSDIR%%-applet/applet-writing.html
@@ -1022,8 +1022,8 @@ share/locale/zh_TW/LC_MESSAGES/mate-panel.mo
share/locale/zu/LC_MESSAGES/mate-panel.mo
%%DATADIR%%/applets/org.mate.panel.ClockApplet.mate-panel-applet
%%DATADIR%%/applets/org.mate.panel.FishApplet.mate-panel-applet
-%%DATADIR%%/applets/org.mate.panel.NotificationAreaApplet.mate-panel-applet
-%%DATADIR%%/applets/org.mate.panel.Wncklet.mate-panel-applet
+%%X11%%%%DATADIR%%/applets/org.mate.panel.NotificationAreaApplet.mate-panel-applet
+%%X11%%%%DATADIR%%/applets/org.mate.panel.Wncklet.mate-panel-applet
%%DATADIR%%/fish/fishanim.png
%%DATADIR%%/fish/footguy.png
%%DATADIR%%/fish/monkey.png