aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-01-30 09:57:08 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-01-30 09:57:08 +0000
commit80de8283418560597f36012582cc655eed8e5b03 (patch)
tree7a3eb3e12d13f986b0478887a1668fd39e9c39f9 /x11
parent7f81c3a08b6151a4a3dc83ac2fec93c11aea2d43 (diff)
downloadports-80de8283418560597f36012582cc655eed8e5b03.tar.gz
ports-80de8283418560597f36012582cc655eed8e5b03.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/hs-X11-xft/Makefile9
-rw-r--r--x11/hs-X11-xft/pkg-plist15
-rw-r--r--x11/hs-x11-xft-ghc/Makefile9
-rw-r--r--x11/hs-x11-xft-ghc/pkg-plist15
4 files changed, 16 insertions, 32 deletions
diff --git a/x11/hs-X11-xft/Makefile b/x11/hs-X11-xft/Makefile
index aae05a81a15a..b5ba3282b52a 100644
--- a/x11/hs-X11-xft/Makefile
+++ b/x11/hs-X11-xft/Makefile
@@ -7,6 +7,7 @@
PORTNAME= x11-xft
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= x11 haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/X11-xft/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -33,11 +34,15 @@ PLIST_SUB+= GHC_VERSION=${GHC_VERSION} \
PORTNAME=${PORTNAME} \
SUBDIR=lib/ghc-${GHC_VERSION}/cabal
DOCSDIR= ${PREFIX}/share/doc/X11-xft-${PORTVERSION}
+PORTDOCS= LICENSE html
CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${CABALDIR} --libsubdir='' --datasubdir=''
-.ifndef (NOPORTDOCS)
+.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.else
+PLIST_DIRS+= %%DOCSDIR%%
+PLIST_FILES+= %%DOCSDIR%%/LICENSE
.endif
do-configure:
@@ -45,7 +50,7 @@ do-configure:
do-build:
cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
-.ifndef (NOPORTDOCS)
+.if !defined(NOPORTDOCS)
cd ${WRKSRC} && ${CABALCMD} haddock
.endif
diff --git a/x11/hs-X11-xft/pkg-plist b/x11/hs-X11-xft/pkg-plist
index 1908fbeb7dec..07b9a37b156d 100644
--- a/x11/hs-X11-xft/pkg-plist
+++ b/x11/hs-X11-xft/pkg-plist
@@ -3,22 +3,9 @@
%%SUBDIR%%/HSX11-xft-0.3.o
%%SUBDIR%%/libHSX11-xft-0.3.a
%%SUBDIR%%/x11-xft-register.sh
-%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xft.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xrender.html
-%%PORTDOCS%%%%DOCSDIR%%/html/X11-xft.haddock
-%%PORTDOCS%%%%DOCSDIR%%/html/doc-index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/haddock-util.js
-%%PORTDOCS%%%%DOCSDIR%%/html/haddock.css
-%%PORTDOCS%%%%DOCSDIR%%/html/haskell_icon.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/minus.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/plus.gif
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-@dirrm %%DOCSDIR%%
@dirrmtry %%SUBDIR%%/Graphics/X11
@dirrmtry %%SUBDIR%%/Graphics
@exec /bin/sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister X11-xft
+@unexec ghc-pkg unregister X11-xft
@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
diff --git a/x11/hs-x11-xft-ghc/Makefile b/x11/hs-x11-xft-ghc/Makefile
index aae05a81a15a..b5ba3282b52a 100644
--- a/x11/hs-x11-xft-ghc/Makefile
+++ b/x11/hs-x11-xft-ghc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= x11-xft
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= x11 haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/X11-xft/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -33,11 +34,15 @@ PLIST_SUB+= GHC_VERSION=${GHC_VERSION} \
PORTNAME=${PORTNAME} \
SUBDIR=lib/ghc-${GHC_VERSION}/cabal
DOCSDIR= ${PREFIX}/share/doc/X11-xft-${PORTVERSION}
+PORTDOCS= LICENSE html
CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${CABALDIR} --libsubdir='' --datasubdir=''
-.ifndef (NOPORTDOCS)
+.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.else
+PLIST_DIRS+= %%DOCSDIR%%
+PLIST_FILES+= %%DOCSDIR%%/LICENSE
.endif
do-configure:
@@ -45,7 +50,7 @@ do-configure:
do-build:
cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
-.ifndef (NOPORTDOCS)
+.if !defined(NOPORTDOCS)
cd ${WRKSRC} && ${CABALCMD} haddock
.endif
diff --git a/x11/hs-x11-xft-ghc/pkg-plist b/x11/hs-x11-xft-ghc/pkg-plist
index 1908fbeb7dec..07b9a37b156d 100644
--- a/x11/hs-x11-xft-ghc/pkg-plist
+++ b/x11/hs-x11-xft-ghc/pkg-plist
@@ -3,22 +3,9 @@
%%SUBDIR%%/HSX11-xft-0.3.o
%%SUBDIR%%/libHSX11-xft-0.3.a
%%SUBDIR%%/x11-xft-register.sh
-%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xft.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xrender.html
-%%PORTDOCS%%%%DOCSDIR%%/html/X11-xft.haddock
-%%PORTDOCS%%%%DOCSDIR%%/html/doc-index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/haddock-util.js
-%%PORTDOCS%%%%DOCSDIR%%/html/haddock.css
-%%PORTDOCS%%%%DOCSDIR%%/html/haskell_icon.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/minus.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/plus.gif
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-@dirrm %%DOCSDIR%%
@dirrmtry %%SUBDIR%%/Graphics/X11
@dirrmtry %%SUBDIR%%/Graphics
@exec /bin/sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister X11-xft
+@unexec ghc-pkg unregister X11-xft
@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old