aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-08-26 13:57:13 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-08-26 13:57:13 +0000
commit9c9536deee13e4a41f69c9e0531a819a004f4dcf (patch)
tree29bb5b2fb540206615ab65c2bf6ff7de7c98e960 /x11
parent2bf0d26b817b2715c9041142e99c0e9f7d3ac81e (diff)
downloadports-9c9536deee13e4a41f69c9e0531a819a004f4dcf.tar.gz
ports-9c9536deee13e4a41f69c9e0531a819a004f4dcf.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/xdm/Makefile2
-rw-r--r--x11/xdm/files/patch-config-Makefile.in6
-rw-r--r--x11/xdm/files/patch-config-Xresources.cpp6
-rw-r--r--x11/xdm/files/patch-config_xdm-config.cpp40
-rw-r--r--x11/xdm/files/patch-greeter-greet.c12
-rw-r--r--x11/xdm/files/patch-xdm_session.c16
6 files changed, 61 insertions, 21 deletions
diff --git a/x11/xdm/Makefile b/x11/xdm/Makefile
index b17ac8b3357a..8088a2677d10 100644
--- a/x11/xdm/Makefile
+++ b/x11/xdm/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xdm
PORTVERSION= 1.1.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
diff --git a/x11/xdm/files/patch-config-Makefile.in b/x11/xdm/files/patch-config-Makefile.in
index 9a59bfc79d9b..81a562d7bbc1 100644
--- a/x11/xdm/files/patch-config-Makefile.in
+++ b/x11/xdm/files/patch-config-Makefile.in
@@ -1,6 +1,6 @@
---- config/Makefile.in.orig 2012-09-27 10:37:59.000000000 +0200
-+++ config/Makefile.in 2012-09-27 10:38:41.000000000 +0200
-@@ -296,7 +296,7 @@
+--- config/Makefile.in.orig 2011-09-25 07:42:16 UTC
++++ config/Makefile.in
+@@ -296,7 +296,7 @@ WCHAR32_FLAGS = -DWCHAR32=@WCHAR32@
# output lines with trailing backslashes.
# Allow XHASH to always be substituted, even in cases where XCOMM isn't.
CPP_SED_MAGIC = $(SED) -e '/^\# *[0-9][0-9]* *.*$$/d' \
diff --git a/x11/xdm/files/patch-config-Xresources.cpp b/x11/xdm/files/patch-config-Xresources.cpp
index 4e727341b442..25cbab9e5b9e 100644
--- a/x11/xdm/files/patch-config-Xresources.cpp
+++ b/x11/xdm/files/patch-config-Xresources.cpp
@@ -1,6 +1,6 @@
---- config/Xresources.cpp.orig 2012-09-27 10:41:28.000000000 +0200
-+++ config/Xresources.cpp 2012-09-27 10:41:56.000000000 +0200
-@@ -60,9 +60,9 @@
+--- config/Xresources.cpp.orig 2011-09-25 07:35:47 UTC
++++ config/Xresources.cpp
+@@ -60,9 +60,9 @@ xlogin*hiColor: black
XHASHendif
#ifdef XPM
XHASHif PLANES >= 8
diff --git a/x11/xdm/files/patch-config_xdm-config.cpp b/x11/xdm/files/patch-config_xdm-config.cpp
new file mode 100644
index 000000000000..d126876334df
--- /dev/null
+++ b/x11/xdm/files/patch-config_xdm-config.cpp
@@ -0,0 +1,40 @@
+--- config/xdm-config.cpp.orig 2011-09-25 07:35:47 UTC
++++ config/xdm-config.cpp
+@@ -12,25 +12,26 @@
+ DisplayManager.authDir: XDMXAUTHDIR
+ DisplayManager.errorLogFile: XDMLOGDIR/xdm.log
+ DisplayManager.pidFile: XDMPIDDIR/xdm.pid
+-DisplayManager.keyFile: XDMCONFIGDIR/xdm-keys
+-DisplayManager.servers: XDMCONFIGDIR/Xservers
+-DisplayManager.accessFile: XDMCONFIGDIR/Xaccess
+-DisplayManager*resources: XDMCONFIGDIR/Xresources
+-DisplayManager.willing: SU nobody -s /bin/sh -c XDMSCRIPTDIR/Xwilling
++DisplayManager.keyFile: /usr/local/lib/X11/xdm/xdm-keys
++DisplayManager.servers: /usr/local/lib/X11/xdm/Xservers
++DisplayManager.accessFile: /usr/local/lib/X11/xdm/Xaccess
++DisplayManager*resources: /usr/local/lib/X11/xdm/Xresources
++DisplayManager.willing: SU nobody -s /bin/sh -c /usr/local/lib/X11/xdm/Xwilling
+ ! All displays should use authorization, but we cannot be sure
+ ! X terminals may not be configured that way, so they will require
+ ! individual resource settings.
+ DisplayManager*authorize: true
+ !
+ DisplayManager*chooser: CHOOSERPATH
+-DisplayManager*startup: XDMSCRIPTDIR/Xstartup
+-DisplayManager*session: XDMSCRIPTDIR/Xsession
+-DisplayManager*reset: XDMSCRIPTDIR/Xreset
++DisplayManager*startup: /usr/local/lib/X11/xdm/Xstartup
++DisplayManager*session: /usr/local/lib/X11/xdm/Xsession
++DisplayManager*reset: /usr/local/lib/X11/xdm/Xreset
+ DisplayManager*authComplain: true
+ ! The following three resources set up display :0 as the console.
+-DisplayManager._0.setup: XDMSCRIPTDIR/Xsetup_0
+-DisplayManager._0.startup: XDMSCRIPTDIR/GiveConsole
+-DisplayManager._0.reset: XDMSCRIPTDIR/TakeConsole
++DisplayManager._0.setup: /usr/local/lib/X11/xdm/Xsetup_0
++DisplayManager._0.startup: /usr/local/lib/X11/xdm/GiveConsole
++DisplayManager._0.reset: /usr/local/lib/X11/xdm/TakeConsole
++DisplayManager.*.authName: MIT-MAGIC-COOKIE-1
+ #ifdef XPM
+ DisplayManager*loginmoveInterval: 10
+ #endif /* XPM */
diff --git a/x11/xdm/files/patch-greeter-greet.c b/x11/xdm/files/patch-greeter-greet.c
index b8a221de6e37..018b11ba1a9c 100644
--- a/x11/xdm/files/patch-greeter-greet.c
+++ b/x11/xdm/files/patch-greeter-greet.c
@@ -1,6 +1,6 @@
---- greeter/greet.c.orig Sat Feb 3 01:25:25 2007
-+++ greeter/greet.c Wed Apr 4 14:03:31 2007
-@@ -612,6 +617,7 @@ greet_user_rtn GreetUser(
+--- greeter/greet.c.orig 2011-09-25 07:35:47 UTC
++++ greeter/greet.c
+@@ -639,6 +639,7 @@ greet_user_rtn GreetUser(
}
DeleteXloginResources (d, *dpy);
CloseGreet (d);
@@ -8,9 +8,9 @@
Debug ("Greet loop finished\n");
/*
* Run system-wide initialization file
-@@ -697,6 +704,8 @@ static int pamconv(int num_msg,
- m = *msg;
- r = *response;
+@@ -729,6 +730,8 @@ static int pamconv(int num_msg,
+ goto pam_error;
+ }
+ if (login == NULL) goto pam_error;
+
diff --git a/x11/xdm/files/patch-xdm_session.c b/x11/xdm/files/patch-xdm_session.c
index de1c579b4f8b..9ac29aa7c1e3 100644
--- a/x11/xdm/files/patch-xdm_session.c
+++ b/x11/xdm/files/patch-xdm_session.c
@@ -1,14 +1,14 @@
---- xdm/session.c.orig Sun Jun 3 22:49:51 2007
-+++ xdm/session.c Sun Jun 3 22:56:06 2007
-@@ -543,6 +543,7 @@
+--- xdm/session.c.orig 2011-09-25 07:35:47 UTC
++++ xdm/session.c
+@@ -575,6 +575,7 @@ StartClient (
pid_t pid;
- #ifdef HAS_SETUSERCONTEXT
+ #ifdef HAVE_SETUSERCONTEXT
struct passwd* pwd;
+ extern char **environ;
#endif
#ifdef USE_PAM
pam_handle_t *pamh = thepamh ();
-@@ -657,6 +660,8 @@
+@@ -695,6 +696,8 @@ StartClient (
* Set the user's credentials: uid, gid, groups,
* environment variables, resource limits, and umask.
*/
@@ -17,11 +17,11 @@
pwd = getpwnam(name);
if (pwd) {
if (setusercontext(NULL, pwd, pwd->pw_uid, LOGIN_SETALL) < 0) {
-@@ -664,6 +669,7 @@
- errno);
+@@ -702,6 +705,7 @@ StartClient (
+ name, _SysErrorMsg (errno));
return (0);
}
+ verify->userEnviron = environ;
endpwent();
} else {
- LogError ("getpwnam for \"%s\" failed, errno=%d\n", name, errno);
+ LogError ("getpwnam for \"%s\" failed: %s\n",