aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJesper Schmitz Mouridsen <jsm@FreeBSD.org>2020-06-22 14:56:36 +0000
committerJesper Schmitz Mouridsen <jsm@FreeBSD.org>2020-06-22 14:56:36 +0000
commite2c75208604775da7ec23dc647822418c60cf152 (patch)
treeb443db2247ba9fa7639e17c26dde13ad66bbaeb7 /x11
parentd42f11bf02523830b9ff704b2c1fa8c3d38c3004 (diff)
downloadports-e2c75208604775da7ec23dc647822418c60cf152.tar.gz
ports-e2c75208604775da7ec23dc647822418c60cf152.zip
Corrects get_x11_device for FreeBSD
fixes active session state for consolekit2 transfer maintainership PR: 243988 Approved by: henry.hu.sh@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=539811
Diffstat (limited to 'x11')
-rw-r--r--x11/slim/Makefile4
-rw-r--r--x11/slim/files/patch-Ck.cpp11
2 files changed, 13 insertions, 2 deletions
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index 8939f598576b..bca5438c801f 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -3,12 +3,12 @@
PORTNAME= slim
PORTVERSION= 1.3.6
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= x11
MASTER_SITES= ftp://ftp.berlios.de/pub/slim/ \
SF/slim.berlios
-MAINTAINER= henry.hu.sh@gmail.com
+MAINTAINER= jsm@FreeBSD.org
COMMENT= Graphical login manager for X11, derived from Login.app
LICENSE= GPLv2
diff --git a/x11/slim/files/patch-Ck.cpp b/x11/slim/files/patch-Ck.cpp
new file mode 100644
index 000000000000..d10129be25b0
--- /dev/null
+++ b/x11/slim/files/patch-Ck.cpp
@@ -0,0 +1,11 @@
+--- Ck.cpp.orig 2020-02-15 19:48:07 UTC
++++ Ck.cpp
+@@ -91,7 +91,7 @@ namespace Ck {
+
+ vt = *((long *)return_value);
+
+- std::snprintf(device, 32, "/dev/tty%ld", vt);
++ std::snprintf(device, 32, "/dev/ttyv%ld", vt-1);
+
+ if(return_value)
+ XFree(return_value);