aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-08-29 23:16:13 +0000
committerWill Andrews <will@FreeBSD.org>2001-08-29 23:16:13 +0000
commit174743bd5ddef6ae9f435be75fb1c0fa4b251433 (patch)
treeb40d9a65fbfa5fdc64c42a68874f4f97967bb534 /x11
parent120285b2502d6fb4785899dc69ac279ce1e7074b (diff)
downloadports-174743bd5ddef6ae9f435be75fb1c0fa4b251433.tar.gz
ports-174743bd5ddef6ae9f435be75fb1c0fa4b251433.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/kdelibs2/Makefile2
-rw-r--r--x11/kdelibs2/files/patch-kdoctools::xml2man.cpp13
-rw-r--r--x11/kdelibs3/Makefile2
-rw-r--r--x11/kdelibs3/files/patch-kdoctools::xml2man.cpp13
-rw-r--r--x11/kdelibs4/Makefile2
-rw-r--r--x11/kdelibs4/files/patch-kdoctools::xml2man.cpp13
6 files changed, 42 insertions, 3 deletions
diff --git a/x11/kdelibs2/Makefile b/x11/kdelibs2/Makefile
index 540b32e9e15d..5765e85fda27 100644
--- a/x11/kdelibs2/Makefile
+++ b/x11/kdelibs2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kdelibs
PORTVERSION= 2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11/kdelibs2/files/patch-kdoctools::xml2man.cpp b/x11/kdelibs2/files/patch-kdoctools::xml2man.cpp
new file mode 100644
index 000000000000..fb020b58532c
--- /dev/null
+++ b/x11/kdelibs2/files/patch-kdoctools::xml2man.cpp
@@ -0,0 +1,13 @@
+--- kdoctools/xml2man.cpp Sat Jul 28 23:55:05 2001
++++ kdoctools/xml2man.cpp.new Wed Aug 29 18:10:54 2001
+@@ -63,9 +63,7 @@
+ QString pat = args->arg( 0 );
+ QFile xmlFile( pat );
+ xmlFile.open(IO_ReadOnly);
+- QCString contents;
+- contents.assign(xmlFile.readAll());
+- contents.truncate(xmlFile.size());
++ QCString contents(xmlFile.radAll(), xmlFile.size() + 1);
+ xmlFile.close();
+
+ contents.replace( QRegExp( "<!--[^-]*-->" ), "" );
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index 540b32e9e15d..5765e85fda27 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kdelibs
PORTVERSION= 2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11/kdelibs3/files/patch-kdoctools::xml2man.cpp b/x11/kdelibs3/files/patch-kdoctools::xml2man.cpp
new file mode 100644
index 000000000000..fb020b58532c
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kdoctools::xml2man.cpp
@@ -0,0 +1,13 @@
+--- kdoctools/xml2man.cpp Sat Jul 28 23:55:05 2001
++++ kdoctools/xml2man.cpp.new Wed Aug 29 18:10:54 2001
+@@ -63,9 +63,7 @@
+ QString pat = args->arg( 0 );
+ QFile xmlFile( pat );
+ xmlFile.open(IO_ReadOnly);
+- QCString contents;
+- contents.assign(xmlFile.readAll());
+- contents.truncate(xmlFile.size());
++ QCString contents(xmlFile.radAll(), xmlFile.size() + 1);
+ xmlFile.close();
+
+ contents.replace( QRegExp( "<!--[^-]*-->" ), "" );
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 540b32e9e15d..5765e85fda27 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kdelibs
PORTVERSION= 2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11/kdelibs4/files/patch-kdoctools::xml2man.cpp b/x11/kdelibs4/files/patch-kdoctools::xml2man.cpp
new file mode 100644
index 000000000000..fb020b58532c
--- /dev/null
+++ b/x11/kdelibs4/files/patch-kdoctools::xml2man.cpp
@@ -0,0 +1,13 @@
+--- kdoctools/xml2man.cpp Sat Jul 28 23:55:05 2001
++++ kdoctools/xml2man.cpp.new Wed Aug 29 18:10:54 2001
+@@ -63,9 +63,7 @@
+ QString pat = args->arg( 0 );
+ QFile xmlFile( pat );
+ xmlFile.open(IO_ReadOnly);
+- QCString contents;
+- contents.assign(xmlFile.readAll());
+- contents.truncate(xmlFile.size());
++ QCString contents(xmlFile.radAll(), xmlFile.size() + 1);
+ xmlFile.close();
+
+ contents.replace( QRegExp( "<!--[^-]*-->" ), "" );