aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-03-29 15:00:21 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-03-29 15:00:21 +0000
commit17f6bd3ad56c182c118ebd4868e305de3e449373 (patch)
tree92df07c11696118133d0de0996ec161d02d5d047 /x11
parent92afe57c3eecfde509d92a7e68564ca50318b4c7 (diff)
downloadports-17f6bd3ad56c182c118ebd4868e305de3e449373.tar.gz
ports-17f6bd3ad56c182c118ebd4868e305de3e449373.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/wshowkeys/Makefile25
-rw-r--r--x11/wshowkeys/distinfo3
-rw-r--r--x11/wshowkeys/files/patch-devmgr.c14
-rw-r--r--x11/wshowkeys/pkg-descr4
5 files changed, 47 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index c53409cfad7f..e40d09447651 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -353,6 +353,7 @@
SUBDIR += wmxss
SUBDIR += wofi
SUBDIR += workrave
+ SUBDIR += wshowkeys
SUBDIR += x11perf
SUBDIR += x3270
SUBDIR += xaniroc
diff --git a/x11/wshowkeys/Makefile b/x11/wshowkeys/Makefile
new file mode 100644
index 000000000000..deafad826280
--- /dev/null
+++ b/x11/wshowkeys/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= wshowkeys
+PORTVERSION= s20190925
+DISTVERSIONSUFFIX= -0-ga9bf6bc
+CATEGORIES= x11
+MASTER_SITES= https://git.sr.ht/~sircmpwn/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Display keystrokes for screencasts on Wayland
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols
+LIB_DEPENDS= libudev.so:devel/libudev-devd \
+ libwayland-client.so:graphics/wayland \
+ libinput.so:x11/libinput \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 gnome meson pkgconfig
+USE_GNOME= cairo pango
+PLIST_FILES= "@(,,4755) bin/${PORTNAME}"
+
+.include <bsd.port.mk>
diff --git a/x11/wshowkeys/distinfo b/x11/wshowkeys/distinfo
new file mode 100644
index 000000000000..9af32cb819df
--- /dev/null
+++ b/x11/wshowkeys/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1569466088
+SHA256 (wshowkeys-s20190925-0-ga9bf6bc.tar.gz) = 11f1428bd85d9670e9cbd4473b4d1b3de7e6a232400df178aac830b9157bb137
+SIZE (wshowkeys-s20190925-0-ga9bf6bc.tar.gz) = 26678
diff --git a/x11/wshowkeys/files/patch-devmgr.c b/x11/wshowkeys/files/patch-devmgr.c
new file mode 100644
index 000000000000..1c0983730354
--- /dev/null
+++ b/x11/wshowkeys/files/patch-devmgr.c
@@ -0,0 +1,14 @@
+https://lists.sr.ht/~sircmpwn/public-inbox/patches/10091
+
+--- devmgr.c.orig 2019-09-26 02:48:08 UTC
++++ devmgr.c
+@@ -4,6 +4,9 @@
+ *
+ * NOTICE: Most of this code runs as root.
+ */
++#ifdef __FreeBSD__
++#define __BSD_VISIBLE 1
++#endif
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <libinput.h>
diff --git a/x11/wshowkeys/pkg-descr b/x11/wshowkeys/pkg-descr
new file mode 100644
index 000000000000..4adc22ae4b06
--- /dev/null
+++ b/x11/wshowkeys/pkg-descr
@@ -0,0 +1,4 @@
+Displays keypresses on screen on supported Wayland compositors
+(requires wlr_layer_shell_v1 support).
+
+WWW: https://git.sr.ht/~sircmpwn/wshowkeys