aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2010-07-18 05:33:10 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2010-07-18 05:33:10 +0000
commit7adb6c0074e549adc718aaa9cba628c5ae3a1b4d (patch)
tree88d11927e988ef7d71b7ba94333e4e70f1ca359a /x11
parentcbf6479d199fff27d33093df9a293b8ae5ad65de (diff)
downloadports-7adb6c0074e549adc718aaa9cba628c5ae3a1b4d.tar.gz
ports-7adb6c0074e549adc718aaa9cba628c5ae3a1b4d.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/mlterm/Makefile7
-rw-r--r--x11/mlterm/distinfo6
-rw-r--r--x11/mlterm/files/patch-configure25
-rw-r--r--x11/mlterm/files/patch-contrib_tool_mlterm-memu_mlterm-menu.c32
-rw-r--r--x11/mlterm/files/patch-inputmethod_iiimf_im_iiimf_aux.c29
-rw-r--r--x11/mlterm/files/patch-kiklib:configure144
-rw-r--r--x11/mlterm/pkg-plist15
7 files changed, 61 insertions, 197 deletions
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 3cf56258ee9e..41fb0dea164e 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= mlterm
-PORTVERSION= 2.9.4
-PORTREVISION= 9
+PORTVERSION= 3.0.1
CATEGORIES= x11
-MASTER_SITES= SF/${PORTNAME}/01%20release/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/01release/${PORTNAME}-${PORTVERSION}
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Multilingual X11 terminal emulator
@@ -26,7 +25,7 @@ CONFIGURE_ARGS= --with-imagelib=gdk-pixbuf --enable-utmp \
--with-tools="mlclient,mlconfig,mlterm-menu,mlcc,w3mmlconfig" \
--with-type-engines="xcore,xft"
CONFIGURE_ENV= LIBS="${LIBS} -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl" CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/iiim"
-
+MAKE_JOBS_UNSAFE= yes
OPTIONS= FRIBIDI "Use Fribidi for BiDi rendering" off \
UIM "uim support (experimental)" off \
M17NLIB "m17n library support (experimental)" off \
diff --git a/x11/mlterm/distinfo b/x11/mlterm/distinfo
index d76d4a45415f..1ada3a02faa4 100644
--- a/x11/mlterm/distinfo
+++ b/x11/mlterm/distinfo
@@ -1,3 +1,3 @@
-MD5 (mlterm-2.9.4.tar.gz) = 67fc33f09da045f86b0d4ceebed76aac
-SHA256 (mlterm-2.9.4.tar.gz) = 6b90e880cbb5dfc091aa0e2da9c75675a84b13bf0f628dc02250026bbbcebe4d
-SIZE (mlterm-2.9.4.tar.gz) = 1991879
+MD5 (mlterm-3.0.1.tar.gz) = 5a658c6f37bebb954899e755628ed4fb
+SHA256 (mlterm-3.0.1.tar.gz) = ad52d19be474d07ae0237304af4caf899fb54448df32e0e7909a12f668b796dd
+SIZE (mlterm-3.0.1.tar.gz) = 2645619
diff --git a/x11/mlterm/files/patch-configure b/x11/mlterm/files/patch-configure
deleted file mode 100644
index 29701bbc5d86..000000000000
--- a/x11/mlterm/files/patch-configure
+++ /dev/null
@@ -1,25 +0,0 @@
---- configure.orig Fri Jun 20 10:53:15 2003
-+++ configure Fri Jun 20 11:00:52 2003
-@@ -9103,11 +9103,6 @@
- top_srcdir="$ac_dots$ac_given_srcdir" ;;
- esac
-
-- case "$ac_given_INSTALL" in
-- [/$]*) INSTALL="$ac_given_INSTALL" ;;
-- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
-- esac
--
- echo creating "$ac_file"
- rm -f "$ac_file"
- configure_input="Generated automatically from `echo $ac_file_in|sed 's%.*/%%'` by configure."
-@@ -9469,10 +9464,6 @@
- *) # Relative path.
- ac_sub_cache_file="$ac_dots$cache_file" ;;
- esac
-- case "$ac_given_INSTALL" in
-- [/$]*) INSTALL="$ac_given_INSTALL" ;;
-- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
-- esac
-
- echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
- # The eval makes quoting arguments work.
diff --git a/x11/mlterm/files/patch-contrib_tool_mlterm-memu_mlterm-menu.c b/x11/mlterm/files/patch-contrib_tool_mlterm-memu_mlterm-menu.c
deleted file mode 100644
index c316951b594e..000000000000
--- a/x11/mlterm/files/patch-contrib_tool_mlterm-memu_mlterm-menu.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- contrib/tool/mlterm-menu/mlterm-menu.c.orig 2008-08-06 08:21:01.000000000 +0400
-+++ contrib/tool/mlterm-menu/mlterm-menu.c 2008-08-06 08:30:00.000000000 +0400
-@@ -201,6 +201,7 @@
- GtkWidget* item;
- char* pty_list;
- char* name;
-+ gchar *utf8_name;
- char* pty;
- char* command;
- int is_active;
-@@ -228,11 +229,12 @@
- name = pty;
- if (strncmp(name, "/dev/", 5) == 0)
- name += 5;
-+ utf8_name = g_locale_to_utf8(name, -1, NULL, NULL, NULL);
-
- command = malloc(strlen(pty) + 12);
- sprintf(command, "select_pty=%s", pty);
-
-- item = gtk_radio_menu_item_new_with_label(group, name);
-+ item = gtk_radio_menu_item_new_with_label(group, utf8_name);
- group = gtk_radio_menu_item_group(GTK_RADIO_MENU_ITEM(item));
-
- gtk_signal_connect(GTK_OBJECT(item), "toggled",
-@@ -240,6 +242,7 @@
- (gpointer) command);
-
- gtk_menu_append(menu, item);
-+ g_free(utf8_name);
- if (is_active) {
- gtk_check_menu_item_set_active(GTK_CHECK_MENU_ITEM(item),
- TRUE);
diff --git a/x11/mlterm/files/patch-inputmethod_iiimf_im_iiimf_aux.c b/x11/mlterm/files/patch-inputmethod_iiimf_im_iiimf_aux.c
new file mode 100644
index 000000000000..cf69c6e00a06
--- /dev/null
+++ b/x11/mlterm/files/patch-inputmethod_iiimf_im_iiimf_aux.c
@@ -0,0 +1,29 @@
+--- inputmethod/iiimf/im_iiimf_aux.c.orig 2010-07-17 17:47:04.000000000 +0900
++++ inputmethod/iiimf/im_iiimf_aux.c 2010-07-17 17:49:47.000000000 +0900
+@@ -1134,7 +1134,7 @@
+ return NULL ;
+ }
+
+- return ((x_window_t *)aux->iiimf->im.listener->self)->display ;
++ return ((x_window_t *)aux->iiimf->im.listener->self)->disp->display ;
+ }
+
+ static Window
+@@ -1458,7 +1458,7 @@
+ return -1 ;
+ }
+
+- return ((x_window_t *)aux->iiimf->im.listener->self)->screen ;
++ return ((x_window_t *)aux->iiimf->im.listener->self)->disp->screen ;
+ }
+
+ static int
+@@ -1491,7 +1491,7 @@
+ point->x = (x > SHRT_MAX) ? SHRT_MAX : x ;
+ point->y = (y > SHRT_MAX) ? SHRT_MAX : y ;
+
+- return ((x_window_t *)aux->iiimf->im.listener->self)->screen ;
++ return ((x_window_t *)aux->iiimf->im.listener->self)->disp->screen ;
+ }
+
+ static int
diff --git a/x11/mlterm/files/patch-kiklib:configure b/x11/mlterm/files/patch-kiklib:configure
index d144377af3ce..95fee4c08958 100644
--- a/x11/mlterm/files/patch-kiklib:configure
+++ b/x11/mlterm/files/patch-kiklib:configure
@@ -1,135 +1,15 @@
---- kiklib/configure.orig 2006-10-20 18:04:01.000000000 +0900
-+++ kiklib/configure 2009-01-25 17:55:52.000000000 +0900
-@@ -7132,52 +7132,6 @@
- UTMP_NAME=none
- UTMP_LIBS=
- fi
--# libutempter
--if test -z "$UTMP_NAME" ; then
-- echo $ac_n "checking for addToUtmp in -lutempter""... $ac_c" 1>&6
--echo "configure:7139: checking for addToUtmp in -lutempter" >&5
--ac_lib_var=`echo utempter'_'addToUtmp | sed 'y%./+-%__p_%'`
--if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
-- echo $ac_n "(cached) $ac_c" 1>&6
--else
-- ac_save_LIBS="$LIBS"
--LIBS="-lutempter $LIBS"
--cat > conftest.$ac_ext <<EOF
--#line 7147 "configure"
--#include "confdefs.h"
--/* Override any gcc2 internal prototype to avoid an error. */
--/* We use char because int might match the return type of a gcc2
-- builtin and then its argument prototype would still apply. */
--char addToUtmp();
--
--int main() {
--addToUtmp()
--; return 0; }
--EOF
--if { (eval echo configure:7158: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-- rm -rf conftest*
-- eval "ac_cv_lib_$ac_lib_var=yes"
--else
-- echo "configure: failed program was:" >&5
-- cat conftest.$ac_ext >&5
-- rm -rf conftest*
-- eval "ac_cv_lib_$ac_lib_var=no"
--fi
--rm -f conftest*
--LIBS="$ac_save_LIBS"
--
--fi
--if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
-- echo "$ac_t""yes" 1>&6
--
-- UTMP_NAME=utmper
-- UTMP_LIBS="-lutempter -lutil"
--
--else
-- echo "$ac_t""no" 1>&6
--fi
--
--fi
- # setutent() (SysV)
- if test -z "$UTMP_NAME" ; then
- echo $ac_n "checking for setutent""... $ac_c" 1>&6
-@@ -7299,66 +7253,7 @@
- if test "$kik_cv_mingw32" = yes ; then
- kik_cv_pty=win32
- else
-- echo $ac_n "checking for posix_openpt""... $ac_c" 1>&6
--echo "configure:7304: checking for posix_openpt" >&5
--if eval "test \"`echo '$''{'ac_cv_func_posix_openpt'+set}'`\" = set"; then
-- echo $ac_n "(cached) $ac_c" 1>&6
--else
-- cat > conftest.$ac_ext <<EOF
--#line 7309 "configure"
--#include "confdefs.h"
--/* System header to define __stub macros and hopefully few prototypes,
-- which can conflict with char posix_openpt(); below. */
--#include <assert.h>
--/* Override any gcc2 internal prototype to avoid an error. */
--/* We use char because int might match the return type of a gcc2
-- builtin and then its argument prototype would still apply. */
--char posix_openpt();
--
--int main() {
--
--/* The GNU C library defines this for functions which it implements
-- to always fail with ENOSYS. Some functions are actually named
-- something starting with __ and the normal name is an alias. */
--#if defined (__stub_posix_openpt) || defined (__stub___posix_openpt)
--choke me
--#else
--posix_openpt();
--#endif
--
--; return 0; }
--EOF
--if { (eval echo configure:7332: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-- rm -rf conftest*
-- eval "ac_cv_func_posix_openpt=yes"
--else
-- echo "configure: failed program was:" >&5
-- cat conftest.$ac_ext >&5
-- rm -rf conftest*
-- eval "ac_cv_func_posix_openpt=no"
--fi
--rm -f conftest*
--fi
--
--if eval "test \"`echo '$ac_cv_func_'posix_openpt`\" = yes"; then
-- echo "$ac_t""yes" 1>&6
--
-- cat >> confdefs.h <<\EOF
--#define HAVE_POSIX_OPENPT
--EOF
--
-- kik_cv_pty=streams
--
--else
-- echo "$ac_t""no" 1>&6
--
-- if test -c /dev/ptmx ; then
-- kik_cv_pty=streams
-- else
-- kik_cv_pty=bsd
-- fi
--fi
--
-+ kik_cv_pty=bsd
+--- kiklib/configure.orig 2010-07-17 17:06:50.000000000 +0900
++++ kiklib/configure 2010-07-17 17:13:09.000000000 +0900
+@@ -23814,6 +23814,12 @@
fi
fi
-@@ -7625,11 +7520,6 @@
- top_srcdir="$ac_dots$ac_given_srcdir" ;;
- esac
-
-- case "$ac_given_INSTALL" in
-- [/$]*) INSTALL="$ac_given_INSTALL" ;;
-- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
-- esac
--
- echo creating "$ac_file"
- rm -f "$ac_file"
- configure_input="Generated automatically from `echo $ac_file_in|sed 's%.*/%%'` by configure."
++case $host_os in
++ freebsd*)
++ kik_cv_pty=bsd
++ ;;
++esac
++
+ { $as_echo "$as_me:$LINENO: result: $kik_cv_pty" >&5
+ $as_echo "$kik_cv_pty" >&6; }
+ PTY_NAME="${kik_cv_pty}"
diff --git a/x11/mlterm/pkg-plist b/x11/mlterm/pkg-plist
index aea0e23cb949..6d795d6a4565 100644
--- a/x11/mlterm/pkg-plist
+++ b/x11/mlterm/pkg-plist
@@ -1,6 +1,7 @@
bin/mlcc
bin/mlterm
bin/mlclient
+bin/mlclientx
bin/w3mmlconfig
etc/mlterm/aafont
etc/mlterm/color
@@ -21,7 +22,19 @@ lib/libkik.so.11
lib/libmkf.a
lib/libmkf.la
lib/libmkf.so
-lib/libmkf.so.13
+lib/libmkf.so.14
+lib/mkf/libmkf_8bits.a
+lib/mkf/libmkf_8bits.la
+lib/mkf/libmkf_8bits.so
+lib/mkf/libmkf_jajp.a
+lib/mkf/libmkf_jajp.la
+lib/mkf/libmkf_jajp.so
+lib/mkf/libmkf_kokr.a
+lib/mkf/libmkf_kokr.la
+lib/mkf/libmkf_kokr.so
+lib/mkf/libmkf_zh.a
+lib/mkf/libmkf_zh.la
+lib/mkf/libmkf_zh.so
lib/mlterm/libathena.a
lib/mlterm/libathena.la
lib/mlterm/libathena.so