aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-08-17 22:17:56 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-08-17 22:17:56 +0000
commit6c3685400f1aff13e58b1131094b7c9c4730cd81 (patch)
tree5debe1b1be0329106440d7a3d7460a1574165aae /x11
parentb02a764cbac1a66aee710ecf7486dad209760264 (diff)
downloadports-6c3685400f1aff13e58b1131094b7c9c4730cd81.tar.gz
ports-6c3685400f1aff13e58b1131094b7c9c4730cd81.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/rxvt-unicode/Makefile264
-rw-r--r--x11/rxvt-unicode/distinfo4
-rw-r--r--x11/rxvt-unicode/files/patch-aa11
-rw-r--r--x11/rxvt-unicode/files/patch-ab12
-rw-r--r--x11/rxvt-unicode/files/patch-ac20
-rw-r--r--x11/rxvt-unicode/files/patch-ad20
-rw-r--r--x11/rxvt-unicode/files/patch-src::Makefile.in40
-rw-r--r--x11/rxvt-unicode/files/patch-src::command.C29
-rw-r--r--x11/rxvt-unicode/files/patch-src::gentables8
-rw-r--r--x11/rxvt-unicode/files/patch-src::ptytty.C14
-rw-r--r--x11/rxvt-unicode/files/patch-src::rxvtutil.C18
-rw-r--r--x11/rxvt-unicode/pkg-descr12
-rw-r--r--x11/rxvt-unicode/pkg-plist14
14 files changed, 313 insertions, 154 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 841637f6a759..88db42be5b1d 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -155,6 +155,7 @@
SUBDIR += ruby-gtktrayicon
SUBDIR += rxvt
SUBDIR += rxvt-devel
+ SUBDIR += rxvt-unicode
SUBDIR += settitle
SUBDIR += silo
SUBDIR += sisctrl
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index b3b16f835582..85e23ac5ece0 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -4,94 +4,194 @@
#
# $FreeBSD$
#
-# If possible, please consider updating the simple ports/x11-clocks/rclock
-# (and maybe ports/chinese/rxvt) when you upgrade rxvt. These ports all use
-# the same distfile.
-
-PORTNAME= rxvt
-PORTVERSION= 2.6.4
-PORTREVISION= 1
-CATEGORIES+= x11
-MASTER_SITES= ftp://ftp.rxvt.org/pub/rxvt/%SUBDIR%/ \
- ftp://ftp.ics.es.osaka-u.ac.jp/pub/mirrors/rxvt/%SUBDIR%/ \
- ftp://ftp.fu-berlin.de/unix/X11/terms/rxvt/%SUBDIR%/
-MASTER_SITE_SUBDIR= . old devel
-
-MAINTAINER= lioux@FreeBSD.org
-COMMENT= A low memory usage xterm replacement that supports color
-
-USE_X_PREFIX= yes
-USE_XPM= yes
-USE_SIZE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-utmp --enable-wtmp \
- --with-xpm --enable-xpm-background --enable-transparency
-USE_BZIP2= yes
-MAN1= rxvt.1
-PLIST_FILES= bin/rxvt
-
-# enable big5 support
-.if defined(WITH_BIG5)
-CONFIGURE_ARGS+= --enable-big5
-.endif # WITH_BIG5
-#
-# enable gb support
-.if defined(WITH_GB)
-CONFIGURE_ARGS+= --enable-gb
-.endif # WITH_GB
-#
-# enable greek keyboard support
-.if defined(WITH_GREEK_KEYBOARD)
-CONFIGURE_ARGS+= --enable-greek
-.endif # WITH_GREEK_KEYBOARD
-#
-# enable half width/height shadows scrollbar
+
+PORTNAME= rxvt-unicode
+PORTVERSION= 3.7
+CATEGORIES= x11
+MASTER_SITES= http://dist.schmorp.de/rxvt-unicode/
+MASTER_SITE_SUBDIR= . Attic
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= A clone of the terminal emulator rxvt modified to support Unicode
+
+LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+USE_PERL5_BUILD= yes
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ARGS= --enable-shared --enable-everything
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+USE_BZIP2= yes
+
+CONFLICTS= rxvt-devel-2*
+
+MAN1= urxvt.1 urxvtc.1 urxvtd.1
+MAN7= urxvt.7
+
+PORTDOCS1= README.unicode Changes
+PORTDOCS= README.menu ${PORTDOCS1}
+EXAMPLES= example.menu jedmenu.sl menu rxvt.menu rxvt.zh-menu terminal.menu
+
+# disable XIM (X Input Method) protocol support
+.if defined(WITHOUT_XIM)
+CONFIGURE_ARGS+= --disable-xim
+.endif
+
+# disable support for Unicode codepoints above 65535
+.if defined(WITHOUT_UNICODE3)
+CONFIGURE_ARGS+= --disable-unicode3
+.endif
+
+# disable automatic composition of combining characters
+# into composite characters
+.if defined(WITHOUT_COMBINING)
+CONFIGURE_ARGS+= --disable-combining
+.endif
+
+# disable support for menu bar system
+.if defined(WITHOUT_MENUBAR)
+CONFIGURE_ARGS+= --disable-menubar
+.endif
+
+# disable support for the original rxvt scrollbar
+.if defined(WITHOUT_RXVT_SCROLLBAR)
+CONFIGURE_ARGS+= --disable-rxvt-scroll
+.endif
+
+# disable support for a NeXT-like scrollbar
+.if defined(WITHOUT_NEXT_SCROLLBAR)
+CONFIGURE_ARGS+= --disable-next-scroll
+.endif
+
+# disable support for an Xterm-like scrollbar
+.if defined(WITHOUT_XTERM_SCROLLBAR)
+CONFIGURE_ARGS+= --disable-xterm-scroll
+.endif
+
+# disable support for a very unobtrusive, plain-looking scrollbar
+.if defined(WITHOUT_PLAIN_SCROLLBAR)
+CONFIGURE_ARGS+= --disable-plain-scroll
+.endif
+
+# enable half width/height shadows rxvt scrollbar
.if defined(WITH_HALF_SHADOW)
CONFIGURE_ARGS+= --enable-half-shadow
.endif
-#
-# enable kanji support
-.if defined(WITH_KANJI)
-CONFIGURE_ARGS+= --enable-kanji
-.endif # WITH_KANJI
-#
-# enable menubar
-.if defined(WITH_MENUBAR)
-CONFIGURE_ARGS+= --enable-menubar
-.endif # WITH_MENUBAR
-#
-# enable NeXT style scrollbar
-.if defined(WITH_NEXT_SCROLLBAR)
-CONFIGURE_ARGS+= --enable-next-scroll
+
+# disable any handling of the backspace key by rxvt
+# let the X server do it
+.if defined(WITHOUT_BACKSPACE_KEY)
+CONFIGURE_ARGS+= --disable-backspace-key
+.endif
+
+# disable any handling of the delete key by rxvt
+.if defined(WITHOUT_DELETE_KEY)
+CONFIGURE_ARGS+= --disable-delete-key
+.endif
+
+# disable support to provide user specified line spacing between text rows
+.if defined(WITHOUT_LINESPACE)
+CONFIGURE_ARGS+= --disable-linespace
+.endif
+
+# enable scrolling via mouse wheel or buttons 4 & 5
+.if defined(WITHOUT_MOUSEWHEEL)
+CONFIGURE_ARGS+= --disable-mousewheel
+.endif
+
+# enable smart resize
+.if defined(WITHOUT_SMART_RESIZE)
+CONFIGURE_ARGS+= --disable-smart-resize
+.else
+CONFIGURE_ARGS+= --enable-smart-resize
.endif
-#
-# XIM (X Input Method) protocol support
-.ifndef(WITHOUT_XIM)
-CONFIGURE_ARGS+= --enable-xim
-.endif # WITH_XIM
-#
-# enable Xterm style scrollbar
-.if defined(WITH_XTERM_SCROLLBAR)
-CONFIGURE_ARGS+= --enable-xterm-scroll
-.endif # WITH_XTERM_SCROLLBAR
-#
-pre-fetch:
- @${ECHO_MSG} ""
+# add support for 256 colours rather than the base 16 colours
+.if defined(WITHOUT_256_COLORS)
+CONFIGURE_ARGS+= --disable-256-color
+.else
+CONFIGURE_ARGS+= --enable-256-color
+.endif
+
+CONFIGURE_ENV+= LIBS="-lutil"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= missing wide-character functions in FreeBSD-4.x libc
+.endif
+
+.if ${OSVERSION} < 502110
+RUN_DEPENDS+= ${LOCALBASE}/share/locale/fr_FR.UTF-8/LC_TIME:${PORTSDIR}/misc/utf8locale
+.endif
+
+# compile in support for additional codeset groups
+.if defined(WITH_ENCODING)
+AVAIL_ENC= jp jp_ext kr cn cn_ext all
+. for ENC in ${AVAIL_ENC}
+. if (${WITH_ENCODING} == ${ENC})
+_ENC= ${ENC}
+. endif
+. endfor
+. if !defined(_ENC)
+. error Invalid encoding for WITH_ENCODING
+. endif
+.else
+. if defined(PACKAGE_BUILDING)
+WITH_ENCODING= all
+. endif
+.endif
+.if defined(WITH_ENCODING)
+CONFIGURE_ARGS+= --with-codesets=${WITH_ENCODING}
+.endif # WITH_ENCODING
+
+pre-everything::
+ @${ECHO_MSG}
@${ECHO_MSG} "You may use the following build options:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "WITHOUT_XIM=yes disable support for XIM (X Input Method) protocol"
- @${ECHO_MSG} "WITH_BIG5=yes add support for Chinese characters (BIG5)"
- @${ECHO_MSG} "WITH_GB=yes add support for Chinese characters (GB)"
- @${ECHO_MSG} "WITH_GREEK_KEYBOARD=yes add support for greek keyboard"
- @${ECHO_MSG} "WITH_HALF_SHADOW=yes use half width/height shadows on non-Xterm scrollbar"
- @${ECHO_MSG} "WITH_KANJI=yes add support for Kanji characters"
- @${ECHO_MSG} "WITH_MENUBAR=yes add support for rxvt menu bar system"
- @${ECHO_MSG} "WITH_NEXT_SCROLLBAR=yes add support for a NeXT-like scrollbar"
- @${ECHO_MSG} "WITH_XTERM_SCROLLBAR=yes make the scrollbar look like an Xterm scrollbar"
- @${ECHO_MSG} "WITH_CLEARTEXTPASSWD=yes use cleartext passwords"
+ @${ECHO_MSG}
+ @${ECHO_MSG} "WITHOUT_XIM disable support for XIM (X Input Method) protocol"
+ @${ECHO_MSG} "WITHOUT_MENUBAR disable support for menu bar system"
+ @${ECHO_MSG} "WITHOUT_RXVT_SCROLLBAR disable support for the original rxvt scrollbar"
+ @${ECHO_MSG} "WITHOUT_NEXT_SCROLLBAR disable support for a NeXT-like scrollbar"
+ @${ECHO_MSG} "WITHOUT_XTERM_SCROLLBAR disable support for an Xterm-like scrollbar"
+ @${ECHO_MSG} "WITHOUT_PLAIN_SCROLLBAR disable support for a plain-looking scrollbar"
+ @${ECHO_MSG} "WITH_HALF_SHADOW use half width/height shadows on rxvt scrollbar"
+ @${ECHO_MSG} "WITHOUT_BACKSPACE_KEY disable handling of the backspace key"
+ @${ECHO_MSG} "WITHOUT_DELETE_KEY disable handling of the delete key"
+ @${ECHO_MSG} "WITHOUT_LINESPACE disable support for line-spacing"
+ @${ECHO_MSG} "WITHOUT_MOUSEWHEEL disable support for scrolling via mouse wheel"
+ @${ECHO_MSG} "WITHOUT_SMART_RESIZE disable smart growth/shrink behaviour"
+ @${ECHO_MSG} "WITHOUT_256_COLORS disable smart growth/shrink behaviour"
+ @${ECHO_MSG}
+.ifndef(WITH_ENCODING)
+ @${ECHO_MSG} "==> You can compile in support for additional codeset groups by setting the WITH_ENCODING variable"
+ @${ECHO_MSG} '==> Options are: "jp" common japanese encodings;'
+ @${ECHO_MSG} ' "jp_ext" rarely used but big japanese encodings;'
+ @${ECHO_MSG} ' "kr" korean encodings;'
+ @${ECHO_MSG} ' "cn" common chinese encodings;'
+ @${ECHO_MSG} ' "cn_ext" rarely used but very big chinese encodigs;'
+ @${ECHO_MSG} ' "all" all of the above;'
+ @${ECHO_MSG} '==> For example, "WITH_ENCODING=kr" for korean encodings.'
+ @${ECHO_MSG}
+.endif
+
+pre-configure:
+ @${PERL} -pi -e 's|(PTYCHAR2\s+"[^"]+)"|\1ghijklmnopqrstuv"|' \
+ ${WRKSRC}/src/ptytty.C
post-install:
- @${CHMOD} 4711 ${PREFIX}/bin/rxvt
+ @${CHMOD} 4711 ${PREFIX}/bin/urxvt
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ @${CP} ${PORTDOCS1:S|^|${WRKSRC}/|} ${WRKSRC}/doc
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/doc/menu/|} ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/rxvt-unicode/distinfo b/x11/rxvt-unicode/distinfo
index ea5535de2d06..ad6d36949c5b 100644
--- a/x11/rxvt-unicode/distinfo
+++ b/x11/rxvt-unicode/distinfo
@@ -1,2 +1,2 @@
-MD5 (rxvt-2.6.4.tar.bz2) = 0f21182dbcf8f48087ef9980dafb8c35
-SIZE (rxvt-2.6.4.tar.bz2) = 252636
+MD5 (rxvt-unicode-3.7.tar.bz2) = 96869b0f76def0227b2469aa04386076
+SIZE (rxvt-unicode-3.7.tar.bz2) = 795500
diff --git a/x11/rxvt-unicode/files/patch-aa b/x11/rxvt-unicode/files/patch-aa
deleted file mode 100644
index e90f485112ef..000000000000
--- a/x11/rxvt-unicode/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Mon Aug 21 23:31:36 2000
-+++ Makefile.in Mon Aug 21 23:31:51 2000
-@@ -9,7 +9,7 @@
- first_rule: all
- dummy:
-
--subdirs = src doc rclock src/graphics
-+subdirs = src doc
-
- DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
-
diff --git a/x11/rxvt-unicode/files/patch-ab b/x11/rxvt-unicode/files/patch-ab
deleted file mode 100644
index a2c62c26ff94..000000000000
--- a/x11/rxvt-unicode/files/patch-ab
+++ /dev/null
@@ -1,12 +0,0 @@
---- doc/Makefile.in.orig Mon Aug 21 23:32:21 2000
-+++ doc/Makefile.in Mon Aug 21 23:32:44 2000
-@@ -41,9 +41,6 @@
-
- all: rxvt.1
-
--rxvt.1: Makefile
-- @if test x$(TBL) = x; then : ; else echo "$(TBL) $(srcdir)/rxvt.tbl | grep -v '^.lf' > rxvt.1"; $(TBL) $(srcdir)/rxvt.tbl | grep -v '^.lf' > rxvt.1 ; fi
--
- SEDREPLACE = -e 's%@RXVT_VERSION@%$(VERSION)%g;'\
- -e 's%@RXVT_LSMDATE@%$(LSMDATE)%g;'\
- -e 's%@RXVT_DATE@%$(DATE)%g;'\
diff --git a/x11/rxvt-unicode/files/patch-ac b/x11/rxvt-unicode/files/patch-ac
deleted file mode 100644
index 5e70c833507b..000000000000
--- a/x11/rxvt-unicode/files/patch-ac
+++ /dev/null
@@ -1,20 +0,0 @@
---- autoconf/config.h.in.orig Mon Aug 21 23:33:43 2000
-+++ autoconf/config.h.in Mon Aug 21 23:34:39 2000
-@@ -161,7 +161,7 @@
- #undef HAVE_UTMP_HOST
-
- /* Define location of utmp */
--#undef RXVT_UTMP_FILE
-+#define RXVT_UTMP_FILE "/var/run/utmp"
-
- /* Define in utmpx.h has struct utmpx */
- #undef HAVE_STRUCT_UTMPX
-@@ -173,7 +173,7 @@
- #undef RXVT_UTMPX_FILE
-
- /* Define location of wtmp */
--#undef RXVT_WTMP_FILE
-+#define RXVT_WTMP_FILE "/var/log/wtmp"
-
- /* Define location of wtmpx */
- #undef RXVT_WTMPX_FILE
diff --git a/x11/rxvt-unicode/files/patch-ad b/x11/rxvt-unicode/files/patch-ad
deleted file mode 100644
index c057993b80dc..000000000000
--- a/x11/rxvt-unicode/files/patch-ad
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/command.c.orig Thu Apr 5 03:52:39 2001
-+++ src/command.c Fri Jun 22 13:36:57 2001
-@@ -322,7 +322,7 @@
- ttydev = tty_name;
-
- # define PTYCHAR1 "pqrstuvwxyz"
--# define PTYCHAR2 "0123456789abcdef"
-+# define PTYCHAR2 "0123456789abcdefghijklmnopqrstuv"
- for (c1 = PTYCHAR1; *c1; c1++) {
- ptydev[len] = ttydev[len] = *c1;
- for (c2 = PTYCHAR2; *c2; c2++) {
-@@ -2376,7 +2376,7 @@
- unsigned char buf[256];
-
- va_start(arg_ptr, fmt);
-- vsprintf(buf, fmt, arg_ptr);
-+ vsnprintf(buf, sizeof(buf), fmt, arg_ptr);
- va_end(arg_ptr);
- tt_write(buf, strlen(buf));
- }
diff --git a/x11/rxvt-unicode/files/patch-src::Makefile.in b/x11/rxvt-unicode/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..a0973a231a18
--- /dev/null
+++ b/x11/rxvt-unicode/files/patch-src::Makefile.in
@@ -0,0 +1,40 @@
+--- src/Makefile.in.orig Mon Aug 16 01:11:45 2004
++++ src/Makefile.in Tue Aug 17 21:25:56 2004
+@@ -72,13 +72,13 @@
+ $(COMPILE) -c $<
+
+ .C.lo:
+- $(LIBTOOL) --mode=compile $(COMPILE) -c $<
++ $(LIBTOOL) --tag=CXX --mode=compile $(COMPILE) -c $<
+
+ .s.lo:
+- $(LIBTOOL) --mode=compile $(COMPILE) -c $<
++ $(LIBTOOL) --tag=CXX --mode=compile $(COMPILE) -c $<
+
+ .S.lo:
+- $(LIBTOOL) --mode=compile $(COMPILE) -c $<
++ $(LIBTOOL) --tag=CXX --mode=compile $(COMPILE) -c $<
+
+ .C.intpro:
+ @$(RMF) $@.tmp
+@@ -91,16 +91,16 @@
+ all: allbin
+
+ rxvt: version.h rxvt.o librxvt.la
+- $(LIBTOOL) --mode=link $(LINK) rxvt.o librxvt.la $(LIBS) $(XLIB) $(DLIB) -o $@
++ $(LIBTOOL) --tag=CXX --mode=link $(LINK) rxvt.o librxvt.la $(LIBS) $(XLIB) $(DLIB) -o $@
+
+ rxvtd: version.h rxvtd.o librxvt.la rxvtdaemon.o
+- $(LIBTOOL) --mode=link $(LINK) rxvtd.o rxvtdaemon.o librxvt.la $(LIBS) $(XLIB) $(DLIB) -o $@
++ $(LIBTOOL) --tag=CXX --mode=link $(LINK) rxvtd.o rxvtdaemon.o librxvt.la $(LIBS) $(XLIB) $(DLIB) -o $@
+
+ rxvtc: version.h rxvtc.o rxvtdaemon.o
+- $(LIBTOOL) --mode=link $(LINK) rxvtc.o rxvtdaemon.o $(LIBS) $(DLIB) -o $@
++ $(LIBTOOL) --tag=CXX --mode=link $(LINK) rxvtc.o rxvtdaemon.o $(LIBS) $(DLIB) -o $@
+
+ librxvt.la: $(LIBOBJS)
+- $(LIBTOOL) --mode=link $(LINK) -rpath $(libdir) -version-info $(LIBVERSION) $(LIBOBJS) $(LIBS) -o $@
++ $(LIBTOOL) --tag=CXX --mode=link $(LINK) -rpath $(libdir) -version-info $(LIBVERSION) $(LIBOBJS) $(LIBS) -o $@
+
+ #-------------------------------------------------------------------------
+
diff --git a/x11/rxvt-unicode/files/patch-src::command.C b/x11/rxvt-unicode/files/patch-src::command.C
new file mode 100644
index 000000000000..98008058103b
--- /dev/null
+++ b/x11/rxvt-unicode/files/patch-src::command.C
@@ -0,0 +1,29 @@
+--- src/command.C.orig Mon Aug 16 09:13:25 2004
++++ src/command.C Tue Aug 17 23:49:02 2004
+@@ -51,6 +51,8 @@
+ #include "command.h"
+
+ #include <wchar.h>
++#include <sys/types.h>
++#include <signal.h>
+
+ /*----------------------------------------------------------------------*/
+
+@@ -4250,7 +4252,7 @@
+ {
+ if (v_buflen == 0)
+ {
+- ssize_t written = write (pty.pty, data, min (len, MAX_PTY_WRITE));
++ ssize_t written = write (pty.pty, data, min (len, (unsigned int) MAX_PTY_WRITE));
+
+ if ((unsigned int)written == len)
+ return;
+@@ -4268,7 +4270,7 @@
+
+ for (;;)
+ {
+- int written = write (pty.pty, v_buffer, min (MAX_PTY_WRITE, v_buflen));
++ int written = write (pty.pty, v_buffer, min ((unsigned int) MAX_PTY_WRITE, v_buflen));
+
+ if (written > 0)
+ {
diff --git a/x11/rxvt-unicode/files/patch-src::gentables b/x11/rxvt-unicode/files/patch-src::gentables
new file mode 100644
index 000000000000..8e3d82b5d7dd
--- /dev/null
+++ b/x11/rxvt-unicode/files/patch-src::gentables
@@ -0,0 +1,8 @@
+--- ./src/gentables.orig Wed Aug 4 04:59:09 2004
++++ ./src/gentables Tue Aug 10 00:03:21 2004
+@@ -1,4 +1,4 @@
+-#!/opt/bin/perl
++#!/usr/bin/perl
+
+ # the generated tables mostly have NOT been checked so far!
+
diff --git a/x11/rxvt-unicode/files/patch-src::ptytty.C b/x11/rxvt-unicode/files/patch-src::ptytty.C
new file mode 100644
index 000000000000..20d723c4434d
--- /dev/null
+++ b/x11/rxvt-unicode/files/patch-src::ptytty.C
@@ -0,0 +1,14 @@
+--- src/ptytty.C.orig Sat Jul 31 17:05:04 2004
++++ src/ptytty.C Tue Aug 10 18:16:01 2004
+@@ -33,6 +33,11 @@
+ #endif
+ #endif
+
++#if defined( __FreeBSD__)
++#include <sys/types.h>
++# include <libutil.h>
++#endif
++
+ #include <cstdio>
+ #ifdef HAVE_STDLIB_H
+ # include <cstdlib>
diff --git a/x11/rxvt-unicode/files/patch-src::rxvtutil.C b/x11/rxvt-unicode/files/patch-src::rxvtutil.C
new file mode 100644
index 000000000000..8a20f4b0a495
--- /dev/null
+++ b/x11/rxvt-unicode/files/patch-src::rxvtutil.C
@@ -0,0 +1,18 @@
+--- ./src/rxvtutil.C.orig Mon Aug 16 01:11:46 2004
++++ ./src/rxvtutil.C Tue Aug 17 23:15:04 2004
+@@ -4,6 +4,7 @@
+
+ #include "rxvtutil.h"
+
++#ifdef HAVE_SYS_BYTEORDER_H
+ class byteorder byteorder;
+
+ byteorder::byteorder ()
+@@ -20,6 +21,6 @@
+
+ e = w.u;
+ }
+-
++#endif
+
+
diff --git a/x11/rxvt-unicode/pkg-descr b/x11/rxvt-unicode/pkg-descr
index d72f27c3619c..4a3ee8f090bc 100644
--- a/x11/rxvt-unicode/pkg-descr
+++ b/x11/rxvt-unicode/pkg-descr
@@ -1,8 +1,6 @@
-Rxvt is an xterm replacement which uses a little less memory, and is
-suitable for use on machines with small memories. Tek4010 support
-is removed.
+rxvt-unicode is a clone of the well known terminal emulator rxvt, modified
+to store text in Unicode (either UCS-2 or UCS-4) and to use locale-correct
+input and output. It also supports mixing multiple fonts at the same time,
+including Xft fonts.
-Modifications were made by Rob Nation (nation@rocket.sanders.lockheed.com)
-to make it a little more compact, and to add and remove certain features.
-
-WWW: http://www.rxvt.org/
+WWW: http://software.schmorp.de/
diff --git a/x11/rxvt-unicode/pkg-plist b/x11/rxvt-unicode/pkg-plist
new file mode 100644
index 000000000000..6676ea5a35ec
--- /dev/null
+++ b/x11/rxvt-unicode/pkg-plist
@@ -0,0 +1,14 @@
+bin/urxvt
+bin/urxvtc
+bin/urxvtd
+include/rxvtlib.h
+lib/librxvt.a
+lib/librxvt.so
+lib/librxvt.so.3
+%%PORTDOCS%%%%EXAMPLESDIR%%/example.menu
+%%PORTDOCS%%%%EXAMPLESDIR%%/jedmenu.sl
+%%PORTDOCS%%%%EXAMPLESDIR%%/menu
+%%PORTDOCS%%%%EXAMPLESDIR%%/rxvt.menu
+%%PORTDOCS%%%%EXAMPLESDIR%%/rxvt.zh-menu
+%%PORTDOCS%%%%EXAMPLESDIR%%/terminal.menu
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%