aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-05-27 03:52:11 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-05-27 03:52:11 +0000
commitcfa3bb1e0a326f63ca6496a6f534b2c96d72553d (patch)
treed75984e8ea68b53fc669dd5a4dd875564fec870f /x11
parent9bc429ab3b873297d585aedf25018e084d537008 (diff)
downloadports-cfa3bb1e0a326f63ca6496a6f534b2c96d72553d.tar.gz
ports-cfa3bb1e0a326f63ca6496a6f534b2c96d72553d.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/gnome-applets/Makefile10
-rw-r--r--x11/gnome-applets/pkg-plist43
-rw-r--r--x11/gnomeapplets2/Makefile10
-rw-r--r--x11/gnomeapplets2/pkg-plist43
4 files changed, 106 insertions, 0 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 4e6cd0755f3b..cf84f04a3b2e 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -45,6 +45,8 @@ GCONF_SCHEMAS= charpick.schemas drivemount.schemas geyes.schemas \
mixer.schemas multiload.schemas \
stickynotes.schemas
+OPTIONS= MINI_COMMANDER "Enable mini-commander applet" off
+
FREEBSD_SYS?= /usr/src/sys
.include <bsd.port.pre.mk>
@@ -69,6 +71,14 @@ PLIST_SUB+= CPUFREQ=""
GCONF_SCHEMAS+= cpufreq-applet.schemas
.endif
+.if defined(WITH_MINI_COMMANDER)
+CONFIGURE_ARGS+= --enable-mini-commander
+GCONF_SCHEMAS+= mini-commander-global.schemas mini-commander.schemas
+PLIST_SUB+= COMMANDER=""
+.else
+PLIST_SUB+= COMMANDER="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g' \
${WRKSRC}/libgweather/weather-met.c
diff --git a/x11/gnome-applets/pkg-plist b/x11/gnome-applets/pkg-plist
index 42368d3b5a50..4eb20a4d8015 100644
--- a/x11/gnome-applets/pkg-plist
+++ b/x11/gnome-applets/pkg-plist
@@ -37,9 +37,11 @@ libexec/charpick_applet2
%%CPUFREQ%%libexec/cpufreq-applet
libexec/drivemount_applet2
libexec/geyes_applet2
+%%COMMANDER%%libexec/gnome-applets/mc-install-default-macros
libexec/gnome-keyboard-applet
libexec/gtik2_applet2
libexec/gweather-applet-2
+%%COMMANDER%%libexec/mini_commander_applet
libexec/mixer_applet2
libexec/modem_applet
libexec/multiload-applet-2
@@ -55,6 +57,7 @@ share/gnome/gnome-2.0/ui/GNOME_GSwitchItApplet.xml
share/gnome/gnome-2.0/ui/GNOME_GWeatherApplet.xml
share/gnome/gnome-2.0/ui/GNOME_GeyesApplet.xml
share/gnome/gnome-2.0/ui/GNOME_GtikApplet.xml
+%%COMMANDER%%share/gnome/gnome-2.0/ui/GNOME_MiniCommanderApplet.xml
share/gnome/gnome-2.0/ui/GNOME_MixerApplet.xml
share/gnome/gnome-2.0/ui/GNOME_ModemLights.xml
share/gnome/gnome-2.0/ui/GNOME_MultiloadApplet.xml
@@ -79,6 +82,7 @@ share/gnome/gnome-applets/geyes/Horrid/horrid_pupil.png
%%CPUFREQ%%share/gnome/gnome-applets/glade/cpufreq-preferences.glade
share/gnome/gnome-applets/glade/gswitchit-plugins.glade
share/gnome/gnome-applets/glade/gswitchit.glade
+%%COMMANDER%%share/gnome/gnome-applets/glade/mini-commander.glade
share/gnome/gnome-applets/glade/modemlights.glade
share/gnome/gnome-applets/glade/stickynotes.glade
share/gnome/gnome-applets/glade/trashapplet.glade
@@ -229,6 +233,27 @@ share/gnome/help/char-palette/uk/figures/charpalette_applet.png
share/gnome/help/char-palette/uk/figures/charpalette_chargroup.png
share/gnome/help/char-palette/uk/figures/charpick-preferences.png
share/gnome/help/char-palette/uk/figures/charpick_characters.png
+%%COMMANDER%%share/gnome/help/command-line/C/command-line.xml
+%%COMMANDER%%share/gnome/help/command-line/C/figures/command-line.png
+%%COMMANDER%%share/gnome/help/command-line/C/figures/prefs-macros.png
+%%COMMANDER%%share/gnome/help/command-line/C/figures/prefs.png
+%%COMMANDER%%share/gnome/help/command-line/C/legal.xml
+%%COMMANDER%%share/gnome/help/command-line/es/command-line.xml
+%%COMMANDER%%share/gnome/help/command-line/es/figures/command-line.png
+%%COMMANDER%%share/gnome/help/command-line/es/figures/prefs-macros.png
+%%COMMANDER%%share/gnome/help/command-line/es/figures/prefs.png
+%%COMMANDER%%share/gnome/help/command-line/fr/command-line.xml
+%%COMMANDER%%share/gnome/help/command-line/fr/figures/command-line.png
+%%COMMANDER%%share/gnome/help/command-line/fr/figures/prefs-macros.png
+%%COMMANDER%%share/gnome/help/command-line/fr/figures/prefs.png
+%%COMMANDER%%share/gnome/help/command-line/pt_BR/command-line.xml
+%%COMMANDER%%share/gnome/help/command-line/pt_BR/figures/command-line.png
+%%COMMANDER%%share/gnome/help/command-line/pt_BR/figures/prefs-macros.png
+%%COMMANDER%%share/gnome/help/command-line/pt_BR/figures/prefs.png
+%%COMMANDER%%share/gnome/help/command-line/uk/command-line.xml
+%%COMMANDER%%share/gnome/help/command-line/uk/figures/command-line.png
+%%COMMANDER%%share/gnome/help/command-line/uk/figures/prefs-macros.png
+%%COMMANDER%%share/gnome/help/command-line/uk/figures/prefs.png
%%CPUFREQ%%share/gnome/help/cpufreq-applet/C/cpufreq-applet.xml
%%CPUFREQ%%share/gnome/help/cpufreq-applet/C/figures/cpufreq-100.png
%%CPUFREQ%%share/gnome/help/cpufreq-applet/C/figures/cpufreq-25.png
@@ -501,6 +526,11 @@ share/gnome/omf/char-palette/char-palette-it.omf
share/gnome/omf/char-palette/char-palette-nl.omf
share/gnome/omf/char-palette/char-palette-pt_BR.omf
share/gnome/omf/char-palette/char-palette-uk.omf
+%%COMMANDER%%share/gnome/omf/command-line/command-line-C.omf
+%%COMMANDER%%share/gnome/omf/command-line/command-line-es.omf
+%%COMMANDER%%share/gnome/omf/command-line/command-line-fr.omf
+%%COMMANDER%%share/gnome/omf/command-line/command-line-pt_BR.omf
+%%COMMANDER%%share/gnome/omf/command-line/command-line-uk.omf
%%CPUFREQ%%share/gnome/omf/cpufreq-applet/cpufreq-applet-C.omf
%%CPUFREQ%%share/gnome/omf/cpufreq-applet/cpufreq-applet-es.omf
%%CPUFREQ%%share/gnome/omf/cpufreq-applet/cpufreq-applet-nl.omf
@@ -691,6 +721,7 @@ share/icons/hicolor/48x48/apps/ax-applet.png
share/icons/hicolor/48x48/apps/charpick.png
share/icons/hicolor/48x48/apps/gnome-cpu.png
share/icons/hicolor/48x48/apps/gnome-eyes.png
+%%COMMANDER%%share/icons/hicolor/48x48/apps/gnome-mini-commander.png
share/icons/hicolor/48x48/apps/gnome-modem.png
share/icons/hicolor/48x48/apps/gnome-money.png
share/icons/hicolor/48x48/apps/gswitchit-applet.png
@@ -795,6 +826,7 @@ share/locale/zh_TW/LC_MESSAGES/gnome-applets-2.0.mo
@dirrm share/gnome/omf/stickynotes_applet
@dirrm share/gnome/omf/multiload
@dirrm share/gnome/omf/mixer_applet2
+%%COMMANDER%%@dirrm share/gnome/omf/command-line
@dirrm share/gnome/omf/gweather
@dirrm share/gnome/omf/gtik2_applet2
@dirrm share/gnome/omf/gswitchit
@@ -912,6 +944,17 @@ share/locale/zh_TW/LC_MESSAGES/gnome-applets-2.0.mo
%%CPUFREQ%%@dirrm share/gnome/help/cpufreq-applet/C/figures
%%CPUFREQ%%@dirrm share/gnome/help/cpufreq-applet/C
%%CPUFREQ%%@dirrm share/gnome/help/cpufreq-applet
+%%COMMANDER%%@dirrm share/gnome/help/command-line/uk/figures
+%%COMMANDER%%@dirrm share/gnome/help/command-line/uk
+%%COMMANDER%%@dirrm share/gnome/help/command-line/pt_BR/figures
+%%COMMANDER%%@dirrm share/gnome/help/command-line/pt_BR
+%%COMMANDER%%@dirrm share/gnome/help/command-line/fr/figures
+%%COMMANDER%%@dirrm share/gnome/help/command-line/fr
+%%COMMANDER%%@dirrm share/gnome/help/command-line/es/figures
+%%COMMANDER%%@dirrm share/gnome/help/command-line/es
+%%COMMANDER%%@dirrm share/gnome/help/command-line/C/figures
+%%COMMANDER%%@dirrm share/gnome/help/command-line/C
+%%COMMANDER%%@dirrm share/gnome/help/command-line
@dirrm share/gnome/help/char-palette/uk/figures
@dirrm share/gnome/help/char-palette/uk
@dirrm share/gnome/help/char-palette/pt_BR/figures
diff --git a/x11/gnomeapplets2/Makefile b/x11/gnomeapplets2/Makefile
index 4e6cd0755f3b..cf84f04a3b2e 100644
--- a/x11/gnomeapplets2/Makefile
+++ b/x11/gnomeapplets2/Makefile
@@ -45,6 +45,8 @@ GCONF_SCHEMAS= charpick.schemas drivemount.schemas geyes.schemas \
mixer.schemas multiload.schemas \
stickynotes.schemas
+OPTIONS= MINI_COMMANDER "Enable mini-commander applet" off
+
FREEBSD_SYS?= /usr/src/sys
.include <bsd.port.pre.mk>
@@ -69,6 +71,14 @@ PLIST_SUB+= CPUFREQ=""
GCONF_SCHEMAS+= cpufreq-applet.schemas
.endif
+.if defined(WITH_MINI_COMMANDER)
+CONFIGURE_ARGS+= --enable-mini-commander
+GCONF_SCHEMAS+= mini-commander-global.schemas mini-commander.schemas
+PLIST_SUB+= COMMANDER=""
+.else
+PLIST_SUB+= COMMANDER="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g' \
${WRKSRC}/libgweather/weather-met.c
diff --git a/x11/gnomeapplets2/pkg-plist b/x11/gnomeapplets2/pkg-plist
index 42368d3b5a50..4eb20a4d8015 100644
--- a/x11/gnomeapplets2/pkg-plist
+++ b/x11/gnomeapplets2/pkg-plist
@@ -37,9 +37,11 @@ libexec/charpick_applet2
%%CPUFREQ%%libexec/cpufreq-applet
libexec/drivemount_applet2
libexec/geyes_applet2
+%%COMMANDER%%libexec/gnome-applets/mc-install-default-macros
libexec/gnome-keyboard-applet
libexec/gtik2_applet2
libexec/gweather-applet-2
+%%COMMANDER%%libexec/mini_commander_applet
libexec/mixer_applet2
libexec/modem_applet
libexec/multiload-applet-2
@@ -55,6 +57,7 @@ share/gnome/gnome-2.0/ui/GNOME_GSwitchItApplet.xml
share/gnome/gnome-2.0/ui/GNOME_GWeatherApplet.xml
share/gnome/gnome-2.0/ui/GNOME_GeyesApplet.xml
share/gnome/gnome-2.0/ui/GNOME_GtikApplet.xml
+%%COMMANDER%%share/gnome/gnome-2.0/ui/GNOME_MiniCommanderApplet.xml
share/gnome/gnome-2.0/ui/GNOME_MixerApplet.xml
share/gnome/gnome-2.0/ui/GNOME_ModemLights.xml
share/gnome/gnome-2.0/ui/GNOME_MultiloadApplet.xml
@@ -79,6 +82,7 @@ share/gnome/gnome-applets/geyes/Horrid/horrid_pupil.png
%%CPUFREQ%%share/gnome/gnome-applets/glade/cpufreq-preferences.glade
share/gnome/gnome-applets/glade/gswitchit-plugins.glade
share/gnome/gnome-applets/glade/gswitchit.glade
+%%COMMANDER%%share/gnome/gnome-applets/glade/mini-commander.glade
share/gnome/gnome-applets/glade/modemlights.glade
share/gnome/gnome-applets/glade/stickynotes.glade
share/gnome/gnome-applets/glade/trashapplet.glade
@@ -229,6 +233,27 @@ share/gnome/help/char-palette/uk/figures/charpalette_applet.png
share/gnome/help/char-palette/uk/figures/charpalette_chargroup.png
share/gnome/help/char-palette/uk/figures/charpick-preferences.png
share/gnome/help/char-palette/uk/figures/charpick_characters.png
+%%COMMANDER%%share/gnome/help/command-line/C/command-line.xml
+%%COMMANDER%%share/gnome/help/command-line/C/figures/command-line.png
+%%COMMANDER%%share/gnome/help/command-line/C/figures/prefs-macros.png
+%%COMMANDER%%share/gnome/help/command-line/C/figures/prefs.png
+%%COMMANDER%%share/gnome/help/command-line/C/legal.xml
+%%COMMANDER%%share/gnome/help/command-line/es/command-line.xml
+%%COMMANDER%%share/gnome/help/command-line/es/figures/command-line.png
+%%COMMANDER%%share/gnome/help/command-line/es/figures/prefs-macros.png
+%%COMMANDER%%share/gnome/help/command-line/es/figures/prefs.png
+%%COMMANDER%%share/gnome/help/command-line/fr/command-line.xml
+%%COMMANDER%%share/gnome/help/command-line/fr/figures/command-line.png
+%%COMMANDER%%share/gnome/help/command-line/fr/figures/prefs-macros.png
+%%COMMANDER%%share/gnome/help/command-line/fr/figures/prefs.png
+%%COMMANDER%%share/gnome/help/command-line/pt_BR/command-line.xml
+%%COMMANDER%%share/gnome/help/command-line/pt_BR/figures/command-line.png
+%%COMMANDER%%share/gnome/help/command-line/pt_BR/figures/prefs-macros.png
+%%COMMANDER%%share/gnome/help/command-line/pt_BR/figures/prefs.png
+%%COMMANDER%%share/gnome/help/command-line/uk/command-line.xml
+%%COMMANDER%%share/gnome/help/command-line/uk/figures/command-line.png
+%%COMMANDER%%share/gnome/help/command-line/uk/figures/prefs-macros.png
+%%COMMANDER%%share/gnome/help/command-line/uk/figures/prefs.png
%%CPUFREQ%%share/gnome/help/cpufreq-applet/C/cpufreq-applet.xml
%%CPUFREQ%%share/gnome/help/cpufreq-applet/C/figures/cpufreq-100.png
%%CPUFREQ%%share/gnome/help/cpufreq-applet/C/figures/cpufreq-25.png
@@ -501,6 +526,11 @@ share/gnome/omf/char-palette/char-palette-it.omf
share/gnome/omf/char-palette/char-palette-nl.omf
share/gnome/omf/char-palette/char-palette-pt_BR.omf
share/gnome/omf/char-palette/char-palette-uk.omf
+%%COMMANDER%%share/gnome/omf/command-line/command-line-C.omf
+%%COMMANDER%%share/gnome/omf/command-line/command-line-es.omf
+%%COMMANDER%%share/gnome/omf/command-line/command-line-fr.omf
+%%COMMANDER%%share/gnome/omf/command-line/command-line-pt_BR.omf
+%%COMMANDER%%share/gnome/omf/command-line/command-line-uk.omf
%%CPUFREQ%%share/gnome/omf/cpufreq-applet/cpufreq-applet-C.omf
%%CPUFREQ%%share/gnome/omf/cpufreq-applet/cpufreq-applet-es.omf
%%CPUFREQ%%share/gnome/omf/cpufreq-applet/cpufreq-applet-nl.omf
@@ -691,6 +721,7 @@ share/icons/hicolor/48x48/apps/ax-applet.png
share/icons/hicolor/48x48/apps/charpick.png
share/icons/hicolor/48x48/apps/gnome-cpu.png
share/icons/hicolor/48x48/apps/gnome-eyes.png
+%%COMMANDER%%share/icons/hicolor/48x48/apps/gnome-mini-commander.png
share/icons/hicolor/48x48/apps/gnome-modem.png
share/icons/hicolor/48x48/apps/gnome-money.png
share/icons/hicolor/48x48/apps/gswitchit-applet.png
@@ -795,6 +826,7 @@ share/locale/zh_TW/LC_MESSAGES/gnome-applets-2.0.mo
@dirrm share/gnome/omf/stickynotes_applet
@dirrm share/gnome/omf/multiload
@dirrm share/gnome/omf/mixer_applet2
+%%COMMANDER%%@dirrm share/gnome/omf/command-line
@dirrm share/gnome/omf/gweather
@dirrm share/gnome/omf/gtik2_applet2
@dirrm share/gnome/omf/gswitchit
@@ -912,6 +944,17 @@ share/locale/zh_TW/LC_MESSAGES/gnome-applets-2.0.mo
%%CPUFREQ%%@dirrm share/gnome/help/cpufreq-applet/C/figures
%%CPUFREQ%%@dirrm share/gnome/help/cpufreq-applet/C
%%CPUFREQ%%@dirrm share/gnome/help/cpufreq-applet
+%%COMMANDER%%@dirrm share/gnome/help/command-line/uk/figures
+%%COMMANDER%%@dirrm share/gnome/help/command-line/uk
+%%COMMANDER%%@dirrm share/gnome/help/command-line/pt_BR/figures
+%%COMMANDER%%@dirrm share/gnome/help/command-line/pt_BR
+%%COMMANDER%%@dirrm share/gnome/help/command-line/fr/figures
+%%COMMANDER%%@dirrm share/gnome/help/command-line/fr
+%%COMMANDER%%@dirrm share/gnome/help/command-line/es/figures
+%%COMMANDER%%@dirrm share/gnome/help/command-line/es
+%%COMMANDER%%@dirrm share/gnome/help/command-line/C/figures
+%%COMMANDER%%@dirrm share/gnome/help/command-line/C
+%%COMMANDER%%@dirrm share/gnome/help/command-line
@dirrm share/gnome/help/char-palette/uk/figures
@dirrm share/gnome/help/char-palette/uk
@dirrm share/gnome/help/char-palette/pt_BR/figures