aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2013-09-18 07:07:08 +0000
committerCy Schubert <cy@FreeBSD.org>2013-09-18 07:07:08 +0000
commitd2f630b20ab1566e6bdf7309b1b8a68a6c4f7c6e (patch)
tree10597b7ea28dfb16d81c786860e26e49c113d5a4 /x11
parent16c11d8f65c37275a795e634ecb1a218b34b7a80 (diff)
downloadports-d2f630b20ab1566e6bdf7309b1b8a68a6c4f7c6e.tar.gz
ports-d2f630b20ab1566e6bdf7309b1b8a68a6c4f7c6e.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/props/Makefile1
-rw-r--r--x11/props/files/patch-ac22
2 files changed, 21 insertions, 2 deletions
diff --git a/x11/props/Makefile b/x11/props/Makefile
index 8d3f428360ec..a394dd204afa 100644
--- a/x11/props/Makefile
+++ b/x11/props/Makefile
@@ -16,6 +16,7 @@ CONFLICTS= xview-clients-3.2.1.4.19*
LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
+MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/props
USES= imake
USE_XORG= x11 xext
diff --git a/x11/props/files/patch-ac b/x11/props/files/patch-ac
index 686095e402c9..a2a8838bed5d 100644
--- a/x11/props/files/patch-ac
+++ b/x11/props/files/patch-ac
@@ -1,5 +1,23 @@
---- props.c.orig Sun Nov 9 01:18:50 1997
-+++ props.c Sun Nov 9 01:24:50 1997
+--- props.c.orig 1997-11-08 17:18:50.000000000 -0800
++++ props.c 2013-09-17 23:33:43.311493251 -0700
+@@ -718,7 +718,7 @@
+ int factory = !(int) xv_get(panel_item, PANEL_VALUE);
+
+ if (factory == showing_factory)
+- return;
++ return 0;
+
+ if (factory) {
+ if (!saved_defaults[0]) {
+@@ -752,7 +752,7 @@
+ int width;
+
+ if (panel_group[which_panel] == current_panel)
+- return;
++ return 0;
+
+ /* Show requested panel */
+ xv_set(current_panel, XV_SHOW, FALSE, NULL);
@@ -816,7 +816,7 @@
else
{