aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2013-10-30 20:43:51 +0000
committerNicola Vitale <nivit@FreeBSD.org>2013-10-30 20:43:51 +0000
commit08b53ff575784bb772de1b8de9b3f2b74df58baf (patch)
tree5b2de9428eef8b1129fa55be2c90c23377643d61 /x11
parentd0bbb68224ca2f18a6d7d5443dfe00fa0f7b8b71 (diff)
downloadports-08b53ff575784bb772de1b8de9b3f2b74df58baf.tar.gz
ports-08b53ff575784bb772de1b8de9b3f2b74df58baf.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/guake/Makefile67
-rw-r--r--x11/guake/distinfo4
-rw-r--r--x11/guake/pkg-descr2
-rw-r--r--x11/guake/pkg-plist3
4 files changed, 42 insertions, 34 deletions
diff --git a/x11/guake/Makefile b/x11/guake/Makefile
index 3dbf2ca4fd01..4df3ce73bf1e 100644
--- a/x11/guake/Makefile
+++ b/x11/guake/Makefile
@@ -2,9 +2,11 @@
PORTNAME= guake
PORTVERSION= 0.4.4.0
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= x11
-MASTER_SITES= http://www.guake.org/downloads/5?dummy=empty/
+MASTER_SITES= http://distfiles.gentoo.org/distfiles/ \
+ http://nivit.altervista.org/FreeBSD/ports/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Dropdown terminal made for the GNOME desktop
@@ -20,50 +22,57 @@ RUN_DEPENDS= py${PYTHON_SUFFIX}-dbus>=0.84.0:${PORTSDIR}/devel/py-dbus \
py${PYTHON_SUFFIX}-vte>=0.26.2_1:${PORTSDIR}/x11-toolkits/py-vte \
py${PYTHON_SUFFIX}-xdg>=0.19:${PORTSDIR}/devel/py-xdg
+#GH_ACCOUNT= Guake
+#GH_TAGNAME= ${PORTVERSION:R}
+#GH_COMMIT= 88af26c
GCONF_SCHEMAS= guake.schemas
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
+NLS_CONFIGURE_ON= --localedir=${PREFIX}/share/locale
+NLS_CONFIGURE_OFF= --disable-nls
+
OPTIONS_DEFINE= MANPAGES NLS
-OPTIONS_DEFAULT= MANPAGES NLS
+OPTIONS_DEFAULT= MANPAGES
+OPTIONS_SUB= MANPAGES NLS
+
+PLIST_SUB+= DESKTOPDIR="${DESKTOPDIR:S,${PREFIX}/,,}"
+
+REINPLACE_ARGS= -e 's,/usr/bin/env python,&${PYTHON_VER},' -i.bak
+REINPLACE_FILES= guake guake-prefs prefs.py
+
+#USE_GITHUB= yes
+USE_GNOME= gtk20 pygnome2
+USE_PYTHON= -2.7
+USES= desktop-file-utils gmake pkgconfig
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
-USES= pkgconfig
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MMANPAGES}
-MAN1= guake.1
-.else
-MAKE_ENV= man_MANS=""
+.if !${PORT_OPTIONS:MMANPAGES}
+MAKE_ENV+= man_MANS=""
.endif
.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS= --localedir=${PREFIX}/share/locale
-PLIST_SUB= NLS=""
-USES+= gettext
+USES+= gettext
.else
-CONFIGURE_ARGS= --disable-nls
-PLIST_SUB= NLS="@comment "
REINPLACE_ARGS= -E -e 's,(USE_NLS=)yes,\1no,'
REINPLACE_FILES= ../configure
.endif
-PLIST_SUB+= DESKTOPDIR="${DESKTOPDIR:S,${PREFIX}/,,}"
-
-REINPLACE_ARGS+= -e 's,/usr/bin/env python,&${PYTHON_VER},' -i.bak
-REINPLACE_FILES+= guake guake-prefs prefs.py
-
-USE_GMAKE= yes
-USE_GNOME= desktopfileutils gtk20 pygnome2
-USE_PYTHON= -2.7
-
-WRKSRC= ${WRKDIR}/${DISTNAME:R}
-
post-patch:
- cd ${WRKSRC}/src && ${REINPLACE_CMD} ${REINPLACE_FILES}
+ @cd ${WRKSRC}/src && ${REINPLACE_CMD} ${REINPLACE_FILES}
+
+.include <bsd.port.pre.mk>
-post-install:
- -${LOCALBASE}/bin/update-desktop-database
+.if exists(${LOCALBASE}/libexec/notification-daemon)
+RUN_DEPENDS+= notification-daemon>=0.7.2_1:${PORTSDIR}/deskutils/notification-daemon
+.elif exists (${LOCALBASE}/bin/xfce4-notifyd-config)
+RUN_DEPENDS+= xfce4-notifyd>=0.2.4:${PORTSDIR}/deskutils/xfce4-notifyd
+.else
+RUN_DEPENDS+= notify-osd>=0.9.29_4:${PORTSDIR}/deskutils/notify-osd
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/guake/distinfo b/x11/guake/distinfo
index a747b93bb482..3602707aa1aa 100644
--- a/x11/guake/distinfo
+++ b/x11/guake/distinfo
@@ -1,2 +1,2 @@
-SHA256 (guake-0.4.4.0.tar.gz) = 1e1054ba6bbd79897bda0e1cd2b9df86082f7e794a0e07afc5cb63c0a5e74ca5
-SIZE (guake-0.4.4.0.tar.gz) = 549189
+SHA256 (guake-0.4.4.tar.gz) = 1e1054ba6bbd79897bda0e1cd2b9df86082f7e794a0e07afc5cb63c0a5e74ca5
+SIZE (guake-0.4.4.tar.gz) = 549189
diff --git a/x11/guake/pkg-descr b/x11/guake/pkg-descr
index a9d2bb1bcfd2..2e5bf80e2daa 100644
--- a/x11/guake/pkg-descr
+++ b/x11/guake/pkg-descr
@@ -4,4 +4,4 @@ or a similar program.
Its style of window is based on fps games, and one of its purposes
is to be easy to reach.
-WWW: http://guake.org
+WWW: http://github.com/Guake/guake
diff --git a/x11/guake/pkg-plist b/x11/guake/pkg-plist
index 522b83300869..04a6484f3df6 100644
--- a/x11/guake/pkg-plist
+++ b/x11/guake/pkg-plist
@@ -1,6 +1,7 @@
@comment $FreeBSD$
bin/guake
bin/guake-prefs
+%%MANPAGES%%man/man1/guake.1.gz
%%NLS%%share/locale/de/LC_MESSAGES/guake.mo
%%NLS%%share/locale/el/LC_MESSAGES/guake.mo
%%NLS%%share/locale/es/LC_MESSAGES/guake.mo
@@ -60,5 +61,3 @@ share/pixmaps/guake/guake.png
@dirrm share/pixmaps/guake
@dirrm %%PYTHON_SITELIBDIR%%/guake
@dirrm %%DATADIR%%
-@exec %%LOCALBASE%%/bin/update-desktop-database || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database || /usr/bin/true