aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-27 01:34:05 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-27 01:34:05 +0000
commit2e7fe43516c22c5d6dc1470a624f013a9289ccb3 (patch)
treed1a00bd6671d8dd3200ac4e8f4114bd0bc363774 /x11
parent714b52cb1957946d90ce79dccb9b3d61fa542f0f (diff)
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libXdamage/Makefile33
-rw-r--r--x11/libXdamage/distinfo1
-rw-r--r--x11/libXdamage/files/patch-Makefile.in11
-rw-r--r--x11/libXdamage/pkg-descr6
-rw-r--r--x11/libXdamage/pkg-plist6
6 files changed, 58 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index a61e742c1ea6..59c02e1ba516 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -80,6 +80,7 @@
SUBDIR += libX11
SUBDIR += libXau
SUBDIR += libXcursor
+ SUBDIR += libXdamage
SUBDIR += libXdmcp
SUBDIR += libXext
SUBDIR += libXfixes
diff --git a/x11/libXdamage/Makefile b/x11/libXdamage/Makefile
new file mode 100644
index 000000000000..5f455de592f4
--- /dev/null
+++ b/x11/libXdamage/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libXdamage
+# Date Created: 13 Nov, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXdamage
+PORTVERSION= 1.0.0.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Damage extension library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xfixes.pc:${PORTSDIR}/x11/libXfixes
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/damageext.pc:${PORTSDIR}/x11/damageext \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.0
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11/libXdamage/distinfo b/x11/libXdamage/distinfo
new file mode 100644
index 000000000000..bb0d57e85a52
--- /dev/null
+++ b/x11/libXdamage/distinfo
@@ -0,0 +1 @@
+MD5 (libXdamage-1.0.0.p1.tar.bz2) = 80983883a01afc584911c48827c3bce7
diff --git a/x11/libXdamage/files/patch-Makefile.in b/x11/libXdamage/files/patch-Makefile.in
new file mode 100644
index 000000000000..321acf82a45b
--- /dev/null
+++ b/x11/libXdamage/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Nov 13 15:25:50 2003
++++ Makefile.in Thu Nov 13 15:33:02 2003
+@@ -189,7 +189,7 @@
+ libXdamageincludedir = $(includedir)/X11/extensions
+ libXdamageinclude_HEADERS = Xdamage.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = xdamage.pc
+
+ EXTRA_DIST = xdamage.pc.in autogen.sh
diff --git a/x11/libXdamage/pkg-descr b/x11/libXdamage/pkg-descr
new file mode 100644
index 000000000000..3fd9a91201af
--- /dev/null
+++ b/x11/libXdamage/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X Damage extension library.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXdamage/pkg-plist b/x11/libXdamage/pkg-plist
new file mode 100644
index 000000000000..530ce2e23685
--- /dev/null
+++ b/x11/libXdamage/pkg-plist
@@ -0,0 +1,6 @@
+include/X11/extensions/Xdamage.h
+lib/libXdamage.a
+lib/libXdamage.la
+lib/libXdamage.so
+lib/libXdamage.so.1
+libdata/pkgconfig/xdamage.pc