aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 16:32:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 16:32:07 +0000
commite4343d70fd4006cdded06afba566cf5ac81c1042 (patch)
tree2b1105fda751368f91c2495b29c8d7ed7603adbd /x11
parent778e2d35510d4f8fa6bbae934b313771189e4268 (diff)
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/kdelibs4/Makefile3
-rw-r--r--x11/libexo/Makefile4
-rw-r--r--x11/libxfce4util/Makefile4
-rw-r--r--x11/mlterm/Makefile4
-rw-r--r--x11/xfce4-conf/Makefile5
-rw-r--r--x11/xkbset/Makefile3
6 files changed, 9 insertions, 14 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index b568b1dc6f51..86b7e0594fca 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -42,9 +42,8 @@ USE_FAM= yes
USE_GNOME= libxml2 libxslt
USE_KDE4= kdehier kdeprefix oxygen \
attica automoc4 ontologies sharedmime soprano strigi
-USES= cmake:outsource gettext
+USES= cmake:outsource gettext perl5
USE_OPENSSL= yes
-USE_PERL5= yes
USE_QT4= corelib dbus declarative designer_build gui \
network opengl phonon qt3support \
qtestlib script sql svg webkit xml \
diff --git a/x11/libexo/Makefile b/x11/libexo/Makefile
index 25f0ca401e46..b7f5ccd57a70 100644
--- a/x11/libexo/Makefile
+++ b/x11/libexo/Makefile
@@ -23,13 +23,11 @@ DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/lib//}
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= glib20 gtk20 intltool intlhack
USE_LDCONFIG= yes
-USE_PERL5= yes
USE_XFCE= configenv libmenu libutil
USE_XORG= x11
-USES= desktop-file-utils pathfix pkgconfig
+USES= desktop-file-utils gmake pathfix perl5 pkgconfig
OPTIONS_DEFINE= DOCS NLS
diff --git a/x11/libxfce4util/Makefile b/x11/libxfce4util/Makefile
index 478a7c7977eb..84f2f4e44edc 100644
--- a/x11/libxfce4util/Makefile
+++ b/x11/libxfce4util/Makefile
@@ -13,12 +13,10 @@ COMMENT= Extension library for the Xfce desktop environment
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= glib20 intltool intlhack
-USE_PERL5= yes
USE_LDCONFIG= yes
USE_XFCE= configenv
-USES= pathfix pkgconfig
+USES= gmake pathfix perl5 pkgconfig
OPTIONS_DEFINE= NLS DOCS
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 702990d9e6c4..3a71c6498930 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -15,8 +15,8 @@ USE_XORG= sm
USE_GNOME= gtk20 lthack vte
USE_AUTOTOOLS= libtool
LIBTOOLFILES= configure kiklib/configure mkf/configure
-USE_PERL5_BUILD=yes
-USES= gettext pkgconfig
+USE_PERL5= build
+USES= gettext pkgconfig perl5
CONFIGURE_ARGS= --with-imagelib=gdk-pixbuf2 --enable-utmp \
--enable-optimize-redrawing \
--with-tools="mlclient,mlconfig,mlterm-menu,mlcc,w3mmlconfig,mlimgloader" \
diff --git a/x11/xfce4-conf/Makefile b/x11/xfce4-conf/Makefile
index f23b9b3ed38a..4a5185320e60 100644
--- a/x11/xfce4-conf/Makefile
+++ b/x11/xfce4-conf/Makefile
@@ -17,13 +17,12 @@ LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= glib20 gtk20 intltool intlhack
USE_LDCONFIG= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_XFCE= configenv libutil
USE_XORG= x11
-USES= pathfix pkgconfig
+USES= gmake pathfix pkgconfig perl5
OPTIONS_DEFINE= DOCS PERL NLS
diff --git a/x11/xkbset/Makefile b/x11/xkbset/Makefile
index 45a94d0fc90a..62b749c69a9d 100644
--- a/x11/xkbset/Makefile
+++ b/x11/xkbset/Makefile
@@ -12,7 +12,8 @@ COMMENT= Manage various XKB features of X Window
MAN1= xkbset.1
USE_XORG= x11
-USE_PERL5_BUILD= yes
+USE_PERL5= build
+USES= perl5
MAKE_ARGS= X11BASE="${LOCALBASE}" X11PREFIX="${PREFIX}" \
INSTALL_DATA="${INSTALL_DATA}" \