aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-01-18 18:47:23 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-01-18 18:47:23 +0000
commitf68b7f3ec4788b5201e9defc57738af223156991 (patch)
tree83518cf9217209bdf5c456c37e889a15724df883 /x11
parentb6de39d6b813eeaf0084a2a562caff849f74440b (diff)
downloadports-f68b7f3ec4788b5201e9defc57738af223156991.tar.gz
ports-f68b7f3ec4788b5201e9defc57738af223156991.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/linux-xalf/Makefile42
-rw-r--r--x11/linux-xalf/distinfo1
-rw-r--r--x11/linux-xalf/pkg-comment1
-rw-r--r--x11/linux-xalf/pkg-descr10
-rw-r--r--x11/linux-xalf/pkg-plist1
6 files changed, 56 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index e2aacd1a4b80..94390b4afc94 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -58,6 +58,7 @@
SUBDIR += libhelp
SUBDIR += libsx
SUBDIR += linux-gnomelibs
+ SUBDIR += linux-xalf
SUBDIR += login.app
SUBDIR += lupe
SUBDIR += mgapdesk
diff --git a/x11/linux-xalf/Makefile b/x11/linux-xalf/Makefile
new file mode 100644
index 000000000000..9e487d1d7f20
--- /dev/null
+++ b/x11/linux-xalf/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: linux-xalf
+# Date created: 17 January 2002
+# Whom: Joe Marcus Clarke <marcus@marcuscom.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xalf
+PORTVERSION= 0.12
+CATEGORIES= x11 linux
+MASTER_SITES= http://www.lysator.liu.se/~astrand/projects/xalf/ \
+ http://www.lysator.liu.se/~astrand/projects/xalf/old/
+DISTNAME= xalf-0.12-1.i386
+PKGNAMEPREFIX= linux-
+EXTRACT_SUFX= .rpm
+
+MAINTAINER= gnome@freebsd.org
+
+LIB_DEPENDS= xalflaunch.0:${PORTSDIR}/x11/xalf
+BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
+USE_LINUX_PREFIX= yes
+
+EXTRACT_CMD= rpm2cpio
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= | cpio -id --quiet
+XALFDIR= /compat/linux/usr/X11R6/lib
+WRKSRC= ${WRKDIR}/usr/lib
+
+# Linux binary should not be stripped by INSTALL_PROGRAM
+# because as a side effect it brands the binary as FreeBSD.
+STRIP=
+
+.include <bsd.port.pre.mk>
+
+ONLY_FOR_ARCHS= i386
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/libxalflaunch.so.0.0.1 \
+ ${XALFDIR}/libxalflaunch.so.0
+
+.include <bsd.port.post.mk>
diff --git a/x11/linux-xalf/distinfo b/x11/linux-xalf/distinfo
new file mode 100644
index 000000000000..f5be43a566ee
--- /dev/null
+++ b/x11/linux-xalf/distinfo
@@ -0,0 +1 @@
+MD5 (xalf-0.12-1.i386.rpm) = 542a51de68e60e91e13fbddf271f4bb3
diff --git a/x11/linux-xalf/pkg-comment b/x11/linux-xalf/pkg-comment
new file mode 100644
index 000000000000..e9b45a7b4991
--- /dev/null
+++ b/x11/linux-xalf/pkg-comment
@@ -0,0 +1 @@
+Linux X11 Application Launch Feedback
diff --git a/x11/linux-xalf/pkg-descr b/x11/linux-xalf/pkg-descr
new file mode 100644
index 000000000000..0b820b06c985
--- /dev/null
+++ b/x11/linux-xalf/pkg-descr
@@ -0,0 +1,10 @@
+lf is a small utility to provide feedback when starting X11 applications.
+Feedback can be given via four different indicators: an invisible window
+(to be used in conjunction with a task pager like GNOMEs tasklist_applet or
+KDEs Taskbar), an generic splashscreen, an hourglass attached to the mouse
+cursor or an animated star.
+
+This is the Linux version need for launching Linux applications from the
+GNOME panel.
+
+WWW: http://www.lysator.liu.se/~astrand/projects/xalf/
diff --git a/x11/linux-xalf/pkg-plist b/x11/linux-xalf/pkg-plist
new file mode 100644
index 000000000000..ed5de8bb63d9
--- /dev/null
+++ b/x11/linux-xalf/pkg-plist
@@ -0,0 +1 @@
+usr/X11R6/lib/libxalflaunch.so.0