aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-02 19:14:43 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-02 19:14:43 +0000
commit4126f016654d2528ef69976e0a8468c7bc8fedd6 (patch)
tree0c88bb146a89ade9538b5a23aeaf60e1b6587e5b /x11
parentb2c861512a54c3833a85d705c899ad9a181d40f3 (diff)
downloadports-4126f016654d2528ef69976e0a8468c7bc8fedd6.tar.gz
ports-4126f016654d2528ef69976e0a8468c7bc8fedd6.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kde4-workspace/files/patch-kwin_effects_blur_blur.cpp13
-rw-r--r--x11/kde4-workspace/files/patch-kwin_scene__xrender.cpp22
3 files changed, 36 insertions, 1 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 6c5432a85fe8..a9e247a9d95b 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kde-workspace
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11 kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/x11/kde4-workspace/files/patch-kwin_effects_blur_blur.cpp b/x11/kde4-workspace/files/patch-kwin_effects_blur_blur.cpp
new file mode 100644
index 000000000000..f41d9a184da9
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-kwin_effects_blur_blur.cpp
@@ -0,0 +1,13 @@
+Fix ambiguous call on armv6.
+
+--- kwin/effects/blur/blur.cpp.orig 2017-01-11 16:01:39 UTC
++++ kwin/effects/blur/blur.cpp
+@@ -387,7 +387,7 @@ bool BlurEffect::shouldBlur(const Effect
+ if (w->isDesktop())
+ return false;
+
+- bool scaled = !qFuzzyCompare(data.xScale(), 1.0) && !qFuzzyCompare(data.yScale(), 1.0);
++ bool scaled = !qFuzzyCompare(data.xScale(), qreal(1.0)) && !qFuzzyCompare(data.yScale(), qreal(1.0));
+ bool translated = data.xTranslation() || data.yTranslation();
+
+ if (scaled || ((translated || (mask & PAINT_WINDOW_TRANSFORMED)) && !w->data(WindowForceBlurRole).toBool()))
diff --git a/x11/kde4-workspace/files/patch-kwin_scene__xrender.cpp b/x11/kde4-workspace/files/patch-kwin_scene__xrender.cpp
new file mode 100644
index 000000000000..6132b4a9e04f
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-kwin_scene__xrender.cpp
@@ -0,0 +1,22 @@
+Fix ambiguous call on armv6.
+
+--- kwin/scene_xrender.cpp.orig 2017-01-11 16:04:04 UTC
++++ kwin/scene_xrender.cpp
+@@ -392,7 +392,7 @@ void SceneXrender::Window::performPaint(
+ {
+ setTransformedShape(QRegion()); // maybe nothing will be painted
+ // check if there is something to paint
+- bool opaque = isOpaque() && qFuzzyCompare(data.opacity(), 1.0);
++ bool opaque = isOpaque() && qFuzzyCompare(data.opacity(), qreal(1.0));
+ /* HACK: It seems this causes painting glitches, disable temporarily
+ if (( mask & PAINT_WINDOW_OPAQUE ) ^ ( mask & PAINT_WINDOW_TRANSLUCENT ))
+ { // We are only painting either opaque OR translucent windows, not both
+@@ -469,7 +469,7 @@ void SceneXrender::Window::performPaint(
+ xscale *= screen_paint.xScale();
+ yscale *= screen_paint.yScale();
+ }
+- if (!qFuzzyCompare(xscale, 1.0) || !qFuzzyCompare(yscale, 1.0)) {
++ if (!qFuzzyCompare(xscale, qreal(1.0)) || !qFuzzyCompare(yscale, qreal(1.0))) {
+ scaled = true;
+ xform.matrix11 = DOUBLE_TO_FIXED(1.0 / xscale);
+ xform.matrix22 = DOUBLE_TO_FIXED(1.0 / yscale);