aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-10-02 19:51:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-10-02 19:51:23 +0000
commit533cbc94d8036a5a409c650df216cff1d4817813 (patch)
treeb183d02ece363a552d85b6836277e6240d1540a7 /x11
parent15b12adb92c7fe8bec92937ddfce99750daadf04 (diff)
downloadports-533cbc94d8036a5a409c650df216cff1d4817813.tar.gz
ports-533cbc94d8036a5a409c650df216cff1d4817813.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/ipager/Makefile4
-rw-r--r--x11/ipager/files/patch-SConstruct72
2 files changed, 72 insertions, 4 deletions
diff --git a/x11/ipager/Makefile b/x11/ipager/Makefile
index 42dbfbbda5b6..4acc8fb2a29f 100644
--- a/x11/ipager/Makefile
+++ b/x11/ipager/Makefile
@@ -33,10 +33,6 @@ post-patch:
-e "s/\([^-]pthread'\)/\1, 'X11'/" \
${WRKSRC}/SConstruct
-pre-build:
- # scons is too stupid to create DESTDIR by itself
- @${MKDIR} ${STAGEDIR}
-
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${DOCS}
diff --git a/x11/ipager/files/patch-SConstruct b/x11/ipager/files/patch-SConstruct
new file mode 100644
index 000000000000..79e120ec4161
--- /dev/null
+++ b/x11/ipager/files/patch-SConstruct
@@ -0,0 +1,72 @@
+--- SConstruct.orig 2005-11-06 11:23:24 UTC
++++ SConstruct
+@@ -7,15 +7,15 @@ SConsignFile()
+ ###############################################
+ # options
+ ipager_optfile = [ 'scons.opts', 'user.opts' ]
+-ipager_options = Options(ipager_optfile)
+-ipager_options.AddOptions(
+- BoolOption('debug', 'build debug version', 0),
+- BoolOption('debug_events', 'debug xserve events', 0),
++ipager_options = Variables(ipager_optfile)
++ipager_options.AddVariables(
++ BoolVariable('debug', 'build debug version', 0),
++ BoolVariable('debug_events', 'debug xserve events', 0),
+
+- BoolOption('xinerama', 'support xinerama', 0),
++ BoolVariable('xinerama', 'support xinerama', 0),
+
+- PathOption('PREFIX', 'install-path base', '/usr/local'),
+- PathOption('DESTDIR', 'install to $DESTDIR/$PREFIX', '/')
++ PathVariable('PREFIX', 'install-path base', '/usr/local'),
++ PathVariable('DESTDIR', 'install to $DESTDIR/$PREFIX', '/')
+ )
+
+
+@@ -73,12 +73,12 @@ if conf.CheckCHeader('sys/time.h'):
+
+ # sys/stat.h
+ if not conf.CheckCHeader('sys/stat.h'):
+- print "missing 'sys/stat.h', install it."
++ print("missing 'sys/stat.h', install it.")
+ exit(1)
+
+ # sys/types.h
+ if not conf.CheckCHeader('sys/types.h'):
+- print "missing 'sys/types.h', install it."
++ print("missing 'sys/types.h', install it.")
+ exit(1)
+
+
+@@ -90,7 +90,7 @@ if conf.CheckLibWithHeader('X11', 'X11/X
+ ipager_env.AppendUnique(
+ LIBS = ['X11','Xmu','Xext'])
+ else:
+- print "missing x11-dev-stuff, install it."
++ print("missing x11-dev-stuff, install it.")
+ exit(1)
+
+
+@@ -102,18 +102,18 @@ if conf.env['xinerama'] and conf.CheckLi
+
+
+ # imlib2
+-print "Checking for Imlib2... ",
++print("Checking for Imlib2... ")
+ if not conf.env.WhereIs('imlib2-config'):
+- print "cant find 'imlib2-config."
++ print("cant find 'imlib2-config.")
+ exit(1)
+ else:
+ imlib2_env = Environment()
+ imlib2_env.ParseConfig('imlib2-config --cflags --libs')
+ if not imlib2_env.Dictionary()['LIBS']:
+- print "missing imlib2, install it."
++ print("missing imlib2, install it.")
+ exit(1)
+ else:
+- print "yes"
++ print("yes")
+ ipager_env.AppendUnique(
+ CPPPATH = imlib2_env.Dictionary()['CPPPATH'],
+ CCFLAGS = imlib2_env.Dictionary()['CCFLAGS'],