aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-09-11 14:57:58 +0000
committerRene Ladan <rene@FreeBSD.org>2021-09-30 21:23:30 +0000
commit620968a43a5f9bb3fa98ab20f257a4c0d864caa7 (patch)
tree09bef799707f4b6e715b912429bd3b73c1addf4c /x11
parentb9a93c0bf4778b9ec327c1be6f819eb1ff90ec19 (diff)
downloadports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.tar.gz
ports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.zip
cleanup: drop support for EOL FreeBSD 11.X
Search criteria used: - 11.4 - OSREL* - OSVER* - *_FreeBSD_11 Input from: - adridg: devel/qca-legacy - jbeich: _WITH_DPRINTF, _WITH_GETLINE, GNU bfd workarounds - sunpoet: security/p5-*OpenSSL* Reviewed by: doceng, kde, multimedia, perl, python, ruby, rust Differential Revision: https://reviews.freebsd.org/D32008 Test Plan: make index
Diffstat (limited to 'x11')
-rw-r--r--x11/brisk-menu/Makefile7
-rw-r--r--x11/foot/Makefile5
-rw-r--r--x11/gnome-shell/Makefile5
-rw-r--r--x11/kitty/Makefile5
-rw-r--r--x11/libxkbcommon/Makefile1
-rw-r--r--x11/nvidia-driver/Makefile2
-rw-r--r--x11/squeekboard/Makefile1
-rw-r--r--x11/taiga/Makefile1
-rw-r--r--x11/waybar/Makefile1
-rw-r--r--x11/wayland-logout/Makefile2
-rw-r--r--x11/xlockmore/Makefile4
-rw-r--r--x11/xorg-minimal/Makefile10
12 files changed, 3 insertions, 41 deletions
diff --git a/x11/brisk-menu/Makefile b/x11/brisk-menu/Makefile
index 733106839ed2..2389c95f4798 100644
--- a/x11/brisk-menu/Makefile
+++ b/x11/brisk-menu/Makefile
@@ -29,11 +29,4 @@ USE_XORG= x11
MESON_ARGS= --sysconfdir=${PREFIX}/etc
-.if exists(/usr/bin/ld.lld)
-LDFLAGS+= -fuse-ld=lld
-.else
-USE_BINUTILS= yes
-LDFLAGS+= -B${LOCALBASE}/bin
-.endif
-
.include <bsd.port.mk>
diff --git a/x11/foot/Makefile b/x11/foot/Makefile
index 0b5ace9a434b..b993dbf4b4b0 100644
--- a/x11/foot/Makefile
+++ b/x11/foot/Makefile
@@ -27,17 +27,12 @@ OPTIONS_DEFINE= DOCS LTO NOTIFY PGO UTF8PROC XDG
OPTIONS_DEFAULT=LTO NOTIFY PGO UTF8PROC XDG
OPTIONS_EXCLUDE+= ${CC:T:Mgcc*:C/.+/LTO/} # undefined reference to `xstrdup'
OPTIONS_EXCLUDE_powerpc64= ${"${/usr/bin/ld:L:tA}"==/usr/bin/ld.lld:?LTO:} # LLVM bug 47353
-OPTIONS_EXCLUDE_FreeBSD_11= ${WAYLAND_DISPLAY:UPGO} # ./pgo hangs
OPTIONS_EXCLUDE_FreeBSD_12= ${WAYLAND_DISPLAY:UPGO} # ./pgo hangs
DOCS_BUILD_DEPENDS= scdoc:textproc/scdoc
DOCS_MESON_ENABLED= docs
LTO_MESON_TRUE= b_lto
-.if exists(/usr/bin/ld.lld) && ${/usr/bin/ld:L:tA} != /usr/bin/ld.lld
-# --plugin isn't supported by old GNU ld.bfd in base
-LTO_LDFLAGS= -fuse-ld=lld
-.endif
NOTIFY_RUN_DEPENDS= notify-send:devel/libnotify
diff --git a/x11/gnome-shell/Makefile b/x11/gnome-shell/Makefile
index 0a3bbc6aeebe..fdc147c700a7 100644
--- a/x11/gnome-shell/Makefile
+++ b/x11/gnome-shell/Makefile
@@ -68,11 +68,6 @@ CPE_VENDOR= gnome
GLIB_SCHEMAS= 00_org.gnome.shell.gschema.override \
org.gnome.shell.gschema.xml
-.if exists(/usr/bin/ld.lld) && ${/usr/bin/ld:L:tA} != /usr/bin/ld.lld
-# Work around "New rpath must not be longer than the old one."
-LDFLAGS+= -fuse-ld=lld
-.endif
-
post-extract:
${CP} ${FILESDIR}/*.xml ${WRKSRC}/data/dbus-interfaces
diff --git a/x11/kitty/Makefile b/x11/kitty/Makefile
index ec78e6a9ac6d..ca7a931426a5 100644
--- a/x11/kitty/Makefile
+++ b/x11/kitty/Makefile
@@ -40,11 +40,6 @@ SHEBANG_GLOB= *.py
TEST_ENV= PATH="${STAGEDIR}${PREFIX}/bin:${PATH}"
TEST_TARGET= test
-.if exists(/usr/bin/ld.lld) && ${/usr/bin/ld:L:tA} != /usr/bin/ld.lld
-# --build-id isn't supported by old GNU ld.bfd in base
-LDFLAGS+= -fuse-ld=lld
-.endif
-
BINARY_ALIAS= python3=${PYTHON_CMD} python=${PYTHON_CMD}
INSTALL_WRKSRC= ${WRKSRC}/linux-package
diff --git a/x11/libxkbcommon/Makefile b/x11/libxkbcommon/Makefile
index e5294f98de9e..67a1d5999b3f 100644
--- a/x11/libxkbcommon/Makefile
+++ b/x11/libxkbcommon/Makefile
@@ -18,7 +18,6 @@ USE_LDCONFIG= yes
MESON_ARGS= -Denable-docs=false \
-Dx-locale-root="${PREFIX}/lib/X11/locale" \
${MESON_ARGS_${OPSYS}_${OSREL:R}}
-MESON_ARGS_FreeBSD_11= -Ddefault-rules=xorg
CPE_VENDOR= xkbcommon
OPTIONS_DEFINE= EVDEV WAYLAND X11
diff --git a/x11/nvidia-driver/Makefile b/x11/nvidia-driver/Makefile
index c47ebdf7279f..5218a2d75ef3 100644
--- a/x11/nvidia-driver/Makefile
+++ b/x11/nvidia-driver/Makefile
@@ -155,12 +155,10 @@ post-patch: .SILENT
${WRKSRC}/src/nvidia-modeset/nvidia-modeset-freebsd.c
.endif
# KPI of kmem_alloc_contig(),kmem_free() changed in FreeBSD src r338143,r338318
-.if ${OSVERSION} >= 1200079
${REINPLACE_CMD} \
-e 's/kmem_alloc_contig(kmem_arena, /kmem_alloc_contig(/' \
-e 's/kmem_free(kmem_arena, /kmem_free(/' \
${WRKSRC}/src/${NVSRC}/nvidia_subr.c
-.endif
# Pull the right header after FreeBSD src r347984
.if ${OSVERSION} >= 1300029 && ${NVVERSION} >= 358.009
${REINPLACE_CMD} -e '/^#include/s:lock\.h:mutex.h:' \
diff --git a/x11/squeekboard/Makefile b/x11/squeekboard/Makefile
index 2820b5a1ac1e..e0cbfad33bf8 100644
--- a/x11/squeekboard/Makefile
+++ b/x11/squeekboard/Makefile
@@ -10,7 +10,6 @@ COMMENT= On-screen keyboard for Wayland
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_FreeBSD_11= requires getrandom()
BROKEN_FreeBSD_12_powerpc64= fails to compile: rs.e2mg9us3-cgu.14:(.text.imservice_handle_commit_state+0x228): undefined reference to 'eekboard_context_service_show_keyboard'
BROKEN_FreeBSD_13_powerpc64= fails to link: ld: error: undefined symbol: eekboard_context_service_get_overlay
diff --git a/x11/taiga/Makefile b/x11/taiga/Makefile
index 7b219a376bc4..4a24a8153711 100644
--- a/x11/taiga/Makefile
+++ b/x11/taiga/Makefile
@@ -15,7 +15,6 @@ LIB_DEPENDS= libwayland-client.so:graphics/wayland \
libavcodec.so:multimedia/ffmpeg
USES= compiler:c11 meson pkgconfig
-CPPFLAGS+= -D_WITH_GETLINE # XXX Remove after FreeBSD 11 EOL
PLIST_FILES= bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/x11/waybar/Makefile b/x11/waybar/Makefile
index f0e82c970359..438ef7cb5b47 100644
--- a/x11/waybar/Makefile
+++ b/x11/waybar/Makefile
@@ -21,7 +21,6 @@ USE_GITHUB= yes
USE_GNOME= gtkmm30
GH_ACCOUNT= Alexays
GH_PROJECT= Waybar
-CPPFLAGS+= -D_WITH_GETLINE # XXX Remove after FreeBSD 11 EOL
PLIST_FILES= bin/${PORTNAME} \
etc/xdg/${PORTNAME}/config \
etc/xdg/${PORTNAME}/style.css
diff --git a/x11/wayland-logout/Makefile b/x11/wayland-logout/Makefile
index b2997555523a..4348e0509c2f 100644
--- a/x11/wayland-logout/Makefile
+++ b/x11/wayland-logout/Makefile
@@ -20,7 +20,7 @@ PLIST_FILES= bin/${PORTNAME} \
# Cannot use C implementation without cr_pid
.if make(makesum)
DISTFILES= ${DISTNAME:S/${DISTVERSION}/1.3/}${EXTRACT_SUFX}
-.elif ${OPSYS} != FreeBSD || ${OSVERSION} < 1202506
+.elif ${OPSYS} != FreeBSD
DISTVERSION= 1.3
NO_ARCH= yes
MESON_ARGS+= -Dimplementation=shell
diff --git a/x11/xlockmore/Makefile b/x11/xlockmore/Makefile
index b38e9024dc10..31bdf441f23d 100644
--- a/x11/xlockmore/Makefile
+++ b/x11/xlockmore/Makefile
@@ -92,10 +92,6 @@ FREETYPE_CFLAGS= -I${LOCALBASE}/include/gltt
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MFREETYPE}
-IGNORE_FreeBSD_11= FREETYPE support requires FreeBSD version 12+
-.endif
-
.if defined(XLOCKMORE_LANG)
CONFIGURE_ARGS+= --with-lang=${XLOCKMORE_LANG}
.endif
diff --git a/x11/xorg-minimal/Makefile b/x11/xorg-minimal/Makefile
index a9fc0526b6dd..fa66cfac63fc 100644
--- a/x11/xorg-minimal/Makefile
+++ b/x11/xorg-minimal/Makefile
@@ -14,14 +14,8 @@ VIDEO_DRIVER?= vesa
RUN_DEPENDS+= ${LOCALBASE}/bin/Xorg:x11-servers/xorg-server \
${LOCALBASE}/bin/xinit:x11/xinit \
- ${LOCALBASE}/bin/xauth:x11/xauth
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200000
-RUN_DEPENDS+= ${LOCALBASE}/lib/xorg/modules/input/mouse_drv.so:x11-drivers/xf86-input-mouse
-RUN_DEPENDS+= ${LOCALBASE}/lib/xorg/modules/input/kbd_drv.so:x11-drivers/xf86-input-keyboard
-.else
-RUN_DEPENDS+= ${LOCALBASE}/lib/xorg/modules/input/libinput_drv.so:x11-drivers/xf86-input-libinput
-.endif
+ ${LOCALBASE}/bin/xauth:x11/xauth \
+ ${LOCALBASE}/lib/xorg/modules/input/libinput_drv.so:x11-drivers/xf86-input-libinput
.if ${VIDEO_DRIVER} == "nvidia"
RUN_DEPENDS+= ${LOCALBASE}/lib/xorg/modules/drivers/nvidia_drv.so:x11/nvidia-driver