aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-02-06 21:16:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-02-06 21:16:17 +0000
commit6dc312169e462b96a294187e5ae0bf7df6bd5319 (patch)
treebffea525620f9c95cad3675a8007b1457170af18 /x11
parent25f51db099f9c129848ff3e7c47be30cb06e7073 (diff)
downloadports-6dc312169e462b96a294187e5ae0bf7df6bd5319.tar.gz
ports-6dc312169e462b96a294187e5ae0bf7df6bd5319.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/xauth/Makefile11
-rw-r--r--x11/xauth/distinfo5
-rw-r--r--x11/xauth/files/patch-Makefile.in11
-rw-r--r--x11/xauth/files/patch-tests_020-xauth-add-local.script11
-rw-r--r--x11/xauth/files/patch-tests_setup-sourced19
5 files changed, 42 insertions, 15 deletions
diff --git a/x11/xauth/Makefile b/x11/xauth/Makefile
index 736b1c53f44d..83ccb47bcc96 100644
--- a/x11/xauth/Makefile
+++ b/x11/xauth/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xauth
-PORTREVISION= 1
-PORTVERSION= 1.0.9
+PORTVERSION= 1.0.10
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
@@ -10,9 +9,17 @@ COMMENT= X authority file utility
LICENSE= MIT
+TEST_DEPENDS= cmdtest:devel/py-cmdtest
+
+USES= shebangfix
XORG_CAT= app
USE_XORG= x11 xau xext xmuu
INSTALL_TARGET= install-strip
+TEST_TARGET= check
+SHEBANG_FILES= ${WRKSRC}/tests/*.script
+SHEBANG_LANG= nobash
+nobash_OLD_CMD= /bin/bash
+nobash_CMD= /bin/sh
PLIST_FILES= bin/xauth man/man1/xauth.1.gz
diff --git a/x11/xauth/distinfo b/x11/xauth/distinfo
index 474474471fc7..3909a68f1708 100644
--- a/x11/xauth/distinfo
+++ b/x11/xauth/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xorg/app/xauth-1.0.9.tar.bz2) = 56ce1523eb48b1f8a4f4244fe1c3d8e6af1a3b7d4b0e6063582421b0b68dc28f
-SIZE (xorg/app/xauth-1.0.9.tar.bz2) = 154976
+TIMESTAMP = 1486412665
+SHA256 (xorg/app/xauth-1.0.10.tar.bz2) = 5afe42ce3cdf4f60520d1658d2b17face45c74050f39af45dccdc95e73fafc4d
+SIZE (xorg/app/xauth-1.0.10.tar.bz2) = 162176
diff --git a/x11/xauth/files/patch-Makefile.in b/x11/xauth/files/patch-Makefile.in
deleted file mode 100644
index 49a816c181ed..000000000000
--- a/x11/xauth/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 2013-11-08 20:32:35.639997675 +0100
-+++ Makefile.in 2013-11-08 20:32:41.358981902 +0100
-@@ -360,7 +360,7 @@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--SUBDIRS = man tests
-+SUBDIRS = man
- AM_CFLAGS = $(CWARNFLAGS) $(XAUTH_CFLAGS)
- xauth_LDADD = $(XAUTH_LIBS)
- xauth_SOURCES = \
diff --git a/x11/xauth/files/patch-tests_020-xauth-add-local.script b/x11/xauth/files/patch-tests_020-xauth-add-local.script
new file mode 100644
index 000000000000..90e30b1ef517
--- /dev/null
+++ b/x11/xauth/files/patch-tests_020-xauth-add-local.script
@@ -0,0 +1,11 @@
+--- tests/020-xauth-add-local.script.orig 2017-02-06 20:55:37 UTC
++++ tests/020-xauth-add-local.script
+@@ -11,7 +11,7 @@ xauth add :3.5 . b90b0fd1
+ xauth add :4 . b90b0fd1cf6a0e7a2c74c00000000004
+
+ # List the number of entries added
+-xauth list | wc -l
++xauth list | wc -l | xargs echo
+
+ # Try to match them and print cookie
+ xauth list unix:0 | awk '{print $3}'
diff --git a/x11/xauth/files/patch-tests_setup-sourced b/x11/xauth/files/patch-tests_setup-sourced
new file mode 100644
index 000000000000..aa253d133d4a
--- /dev/null
+++ b/x11/xauth/files/patch-tests_setup-sourced
@@ -0,0 +1,19 @@
+--- tests/setup-sourced.orig 2017-01-29 20:59:17 UTC
++++ tests/setup-sourced
+@@ -11,14 +11,14 @@ export XAUTHORITY=${DATADIR:-/tmp}/.Xaut
+ # Start a new authority file
+ rm -f $XAUTHORITY ; touch $XAUTHORITY
+
+-function xauth()
++xauth()
+ {
+ echo "> xauth" "$@"
+ ../xauth "$@"
+ echo " exits with $?"
+ }
+
+-function xauth_silent()
++xauth_silent()
+ {
+ echo "> xauth" "some silent commands which should not be logged..."
+ ../xauth "$@"