aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-11-04 19:55:56 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-11-04 19:55:56 +0000
commit986bc82e69519d1da7407269d1513672af142a6d (patch)
tree639a10ec1b28429af44d7f660457220dd0e3e3b5 /x11
parent57734edbdb1142168f9f8328dfc63aa62ffb6036 (diff)
downloadports-986bc82e69519d1da7407269d1513672af142a6d.tar.gz
ports-986bc82e69519d1da7407269d1513672af142a6d.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/deforaos-keyboard/Makefile9
-rw-r--r--x11/deforaos-keyboard/files/patch-keyboard.c.diff11
-rw-r--r--x11/deforaos-keyboard/pkg-plist1
3 files changed, 16 insertions, 5 deletions
diff --git a/x11/deforaos-keyboard/Makefile b/x11/deforaos-keyboard/Makefile
index 515a9124d8ce..b25cec37f82e 100644
--- a/x11/deforaos-keyboard/Makefile
+++ b/x11/deforaos-keyboard/Makefile
@@ -3,23 +3,22 @@
PORTNAME= keyboard
PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= http://www.defora.org/os/download/download/3696/
-DISTNAME= Keyboard-${PORTVERSION}
PKGNAMEPREFIX= deforaos-
+DISTNAME= Keyboard-${PORTVERSION}
MAINTAINER= olivier@cochard.me
COMMENT= DeforaOS desktop virtual keyboardr
LICENSE= GPLv3
-LIB_DEPENDS= Desktop:${PORTSDIR}/x11/deforaos-libdesktop
+LIB_DEPENDS= libDesktop.so:${PORTSDIR}/x11/deforaos-libdesktop
USE_GNOME= gtk20
-USES= pkgconfig gettext
+USES= desktop-file-utils gettext pkgconfig
USE_XORG= xtst
MAKE_ARGS+= PREFIX=${PREFIX}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/x11/deforaos-keyboard/files/patch-keyboard.c.diff b/x11/deforaos-keyboard/files/patch-keyboard.c.diff
new file mode 100644
index 000000000000..81cc847fad24
--- /dev/null
+++ b/x11/deforaos-keyboard/files/patch-keyboard.c.diff
@@ -0,0 +1,11 @@
+--- src/keyboard.c.orig 2013-10-30 12:04:38.512854430 +0100
++++ src/keyboard.c 2013-10-30 12:04:53.198851447 +0100
+@@ -437,7 +437,7 @@
+ keyboard_set_layout(keyboard, KLS_LETTERS);
+ pango_font_description_free(bold);
+ /* messages */
+- desktop_message_register(KEYBOARD_CLIENT_MESSAGE, on_keyboard_message,
++ desktop_message_register(keyboard->window,KEYBOARD_CLIENT_MESSAGE, on_keyboard_message,
+ keyboard);
+ return keyboard;
+ }
diff --git a/x11/deforaos-keyboard/pkg-plist b/x11/deforaos-keyboard/pkg-plist
index 1d466e2bc65a..af7e4952f162 100644
--- a/x11/deforaos-keyboard/pkg-plist
+++ b/x11/deforaos-keyboard/pkg-plist
@@ -3,3 +3,4 @@ bin/keyboard
include/Desktop/Keyboard.h
share/applications/keyboard.desktop
share/locale/fr/LC_MESSAGES/Keyboard.mo
+@dirrm include/Desktop