aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2010-05-12 17:36:04 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2010-05-12 17:36:04 +0000
commitbfd0eb9a4e0df5c1cddea93a35f7b88ebca1d177 (patch)
tree281f79c7d97b7481e9c62a5d8db4a99596424f06 /x11
parentec29a59ec3d0472e808e9907b2f18dce2e9fe68c (diff)
downloadports-bfd0eb9a4e0df5c1cddea93a35f7b88ebca1d177.tar.gz
ports-bfd0eb9a4e0df5c1cddea93a35f7b88ebca1d177.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/xwit/Makefile18
-rw-r--r--x11/xwit/distinfo3
-rw-r--r--x11/xwit/files/patch-dsimple.c29
-rw-r--r--x11/xwit/pkg-descr22
4 files changed, 22 insertions, 50 deletions
diff --git a/x11/xwit/Makefile b/x11/xwit/Makefile
index ac1172278a7e..74088d4ca5bd 100644
--- a/x11/xwit/Makefile
+++ b/x11/xwit/Makefile
@@ -1,23 +1,27 @@
-# New ports collection makefile for: xwit
-# Date created: 15 June 1998
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
+# New ports collection makefile for: xwit
+# Date created: 15 June 1998
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= xwit
PORTVERSION= 3.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR = utilities
+MASTER_SITES= XCONTRIB/utilities:source1 CRITICAL:source2
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}:source1 \
+ ${PORTNAME}-patchset-${PORTVERSION}${EXTRACT_SUFX}:source2
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ehaupt@FreeBSD.org
COMMENT= X interface tool
USE_IMAKE= yes
USE_XORG= x11 xext
+
MAN1= xwit.1
PLIST_FILES= bin/xwit
+EXTRA_PATCHES= ${WRKDIR}/${PORTNAME}-patchset-${PORTVERSION}/patch-*
+
.include <bsd.port.mk>
diff --git a/x11/xwit/distinfo b/x11/xwit/distinfo
index 5bc0a0982fd8..19a116af4161 100644
--- a/x11/xwit/distinfo
+++ b/x11/xwit/distinfo
@@ -1,3 +1,6 @@
MD5 (xwit-3.4.tar.gz) = 627a2ff424ae5593be929f3def62dd1e
SHA256 (xwit-3.4.tar.gz) = d915a7f2f8809da41edcc7784c2618be3f8ce179d82d8ace6d27ba264332c729
SIZE (xwit-3.4.tar.gz) = 14536
+MD5 (xwit-patchset-3.4.tar.gz) = 0d19e3bc9b054e2aeb2f522c0de090e4
+SHA256 (xwit-patchset-3.4.tar.gz) = 24f295b6312cde2052e6f101e650b7972cbfc40777445f512e4a5734c5a59b9a
+SIZE (xwit-patchset-3.4.tar.gz) = 11075
diff --git a/x11/xwit/files/patch-dsimple.c b/x11/xwit/files/patch-dsimple.c
deleted file mode 100644
index e1b2fd4bb27c..000000000000
--- a/x11/xwit/files/patch-dsimple.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- dsimple.c~ Thu Oct 19 00:59:17 1995
-+++ dsimple.c Wed Jul 24 15:49:26 2002
-@@ -5,6 +5,8 @@
- #include <X11/Xutil.h>
- #include <X11/cursorfont.h>
- #include <stdio.h>
-+#include <stdlib.h>
-+
- /*
- * Other_stuff.h: Definitions of routines in other_stuff.
- *
-@@ -46,7 +48,7 @@
- char *Malloc(size)
- unsigned size;
- {
-- char *data, *malloc();
-+ char *data;
-
- if (!(data = malloc(size)))
- Fatal_Error("Out of memory!");
-@@ -62,7 +64,7 @@
- char *ptr;
- int size;
- {
-- char *new_ptr, *realloc();
-+ char *new_ptr;
-
- if (!ptr)
- return(Malloc(size));
diff --git a/x11/xwit/pkg-descr b/x11/xwit/pkg-descr
index 331b80aaf28d..a810891d16db 100644
--- a/x11/xwit/pkg-descr
+++ b/x11/xwit/pkg-descr
@@ -1,16 +1,10 @@
-xwit ("x window interface tool") is a hotch-potch collection of simple
-routines to call some of those X11 functions that don't already have any
-utility commands built around them. The reasoning behind this is that
-loosely every X function should be accessible from a shell script.
+xwit ("x window interface tool") is a hotch-potch collection of simple routines
+to call some of those X11 functions that don't already have any utility commands
+built around them. The reasoning behind this is that loosely every X function
+should be accessible from a shell script.
For example, XWarpPointer() will move the X pointer, but no utility program
-exists to do so on those rare occasions when you could really use it. xwit
-will also resize, iconify, pop, and move windows given by name or id,
-change an icon, title or name, set the screen saver going, and change
-individual key autorepeat settings.
-
-The program is released into the public domain. Only the considerate
-will leave credit for the authors.
-
- Mark M Martin. mmm@cetia.fr dec 1993.
- David DiGiacomo dd@mv.us.adobe.com
+exists to do so on those rare occasions when you could really use it. xwit will
+also resize, iconify, pop, and move windows given by name or id, change an icon,
+title or name, set the screen saver going, and change individual key autorepeat
+settings.