aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2022-02-12 18:14:18 +0000
committerCy Schubert <cy@FreeBSD.org>2022-02-13 01:21:14 +0000
commit15f9fa2d5b3c6c3babc70ba1037426b2a4e7532d (patch)
tree8d9719d112b7065b1110ac4660bf1b019764c21c /x11
parent35b5f38563a2236dc8081e09a1444d610b5dbe02 (diff)
downloadports-15f9fa2d5b3c6c3babc70ba1037426b2a4e7532d.tar.gz
ports-15f9fa2d5b3c6c3babc70ba1037426b2a4e7532d.zip
x11/cde: Fix build under 14-CURRENT
Under 14-CURRENT MALLOC_PRODUCTION is not set which puts malloc() into debug mode. In debug mode malloc() enables opt.junk to write junk to newly malloc()ed heap in order to help developers discover memory allocation bugs. Unfortunately CDE's dtinfogen assumes newly malloc()ed memory is zero filled (i.e. not filled with junk), resulting in "flex scanner jammed". This likely causes parsing of the junk past the end of any legitimate statements. This affects stock 14-CURRENT without MALLOC_PRODUCTION enabled. This is accomplished by setting the make environment variable MALLOC_CONF=junk:false. See malloc(3) for a complete description of MALLOC_CONF=junk:false. (cherry picked from commit 50324bba317cf1f58e8c434e0e2ed129cded3887)
Diffstat (limited to 'x11')
-rw-r--r--x11/cde/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/x11/cde/Makefile b/x11/cde/Makefile
index 257ecc4ea23c..afc2a5219849 100644
--- a/x11/cde/Makefile
+++ b/x11/cde/Makefile
@@ -37,6 +37,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
ALL_TARGET= World
MAKE_ARGS+= PERL=${PERL} "LOCAL_LDFLAGS=${LDFLAGS}"
MAKE_JOBS_UNSAFE=yes
+MAKE_ENV= MALLOC_CONF=junk:false
SUB_FILES= pkg-message
LDFLAGS+= -z muldefs #--allow-multiple-definition