aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2016-06-09 22:28:18 +0000
committerJason Helfman <jgh@FreeBSD.org>2016-06-09 22:28:18 +0000
commit719cd2344afd6ab32514c4083092a7ce8133d30f (patch)
treed7beb173e67fb897c1adcafe8059f4199ae99698 /x11
parent612b236c0fb3a5ad16dce7f632367181a76b03a9 (diff)
downloadports-719cd2344afd6ab32514c4083092a7ce8133d30f.tar.gz
ports-719cd2344afd6ab32514c4083092a7ce8133d30f.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/xlockmore/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11/xlockmore/Makefile b/x11/xlockmore/Makefile
index 5b47dc570761..74401cd0c5ba 100644
--- a/x11/xlockmore/Makefile
+++ b/x11/xlockmore/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xlockmore
PORTVERSION= 5.46
+PORTREVISION= 1
CATEGORIES?= x11
MASTER_SITES= http://www.tux.org/~bagleyd/xlock/ \
LOCAL/jgh/x11/${PORTNAME}/
@@ -22,7 +23,9 @@ USE_XORG= x11 xaw ice
LIB_DEPENDS+= libfreetype.so:print/freetype2
OPTIONS_DEFINE= MESAGL MB SYSLOG DISABLE_ALLOW_ROOT NICE_ONLY BLANK_ONLY \
- KERBEROS4 BAD_PAM GTK2 TIME_BOMB CUSTOMIZATION MAGICK JP
+ KERBEROS4 BAD_PAM GTK2 TIME_BOMB CUSTOMIZATION MAGICK JP \
+ XINERAMA
+OPTIONS_DEFAULT= XINERAMA
OPTIONS_SUB= yes
MESAGL_DESC= Mesa 3D (for GL modes)
@@ -140,6 +143,10 @@ CONFIGURE_ENV+= XLOCKLIBS="${KRB5LIB} ${KRB4LIB} ${MESALIB}"
CONFIGURE_ARGS+= --disable-allow-root
.endif
+.if ${PORT_OPTIONS:MXINERAMA}
+CONFIGURE_ARGS+= --with-xinerama
+.endif
+
.if ${PORT_OPTIONS:MPAM} && empty(PORT_OPTIONS:MBAD_PAM)
pre-extract:
@${ECHO}