aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-01 16:13:45 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-01 16:13:45 +0000
commitb2aa13a92865516b92b02fd7e4e525286962c5da (patch)
treea52b3e5e36c4436205a5718d25629f949f39af77 /x11
parent6789dd6575a7dc3d7b58569b79477186441e24bf (diff)
downloadports-b2aa13a92865516b92b02fd7e4e525286962c5da.tar.gz
ports-b2aa13a92865516b92b02fd7e4e525286962c5da.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/lxpanel/Makefile17
-rw-r--r--x11/terminator/Makefile15
-rw-r--r--x11/xfce4-verve-plugin/Makefile12
3 files changed, 22 insertions, 22 deletions
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index 16a49d943612..8bbdb1770290 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lxpanel
-# Date created: Sat Oct 7 01:22:35 CST 2006
-# Whom: Lin, Cheng-Tao <b89605222@ntu.edu.tw>
-#
+# Created by: Lin, Cheng-Tao <b89605222@ntu.edu.tw>
# $FreeBSD$
-#
PORTNAME= lxpanel
PORTVERSION= 0.5.12
@@ -11,7 +7,7 @@ CATEGORIES= x11
MASTER_SITES= SF/lxde/LXPanel%20%28desktop%20panel%29/LXPanel%20${PORTVERSION}
MAINTAINER= kmoore@FreeBSD.org
-COMMENT= LXPanel is a lightweight X11 desktop panel
+COMMENT= Lightweight X11 desktop panel
LIB_DEPENDS= menu-cache.1:${PORTSDIR}/x11/menu-cache
RUN_DEPENDS= ${LOCALBASE}/share/desktop-directories/lxde-audio-video.directory:${PORTSDIR}/x11/lxmenu-data
@@ -20,7 +16,8 @@ OPTIONS_DEFINE= ALSA NLS
OPTIONS_DEFAULT=NLS
USE_XORG= x11 xmu
-USE_GNOME= gnomehack gtk20 pkgconfig libwnck
+USE_GNOME= gtk20 libwnck
+USES= pathfix pkgconfig
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake:env
CONFIGURE_ARGS= --prefix=${PREFIX} \
@@ -32,7 +29,7 @@ USE_GMAKE= yes
MAN1= lxpanel.1 lxpanelctl.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MALSA}
RUN_DEPENDS+= ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-f10-alsa-lib
@@ -41,7 +38,7 @@ CONFIGURE_ARGS+=--disable-alsa
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
@@ -54,4 +51,4 @@ pre-patch:
@${REINPLACE_CMD} -e 's,$$(DATADIRNAME)/locale,share/locale,' \
${WRKSRC}/po/Makefile.in.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/terminator/Makefile b/x11/terminator/Makefile
index 717c1d1bd02c..9610d8bfcb61 100644
--- a/x11/terminator/Makefile
+++ b/x11/terminator/Makefile
@@ -29,17 +29,20 @@ INSTALLS_ICONS= yes
WANT_GNOME= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-PYSETUP+= --without-icon-cache
-.if empty(PORT_OPTIONS:MNLS)
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
PLIST_SUB+= NLS="@comment "
PYSETUP+= --without-gettext
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
.endif
+.include <bsd.port.pre.mk>
+
+PYSETUP+= --without-icon-cache
+
.if ${PORT_OPTIONS:MGCONF}
USE_GNOME+= pygnome2
.endif
diff --git a/x11/xfce4-verve-plugin/Makefile b/x11/xfce4-verve-plugin/Makefile
index de313a3ecba8..f61194d9b24a 100644
--- a/x11/xfce4-verve-plugin/Makefile
+++ b/x11/xfce4-verve-plugin/Makefile
@@ -12,7 +12,7 @@ PKGNAMEPREFIX= xfce4-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= xfce@FreeBSD.org
-COMMENT= A command line plugin for Xfce4
+COMMENT= Command line plugin for Xfce4
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
@@ -20,18 +20,18 @@ USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack glib20 intltool intlhack
+USE_GNOME= glib20 intltool intlhack
USE_XFCE= configenv panel libexo libgui libutil
-USES= pkgconfig
+USES= pkgconfig pathfix
CONFIGURE_ARGS= --disable-debug
OPTIONS_DEFINE= NLS DBUS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
@@ -48,4 +48,4 @@ CONFIGURE_ARGS+=--disable-dbus
PLIST_SUB+= DBUS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>