aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
commit4b68fc723bc6478544954fa1a7554ca5c269f611 (patch)
tree752bd2703b89f85a96b337b223e14ab4bb621705 /x11
parent66521294b08078847ba4c56a6423c20cf34d68f8 (diff)
downloadports-4b68fc723bc6478544954fa1a7554ca5c269f611.tar.gz
ports-4b68fc723bc6478544954fa1a7554ca5c269f611.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/libexo/Makefile15
-rw-r--r--x11/libxfce4menu/Makefile26
-rw-r--r--x11/libxfce4util/Makefile17
-rw-r--r--x11/xfce4-conf/Makefile20
4 files changed, 36 insertions, 42 deletions
diff --git a/x11/libexo/Makefile b/x11/libexo/Makefile
index b6efff544d1c..efb42fb413f8 100644
--- a/x11/libexo/Makefile
+++ b/x11/libexo/Makefile
@@ -33,24 +33,23 @@ USE_XFCE= configenv libmenu libutil
USE_XORG= x11
CONFIGURE_ARGS+=--enable-gio-unix \
- --disable-gtk-doc-html
+ --disable-gtk-doc-html
-OPTIONS= APIDOCS "Install api documentation" off \
- NLS "Enable Native Language Support" on
+OPTIONS_DEFINE= DOCS NLS
MAN1= exo-csource.1 exo-open.1
.include <bsd.port.options.mk>
-.if defined(WITHOUT_APIDOCS)
-CONFIGURE_ARGS+=--without-html-dir
-PLIST_SUB+= APIDOCS="@comment "
-.else
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+=--with-html-dir=${PREFIX}/share/gtk-doc/html
PLIST_SUB+= APIDOCS=""
+.else
+CONFIGURE_ARGS+=--without-html-dir
+PLIST_SUB+= APIDOCS="@comment "
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
diff --git a/x11/libxfce4menu/Makefile b/x11/libxfce4menu/Makefile
index a76740b8c1e6..59938edff7ef 100644
--- a/x11/libxfce4menu/Makefile
+++ b/x11/libxfce4menu/Makefile
@@ -25,24 +25,22 @@ USE_XFCE= configenv libutil xfconf
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --disable-gtk-doc-html \
- --with-vendor-info=FreeBSD
+ --with-vendor-info=FreeBSD
-OPTIONS= APIDOCS "Install api documentation" off \
- NLS "Enable Native Language Support" on \
- STARTUP "Enable startup notification" on \
- GLADEUI "Enable Glade interface designer support" off
+OPTIONS_DEFINE= DOCS NLS NOTIFY GLADE
+OPTIONS_DEFAULT= NOTIFY
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_APIDOCS)
-CONFIGURE_ARGS+=--without-html-dir
-PLIST_SUB+= APIDOCS="@comment "
-.else
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+=--with-html-dir=${PREFIX}/share/gtk-doc/html
PLIST_SUB+= APIDOCS=""
+.else
+CONFIGURE_ARGS+=--without-html-dir
+PLIST_SUB+= APIDOCS="@comment "
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -51,18 +49,18 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(WITHOUT_STARTUP)
+.if ${PORT_OPTIONS:MNOTIFY}
LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
CONFIGURE_ARGS+=--enable-startup-notification
.else
CONFIGURE_ARGS+=--disable-startup-notification
.endif
-.if !defined(WITHOUT_GLADEUI)
+.if ${PORT_OPTIONS:MGLADE}
LIB_DEPENDS+= gladeui-1.10:${PORTSDIR}/devel/glade3
CONFIGURE_ARGS+=--enable-gladeui
.else
CONFIGURE_ARGS+=--disable-gladeui
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/libxfce4util/Makefile b/x11/libxfce4util/Makefile
index 63aa1a74aaa3..e9719465beaa 100644
--- a/x11/libxfce4util/Makefile
+++ b/x11/libxfce4util/Makefile
@@ -25,12 +25,11 @@ USE_XFCE= configenv
CONFIGURE_ARGS+=--disable-gtk-doc-html
-OPTIONS= NLS "Enable Native Language Support" on \
- APIDOCS "Install api documentation" off
+OPTIONS_DEFINE= NLS DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -39,12 +38,12 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITHOUT_APIDOCS)
-CONFIGURE_ARGS+=--without-html-dir
-PLIST_SUB+= APIDOCS="@comment "
-.else
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+=--with-html-dir=${PREFIX}/share/gtk-doc/html
PLIST_SUB+= APIDOCS=""
+.else
+CONFIGURE_ARGS+=--without-html-dir
+PLIST_SUB+= APIDOCS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/xfce4-conf/Makefile b/x11/xfce4-conf/Makefile
index 6c35952f44f4..12b48478788e 100644
--- a/x11/xfce4-conf/Makefile
+++ b/x11/xfce4-conf/Makefile
@@ -28,23 +28,21 @@ USE_XORG= x11
CONFIGURE_ARGS+=--disable-gtk-doc-html
-OPTIONS= APIDOCS "Install api documentation" off \
- PERL "Install Perl bindings" off \
- NLS "Enable Native Language Support" on
+OPTIONS_DEFINE= DOCS PERL NLS
MAN3PREFIX?= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_APIDOCS)
-CONFIGURE_ARGS+=--without-html-dir
-PLIST_SUB+= APIDOCS="@comment "
-.else
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+=--with-html-dir=${PREFIX}/share/gtk-doc/html
PLIST_SUB+= APIDOCS=""
+.else
+CONFIGURE_ARGS+=--without-html-dir
+PLIST_SUB+= APIDOCS="@comment "
.endif
-.if defined(WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
MAN3= Xfce4::Xfconf.3
BUILD_DEPENDS+= p5-ExtUtils-Depends>=0.300:${PORTSDIR}/devel/p5-ExtUtils-Depends \
p5-ExtUtils-PkgConfig>=1.12:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
@@ -57,7 +55,7 @@ CONFIGURE_ARGS+=--disable-perl-bindings
PLIST_SUB+= PERLBIND="@comment "
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -66,4 +64,4 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>