aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-06 22:00:19 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-06 22:00:19 +0000
commite142b9dd2612adae322b1e434969adbeeed795dc (patch)
tree683ff94f60542b82d014f74cc4453aee3491cf76 /x11
parentd4372f1606011c1e649fff8d2ded1d92003aca05 (diff)
downloadports-e142b9dd2612adae322b1e434969adbeeed795dc.tar.gz
ports-e142b9dd2612adae322b1e434969adbeeed795dc.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/e17-module-devian/Makefile1
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_config.c20
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_devian.c11
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_theme.c27
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_container.c20
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_data_file.c11
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_data_picture.c20
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_data_rss.c47
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_devian.c11
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_main.c11
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_source_file.c11
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_source_picture.c38
-rw-r--r--x11/e17-module-devian/files/patch-src__module__e_mod_source_rss.c20
13 files changed, 248 insertions, 0 deletions
diff --git a/x11/e17-module-devian/Makefile b/x11/e17-module-devian/Makefile
index c455c31b98ff..8d3581c9aca2 100644
--- a/x11/e17-module-devian/Makefile
+++ b/x11/e17-module-devian/Makefile
@@ -7,6 +7,7 @@
PORTNAME= devian
PORTVERSION= 23062006
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://mbsd.msk.ru/dist/
PKGNAMEPREFIX= e17-module-
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_config.c b/x11/e17-module-devian/files/patch-src__module__e_mod_config.c
new file mode 100644
index 000000000000..5bfef32cd41d
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_config.c
@@ -0,0 +1,20 @@
+--- src/module/e_mod_config.c.orig Thu Jul 6 23:32:07 2006
++++ src/module/e_mod_config.c Thu Jul 6 23:32:25 2006
+@@ -100,7 +100,7 @@
+ "has been upgraded<br>"
+ "Your settings were removed<br>"
+ "Sorry for the inconvenience<br><br>" "(%d -> %d)"), cfg_main->conf_version, CONFIG_VERSION);
+- e_module_dialog_show(_(MODULE_NAME " Module version " MODULE_VERSION), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module version " MODULE_VERSION), buf);
+
+ cfg_main = NULL;
+ }
+@@ -116,7 +116,7 @@
+ "has been downgraded<br>"
+ "Your settings were removed<br>"
+ "Sorry for the inconvenience<br><br>" "(%d ->%d)"), cfg_main->conf_version, CONFIG_VERSION);
+- e_module_dialog_show(_(MODULE_NAME " Module version " MODULE_VERSION), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module version " MODULE_VERSION), buf);
+ cfg_main = NULL;
+ }
+ }
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_devian.c b/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_devian.c
new file mode 100644
index 000000000000..cd4c580f3b49
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_devian.c
@@ -0,0 +1,11 @@
+--- src/module/e_mod_config_dialog_devian.c.orig Thu Jul 6 23:32:48 2006
++++ src/module/e_mod_config_dialog_devian.c Thu Jul 6 23:33:02 2006
+@@ -789,7 +789,7 @@
+ snprintf(buf, sizeof(buf),
+ _("<hilight>Rss '%s' is in use !</hilight><br><br>"
+ "You can't delete it while its in use.<br><br>" "Owner is %s"), doc->name, doc->user->source->devian->id);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ }
+ }
+ #endif
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_theme.c b/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_theme.c
new file mode 100644
index 000000000000..73338ca1ff69
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_config_dialog_theme.c
@@ -0,0 +1,27 @@
+--- src/module/e_mod_config_dialog_theme.c.orig Thu Jul 6 23:33:17 2006
++++ src/module/e_mod_config_dialog_theme.c Thu Jul 6 23:33:33 2006
+@@ -636,7 +636,7 @@
+ if (!ecore_file_is_dir(themes_path))
+ {
+ snprintf(buf, sizeof(buf), _("<hilight>Directory %s doesnt exists.</hilight><br><br>" "No themes found !!!"), themes_path);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return NULL;
+ }
+
+@@ -644,7 +644,7 @@
+ if (ecore_list_is_empty(list) || !list)
+ {
+ snprintf(buf, sizeof(buf), _("<hilight>Directory %s is empty !</hilight><br><br>" "No themes found !!!"), themes_path);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return NULL;
+ }
+
+@@ -701,5 +701,5 @@
+ snprintf(buf, sizeof(buf),
+ _("<hilight>Invalid theme</hilight><br><br>"
+ "You have selected an invalid theme.<br>" "A valid theme has a dEvian icon in front of it."));
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ }
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_container.c b/x11/e17-module-devian/files/patch-src__module__e_mod_container.c
new file mode 100644
index 000000000000..6f71799d61cd
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_container.c
@@ -0,0 +1,20 @@
+--- src/module/e_mod_container.c.orig Thu Jul 6 23:33:42 2006
++++ src/module/e_mod_container.c Thu Jul 6 23:33:53 2006
+@@ -248,7 +248,7 @@
+ char buf[4096];
+
+ snprintf(buf, sizeof(buf), _("<hilight>Invalid theme !</hilight><br><br>" "Failed to switch to %s theme"), *theme);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ evas_stringshare_del(*theme);
+ *theme = evas_stringshare_add(DEVIAN_THEME_DEFAULT);
+ DEVIANF(container_change) (devian, devian->conf->container_type);
+@@ -272,7 +272,7 @@
+
+ snprintf(buf, sizeof(buf),
+ _("<hilight>Invalid theme !</hilight><br><br>" "Failed to switch to %s theme"), *theme);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ evas_stringshare_del(*theme);
+ *theme = evas_stringshare_add(DEVIAN_THEME_DEFAULT);
+ DEVIANF(container_change) (devian, devian->conf->container_type);
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_data_file.c b/x11/e17-module-devian/files/patch-src__module__e_mod_data_file.c
new file mode 100644
index 000000000000..a4f3aab53a05
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_data_file.c
@@ -0,0 +1,11 @@
+--- src/module/e_mod_data_file.c.orig Thu Jul 6 23:30:59 2006
++++ src/module/e_mod_data_file.c Thu Jul 6 23:31:07 2006
+@@ -33,7 +33,7 @@
+ snprintf(buf, sizeof(buf),
+ _("<hilight>Can't open file %s</hilight><br><br>"
+ "You can change the file in the dEvian's config panel"), source->devian->conf->file_path);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ }
+
+ /* create the textblock */
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_data_picture.c b/x11/e17-module-devian/files/patch-src__module__e_mod_data_picture.c
new file mode 100644
index 000000000000..d8de6e37e18d
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_data_picture.c
@@ -0,0 +1,20 @@
+--- src/module/e_mod_data_picture.c.orig Thu Jul 6 23:30:33 2006
++++ src/module/e_mod_data_picture.c Thu Jul 6 23:30:56 2006
+@@ -402,7 +402,7 @@
+ "They can be jpeg or png<br><br>"
+ "After import, if you can remove these files and the pictures still can<br>"
+ "be viewed, but you wont be able to set them as wallpaper anymore<br><br>"), dir);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return 0;
+ }
+
+@@ -1199,7 +1199,7 @@
+ DEVIANM->conf->sources_picture_data_import_thumbs_warn)
+ {
+ DEVIANM->conf->sources_picture_data_import_thumbs_warn = 0;
+- e_module_dialog_show(_(MODULE_NAME " Module Information"),
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Information"),
+ _("<hilight>Creating thumbs</hilight><br><br>"
+ "Some pictures are being thumbed in a <hilight>background task</hilight>.<br>"
+ "It can take a while, but after, loading will be faster :)<br><br>"
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_data_rss.c b/x11/e17-module-devian/files/patch-src__module__e_mod_data_rss.c
new file mode 100644
index 000000000000..d0b0eae4bf2a
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_data_rss.c
@@ -0,0 +1,47 @@
+--- src/module/e_mod_data_rss.c.orig Thu Jul 6 23:30:02 2006
++++ src/module/e_mod_data_rss.c Thu Jul 6 23:30:29 2006
+@@ -280,7 +280,7 @@
+ snprintf(buf, sizeof(buf),
+ _("<hilight>Rss '%s' is aready in use !</hilight><br><br>"
+ "You can't set a rss document to more than one dEvian<br><br>" "Url: %s"), doc->name, doc->url);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return -1;
+ }
+
+@@ -561,7 +561,7 @@
+ "<underline=on underline_color=#000>Url :</> %s<br>"
+ "<underline=on underline_color=#000>Begining of the document dEvian get :</><br>%100.100s"),
+ doc->name, doc->url, feed->buffer);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ }
+ else
+ {
+@@ -572,7 +572,7 @@
+ "<underline=on underline_color=#000>Url :</> %s<br>"
+ "<underline=on underline_color=#000>Begining of the document dEvian get :</><br>%100.100s<br>"
+ "%100.100s"), doc->name, doc->url, feed->buffer, p);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ }
+ }
+ DEVIANF(container_loading_state_change) (feed->source->devian, 0);
+@@ -1009,7 +1009,7 @@
+ {
+ snprintf(buf, sizeof(buf),
+ _("<hilight>Unable to open link</hilight><br><br>" "Article '%s' has no link associated !"), article->title);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return;
+ }
+
+@@ -1029,7 +1029,7 @@
+ _("<hilight>Viewer %s not found !</hilight><br><br>"
+ "You can change the viewer for http in dEvian configuration panel\
+ (Advanced view)"), DEVIANM->conf->viewer_http);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return;
+ }
+
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_devian.c b/x11/e17-module-devian/files/patch-src__module__e_mod_devian.c
new file mode 100644
index 000000000000..806f812f99b6
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_devian.c
@@ -0,0 +1,11 @@
+--- src/module/e_mod_devian.c.orig Thu Jul 6 23:34:34 2006
++++ src/module/e_mod_devian.c Thu Jul 6 23:34:41 2006
+@@ -443,7 +443,7 @@
+
+ snprintf(buf, sizeof(buf),
+ _("<hilight>Error !</hilight><br>" "Did not find <hilight>theme</hilight> %s group %s"), path, part);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return NULL;
+ }
+ DMAIN(("Edje loaded %s group %s", path, part));
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_main.c b/x11/e17-module-devian/files/patch-src__module__e_mod_main.c
new file mode 100644
index 000000000000..4284969b62ab
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_main.c
@@ -0,0 +1,11 @@
+--- src/module/e_mod_main.c.orig Thu Jul 6 23:28:34 2006
++++ src/module/e_mod_main.c Thu Jul 6 23:28:50 2006
+@@ -48,7 +48,7 @@
+ char buf[4096];
+
+ snprintf(buf, sizeof(buf), _("Enlightenment %s Module - version " MODULE_VERSION), MODULE_NAME);
+- e_module_dialog_show(buf, _(
++ e_module_dialog_show(m, buf, _(
+ #ifndef HAVE_ALL
+ "This module is part of dEvian module<br><br>"
+ #ifdef HAVE_PICTURE
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_source_file.c b/x11/e17-module-devian/files/patch-src__module__e_mod_source_file.c
new file mode 100644
index 000000000000..59bcfb49d150
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_source_file.c
@@ -0,0 +1,11 @@
+--- src/module/e_mod_source_file.c.orig Thu Jul 6 23:29:46 2006
++++ src/module/e_mod_source_file.c Thu Jul 6 23:29:54 2006
+@@ -24,7 +24,7 @@
+ snprintf(buf, sizeof(buf),
+ _("<hilight>dEvian's Log feature isn't stable yet !</hilight><br><br>"
+ "It's disabled for now"));
+- e_module_dialog_show(_(MODULE_NAME " Module error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module error"), buf);
+ return 0;
+ }
+ #endif
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_source_picture.c b/x11/e17-module-devian/files/patch-src__module__e_mod_source_picture.c
new file mode 100644
index 000000000000..e220b744198a
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_source_picture.c
@@ -0,0 +1,38 @@
+--- src/module/e_mod_source_picture.c.orig Thu Jul 6 23:29:20 2006
++++ src/module/e_mod_source_picture.c Thu Jul 6 23:29:41 2006
+@@ -174,7 +174,7 @@
+ _("<hilight>File %s doesnt exists.</hilight><br><br>"
+ "This file is in dEvian's picture list, but it seems you removed it from the disk<br>"
+ "It cant be set as background, sorry."), file);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return 0;
+ }
+
+@@ -201,7 +201,7 @@
+ "%s is not an edje file !<br>"
+ "dEvian need e17setroot util from e_utils package to set you're picture as background"
+ "Please install it and try again"), file);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return 0;
+ }
+ }
+@@ -261,7 +261,7 @@
+ _("<hilight>File %s doesnt exists !</hilight><br><br>"
+ "This file is in dEvian's picture list, but it seems you removed it from the disk.<br>"
+ "It cant be set opened in a viewer, sorry."), file);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return 0;
+ }
+
+@@ -281,7 +281,7 @@
+ _("<hilight>Viewer %s not found !</hilight><br><br>"
+ "You can change the viewer for images in dEvian configuration panel (Advanced view)"),
+ DEVIANM->conf->viewer_image);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return 0;
+ }
+
diff --git a/x11/e17-module-devian/files/patch-src__module__e_mod_source_rss.c b/x11/e17-module-devian/files/patch-src__module__e_mod_source_rss.c
new file mode 100644
index 000000000000..abef36a9889f
--- /dev/null
+++ b/x11/e17-module-devian/files/patch-src__module__e_mod_source_rss.c
@@ -0,0 +1,20 @@
+--- src/module/e_mod_source_rss.c.orig Thu Jul 6 23:28:58 2006
++++ src/module/e_mod_source_rss.c Thu Jul 6 23:29:14 2006
+@@ -108,7 +108,7 @@
+ snprintf(buf, sizeof(buf),
+ _("<hilight>Unable to open link</hilight><br><br>"
+ "Feed '%s' has no link associated !"), source->devian->conf->rss_doc->name);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return 0;
+ }
+
+@@ -128,7 +128,7 @@
+ _("<hilight>Viewer %s not found !</hilight><br><br>"
+ "You can change the viewer for http in DEVIANN configuration panel (Advanced view)"),
+ DEVIANM->conf->viewer_http);
+- e_module_dialog_show(_(MODULE_NAME " Module Error"), buf);
++ e_module_dialog_show(DEVIANM->module, _(MODULE_NAME " Module Error"), buf);
+ return 0;
+ }
+