aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-22 00:30:35 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-22 00:30:35 +0000
commit2005bec2e389eae4f370be9be6c7c92b0caa3f1c (patch)
treeecafedc7d90afd94c423abcfc02443e8f71ec31c /x11
parent72887b1ed1e6d1ef0642acff5415998eb51092b3 (diff)
downloadports-2005bec2e389eae4f370be9be6c7c92b0caa3f1c.tar.gz
ports-2005bec2e389eae4f370be9be6c7c92b0caa3f1c.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/fixesext/Makefile29
-rw-r--r--x11/fixesext/distinfo1
-rw-r--r--x11/fixesext/files/patch-Makefile.in11
-rw-r--r--x11/fixesext/pkg-descr6
-rw-r--r--x11/fixesext/pkg-plist5
6 files changed, 53 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index b7473ba7333d..757a01ab925f 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -38,6 +38,7 @@
SUBDIR += eterm
SUBDIR += eweather
SUBDIR += fbsd-icons
+ SUBDIR += fixesext
SUBDIR += fluxbg
SUBDIR += fspanel
SUBDIR += gdkxft
diff --git a/x11/fixesext/Makefile b/x11/fixesext/Makefile
new file mode 100644
index 000000000000..354b5437840d
--- /dev/null
+++ b/x11/fixesext/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: fixesext
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fixesext
+PORTVERSION= 2.0.p2
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Fixes extension headers and specification
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xextensions.pc:${PORTSDIR}/x11/xextensions
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.0
+
+.include <bsd.port.mk>
diff --git a/x11/fixesext/distinfo b/x11/fixesext/distinfo
new file mode 100644
index 000000000000..42ed68eecaa1
--- /dev/null
+++ b/x11/fixesext/distinfo
@@ -0,0 +1 @@
+MD5 (fixesext-2.0.p2.tar.bz2) = 386ee5346f162c443bd8c8905784491c
diff --git a/x11/fixesext/files/patch-Makefile.in b/x11/fixesext/files/patch-Makefile.in
new file mode 100644
index 000000000000..6ba01bb85635
--- /dev/null
+++ b/x11/fixesext/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Nov 9 22:38:12 2003
++++ Makefile.in Sun Nov 9 22:38:22 2003
+@@ -125,7 +125,7 @@
+ fixesextdocdir = $(datadir)/doc/fixesext
+ fixesextdoc_DATA = protocol
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = fixesext.pc
+
+ EXTRA_DIST = autogen.sh fixesext.pc.in $(fixesextdoc_DATA)
diff --git a/x11/fixesext/pkg-descr b/x11/fixesext/pkg-descr
new file mode 100644
index 000000000000..06274a96e27a
--- /dev/null
+++ b/x11/fixesext/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X Fixes extension headers and specification
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/fixesext/pkg-plist b/x11/fixesext/pkg-plist
new file mode 100644
index 000000000000..2675c130d1bf
--- /dev/null
+++ b/x11/fixesext/pkg-plist
@@ -0,0 +1,5 @@
+include/X11/extensions/xfixesproto.h
+include/X11/extensions/xfixeswire.h
+libdata/pkgconfig/fixesext.pc
+%%DOCSDIR%%/protocol
+@dirrm %%DOCSDIR%%