aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorDejan Lesjak <lesi@FreeBSD.org>2006-02-01 21:20:03 +0000
committerDejan Lesjak <lesi@FreeBSD.org>2006-02-01 21:20:03 +0000
commit56b91b85470cefa84a325b81d0b610a11808a10d (patch)
tree5142672ca8a24407eccb1ea514bc0da3502fe50d /x11
parent54a0cec780c773071a56dc1ac61fe7bbfe3a0461 (diff)
downloadports-56b91b85470cefa84a325b81d0b610a11808a10d.tar.gz
ports-56b91b85470cefa84a325b81d0b610a11808a10d.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/xorg-clients/Makefile5
-rw-r--r--x11/xorg-clients/files/extra-patch-4x79
-rw-r--r--x11/xorg-clients/files/patch-symbols_pc_gr38
3 files changed, 122 insertions, 0 deletions
diff --git a/x11/xorg-clients/Makefile b/x11/xorg-clients/Makefile
index 301fe117a4c0..567cea88143d 100644
--- a/x11/xorg-clients/Makefile
+++ b/x11/xorg-clients/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xorg-clients
PORTVERSION= 6.9.0
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XORG}
MASTER_SITE_SUBDIR= X11R${PORTVERSION}/src
@@ -84,6 +85,10 @@ post-install:
.include "${.CURDIR}/../../x11-servers/xorg-server/Makefile.inc"
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 502123
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-4x
+.endif
+
.if ${X_WINDOW_SYSTEM:L} != xorg
IGNORE= is part of X.Org and you have ${X_WINDOW_SYSTEM} set for X11\
distribution. See The X Window System and Virtual Consoles chapter\
diff --git a/x11/xorg-clients/files/extra-patch-4x b/x11/xorg-clients/files/extra-patch-4x
new file mode 100644
index 000000000000..91672685e8c4
--- /dev/null
+++ b/x11/xorg-clients/files/extra-patch-4x
@@ -0,0 +1,79 @@
+--- programs/xedit/util.c.orig Fri Jan 27 13:07:57 2006
++++ programs/xedit/util.c Fri Jan 27 13:10:58 2006
+@@ -58,43 +58,14 @@
+ extern Widget vpanes[2], labels[3], texts[3], forms[3];
+ extern XawTextWrapMode wrapmodes[3];
+
+-#ifndef va_copy
+-# ifdef __va_copy
+-# define va_copy __va_copy
+-# else
+-# error "no working va_copy was found"
+-# endif
+-#endif
+-
+ /*
+ * Implementation
+ */
+ void
+-XeditPrintf(const char *format, ...)
++XeditPrintf(char *str)
+ {
+- char *str;
+- size_t size;
+- va_list va,
+- va2;
+- XawTextBlock text;
+- XawTextPosition pos;
+-
+- va_start(va, format);
+-
+- va_copy(va2, va);
+- size = vsnprintf(NULL, 0, format, va2);
+- va_end(va2);
+-
+- str = (char *)malloc(size + 1);
+- if (str == NULL)
+- return;
+-
+- vsnprintf(str, size + 1, format, va);
+- str[size] = 0;
+-
+- va_end(va);
+-
+- pos = XawTextSourceScan(XawTextGetSource(messwidget),
++ XawTextBlock text;
++ XawTextPosition pos = XawTextSourceScan(XawTextGetSource(messwidget),
+ 0, XawstAll, XawsdRight, 1, True);
+
+ text.length = strlen(str);
+@@ -106,7 +77,6 @@
+
+ XawTextSetInsertionPoint(messwidget, pos + text.length);
+
+- free(str);
+ }
+
+ Widget
+--- programs/xedit/xedit.h.orig Fri Jan 27 13:11:42 2006
++++ programs/xedit/xedit.h Fri Jan 27 13:12:55 2006
+@@ -106,7 +106,7 @@
+ void Feep(void);
+
+ /* externals in util.c */
+-void XeditPrintf(const char *format, ...);
++void XeditPrintf(char*);
+ Widget MakeCommandButton(Widget, char*, XtCallbackProc);
+ Widget MakeStringBox(Widget, String, String);
+ String GetString(Widget);
+--- programs/xmore/print.h.orig Fri Jan 27 13:21:05 2006
++++ programs/xmore/print.h Fri Jan 27 13:22:53 2006
+@@ -38,7 +38,7 @@
+ #if defined(XMORE)
+ #define PrintMsg(x) { printf("xmore: "); printf x ; }
+ #elif defined(XEDIT)
+-#define PrintMsg(x) { XeditPrintf x ; }
++#define PrintMsg(x) { printf("xedit: "); printf x ; }
+ #else
+ #error unknown application
+ #endif
diff --git a/x11/xorg-clients/files/patch-symbols_pc_gr b/x11/xorg-clients/files/patch-symbols_pc_gr
new file mode 100644
index 000000000000..a18b27cbc105
--- /dev/null
+++ b/x11/xorg-clients/files/patch-symbols_pc_gr
@@ -0,0 +1,38 @@
+--- programs/xkbcomp/symbols/pc/gr.orig Tue Jan 31 20:28:22 2006
++++ programs/xkbcomp/symbols/pc/gr Tue Jan 31 20:29:05 2006
+@@ -13,7 +13,7 @@
+ default partial alphanumeric_keys alternate_group
+ xkb_symbols "basic" {
+
+- include "pc/el(bare)"
++ include "pc/gr(bare)"
+
+ name[Group1] = "Greece";
+
+@@ -83,7 +83,7 @@
+ partial alphanumeric_keys alternate_group
+ xkb_symbols "extended" {
+
+- include "pc/el(basic)"
++ include "pc/gr(basic)"
+ name[Group1] = "Greece - Extended";
+
+ key.type = "THREE_LEVEL";
+@@ -102,7 +102,7 @@
+ partial alphanumeric_keys alternate_group
+ xkb_symbols "polytonic" {
+
+- include "pc/el(extended)"
++ include "pc/gr(extended)"
+
+ name[Group1] = "Greece - Polytonic";
+
+@@ -119,7 +119,7 @@
+ partial alphanumeric_keys alternate_group
+ xkb_symbols "nodeadkeys" {
+
+- include "pc/el(basic)"
++ include "pc/gr(basic)"
+ name[Group1] = "Greece - Eliminate dead keys";
+
+ key <AC10> { [ semicolon, colon ] };