aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2005-08-28 08:20:53 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2005-08-28 08:20:53 +0000
commitbade40d1c8efd3bf27a2d82af840298e187130ca (patch)
treeec2d045da5bc01901835a34955d0fd10c0a99a19 /x11
parentbfbbdad41276ab22f33ea164e51516cf5497fbb5 (diff)
Rearrange the kdelibs3 and kdelibs3-nocups ports so that it's possible
to build a cups-disabled kdelibs from the get-go by defining WITHOUT_CUPS or KDE_WITHOUT_CUPS during builds. Proposed and based on a patch submitted by: mi
Notes
Notes: svn path=/head/; revision=141045
Diffstat (limited to 'x11')
-rw-r--r--x11/kdelibs3-nocups/Makefile10
-rw-r--r--x11/kdelibs3/Makefile9
-rw-r--r--x11/kdelibs4/Makefile9
3 files changed, 16 insertions, 12 deletions
diff --git a/x11/kdelibs3-nocups/Makefile b/x11/kdelibs3-nocups/Makefile
index 7ffadeb0f62c..30e1c98bac39 100644
--- a/x11/kdelibs3-nocups/Makefile
+++ b/x11/kdelibs3-nocups/Makefile
@@ -4,15 +4,13 @@
#
# $FreeBSD$
-PORTNAME= kdelibs3
-PKGNAMESUFFIX= -nocups
+PORTNAME?= kdelibs3
+PKGNAMESUFFIX?= -nocups
MAINTAINER= kde@FreeBSD.org
-MASTERDIR= ${.CURDIR}/../kdelibs3
-CONFLICTS+= kdelibs-[0-9]*
-
-CONFIGURE_ARGS+= --disable-cups
PLIST= ${.CURDIR}/pkg-plist
+WITHOUT_CUPS= yes
+MASTERDIR= ${.CURDIR}/../../x11/kdelibs3
.include "${MASTERDIR}/Makefile"
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index 6c228e839832..e959c44f3193 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -36,11 +36,14 @@ RUN_DEPENDS= iceauth:${X_CLIENTS_PORT} \
${FONTSCALE}:${X_FONTS_TTF_PORT} \
${FONTENCOD}:${X_FONTS_ENCODINGS_PORT}
-.if ${PKGNAMESUFFIX} == -nocups
CONFLICTS+= kdeadmin-3.[0-3].* kdeadmin-3.4.[0-1]* kdeartwork-3.[2-3]* kdebase-3.[0-3]* kdepim-3.2*
+.if defined(WITHOUT_CUPS) || defined(KDE_WITHOUT_CUPS)
+CONFLICTS+= kdelibs-[0-9]*
+PKGNAMESUFFIX= -nocups
+CONFIGURE_ARGS+=--disable-cups
.else
-CONFLICTS+= kdeadmin-3.[0-3].* kdeadmin-3.4.[0-1]* kdeartwork-3.[2-3]* kdebase-3.[0-3]* kdelibs-nocups-[0-9]* kdepim-3.2*
-LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+CONFLICTS+= kdelibs-nocups-[0-9]*
+LIB_DEPENDS+= cups:${PORTSDIR}/print/cups-base
.endif
USE_GETTEXT= yes
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 6c228e839832..e959c44f3193 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -36,11 +36,14 @@ RUN_DEPENDS= iceauth:${X_CLIENTS_PORT} \
${FONTSCALE}:${X_FONTS_TTF_PORT} \
${FONTENCOD}:${X_FONTS_ENCODINGS_PORT}
-.if ${PKGNAMESUFFIX} == -nocups
CONFLICTS+= kdeadmin-3.[0-3].* kdeadmin-3.4.[0-1]* kdeartwork-3.[2-3]* kdebase-3.[0-3]* kdepim-3.2*
+.if defined(WITHOUT_CUPS) || defined(KDE_WITHOUT_CUPS)
+CONFLICTS+= kdelibs-[0-9]*
+PKGNAMESUFFIX= -nocups
+CONFIGURE_ARGS+=--disable-cups
.else
-CONFLICTS+= kdeadmin-3.[0-3].* kdeadmin-3.4.[0-1]* kdeartwork-3.[2-3]* kdebase-3.[0-3]* kdelibs-nocups-[0-9]* kdepim-3.2*
-LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+CONFLICTS+= kdelibs-nocups-[0-9]*
+LIB_DEPENDS+= cups:${PORTSDIR}/print/cups-base
.endif
USE_GETTEXT= yes