aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-25 09:59:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-25 09:59:38 +0000
commit578899e105e80d1e1c6642587d2cada6a4bf6b1a (patch)
tree94da5e39dec75f0d387d556ea729b9e95c10a7b3 /x11
parent6a5f84f7bbbe1c7c9a9f4b5b996ff38aadd64bfa (diff)
downloadports-578899e105e80d1e1c6642587d2cada6a4bf6b1a.tar.gz
ports-578899e105e80d1e1c6642587d2cada6a4bf6b1a.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/trayer-srg/Makefile47
-rw-r--r--x11/trayer-srg/distinfo2
-rw-r--r--x11/trayer-srg/files/patch-Makefile.common15
-rw-r--r--x11/trayer-srg/pkg-descr12
5 files changed, 77 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index cb3a21519bc1..487a6dc34998 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -277,6 +277,7 @@
SUBDIR += tkXwin
SUBDIR += trapproto
SUBDIR += trayer
+ SUBDIR += trayer-srg
SUBDIR += tycoon
SUBDIR += vdesk
SUBDIR += videoproto
diff --git a/x11/trayer-srg/Makefile b/x11/trayer-srg/Makefile
new file mode 100644
index 000000000000..c60515c63727
--- /dev/null
+++ b/x11/trayer-srg/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: trayer-srg
+# Date created: Jun 21, 2011
+# Whom: Guido Falsi <mad@madpilot.net>
+# Based on the x11/trayer port Makefile from Alexey Mikhailov <karma@ez.pereslavl.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trayer
+PORTVERSION= 1.1.1
+CATEGORIES= x11
+MASTER_SITES= http://github.com/sargon/${PORTNAME}${PKGNAMESUFFIX}/tarball/${PORTNAME}-${PORTVERSION}/
+PKGNAMESUFFIX= -srg
+DISTNAME= sargon-${PORTNAME}${PKGNAMESUFFIX}-${PORTNAME}-${PORTVERSION}-${GITVERSION}
+
+MAINTAINER= mad@madpilot.net
+COMMENT= Lightweight GTK2-based systray for UNIX desktop - sargon fork
+
+CONFLICTS_INSTALL= trayer-1.0*
+GITVERSION= 0-g82d5d05
+FETCH_ARGS= -pRr
+WRKSRC= ${WRKDIR}/sargon-${PORTNAME}${PKGNAMESUFFIX}-${GITVERSION:S/^0-g//}
+USE_GNOME= gtk20 glib20 pango atk
+USE_ICONV= yes
+USE_XORG= xmu
+USE_GMAKE= yes
+MAKE_ARGS= "PREFIX=${PREFIX}"
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README CREDITS CHANGELOG
+.endif
+
+PLIST_FILES= bin/trayer
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/Makefile.common
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/trayer-srg/distinfo b/x11/trayer-srg/distinfo
new file mode 100644
index 000000000000..f56ab6fd8819
--- /dev/null
+++ b/x11/trayer-srg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sargon-trayer-srg-trayer-1.1.1-0-g82d5d05.tar.gz) = 94121f2c69d18e074982c6c2b808879076d0034fa70a144adf5d5dcb2b3c60eb
+SIZE (sargon-trayer-srg-trayer-1.1.1-0-g82d5d05.tar.gz) = 24645
diff --git a/x11/trayer-srg/files/patch-Makefile.common b/x11/trayer-srg/files/patch-Makefile.common
new file mode 100644
index 000000000000..bcf5eb8195a6
--- /dev/null
+++ b/x11/trayer-srg/files/patch-Makefile.common
@@ -0,0 +1,15 @@
+--- Makefile.common.orig 2011-05-01 15:07:21.000000000 +0200
++++ Makefile.common 2011-06-21 15:50:10.302230043 +0200
+@@ -15,10 +15,10 @@
+ endif
+ endif
+
+-CC = gcc
++CC ?= gcc
+ LIBS = $(shell pkg-config --libs gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0) -lX11 -L/usr/X11R6/lib -lXmu
+ INCS = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
+-CFLAGS = -O2 # overwriten by command line or env. variable
++CFLAGS ?= -O2 # overwriten by command line or env. variable
+ CFLAGS += -Wall # always nice to have
+ ifneq (,$(DEVEL))
+ CFLAGS := -g -Wall
diff --git a/x11/trayer-srg/pkg-descr b/x11/trayer-srg/pkg-descr
new file mode 100644
index 000000000000..c55c223f7d57
--- /dev/null
+++ b/x11/trayer-srg/pkg-descr
@@ -0,0 +1,12 @@
+trayer-srg was forked from trayer in january 2010 to add some
+fancy features and clean up code.
+
+trayer is small program designed to provide systray functionality
+present in GNOME/KDE desktop enviroments for window managers
+which doesn't support that function. It's similar to other
+applications such as 'peksystray' and 'docker'.
+
+trayer code was extracted from fbpanel application, you can find more
+about it on it's homepage
+
+WWW: http://github.com/sargon/trayer-srg