aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2019-09-26 19:34:53 +0000
committerCy Schubert <cy@FreeBSD.org>2019-09-26 19:34:53 +0000
commit4428aef27eae77c6b66fec1eb1f64c8ad00e8f61 (patch)
tree3fc488a2e9e27eaa41d146d3bc9924833c1a7bf3 /x11
parent6ab99f7fcfbad8c93c5a30d26ce20d9bb71f9e72 (diff)
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/xforward/Makefile5
-rw-r--r--x11/xforward/files/patch-Makefile13
2 files changed, 10 insertions, 8 deletions
diff --git a/x11/xforward/Makefile b/x11/xforward/Makefile
index a16773755114..814f340ce2d4 100644
--- a/x11/xforward/Makefile
+++ b/x11/xforward/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xforward
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://komquats.com/distfiles/ \
http://people.freebsd.org/~cy/distfiles/
@@ -18,8 +19,8 @@ LIB_DEPENDS= libpng.so:graphics/png \
libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2
-USES= motif
-USE_XORG= x11 xt xaw xmu xt xext sm ice xp xft xau xcb xdmcp xrender
+USES= motif xorg
+USE_XORG= x11 xt xaw xmu xt xext sm ice xft xau xcb xdmcp xrender
MAKE_ARGS= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
NO_WRKSUBDIR= yes
diff --git a/x11/xforward/files/patch-Makefile b/x11/xforward/files/patch-Makefile
index 1e35b4c243b9..66c2676027f1 100644
--- a/x11/xforward/files/patch-Makefile
+++ b/x11/xforward/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 1993-06-04 19:32:01.000000000 -0700
-+++ Makefile 2016-04-29 22:53:07.305978000 -0700
-@@ -18,17 +18,19 @@
+--- Makefile.orig 1993-06-05 02:32:01 UTC
++++ Makefile
+@@ -18,18 +18,20 @@
# MANDIR is where the manual page will be installed.
DESTDIR=
@@ -20,12 +20,13 @@
+INCFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+LIBS= -lXm -lXt -lX11 -lXext
-+LIBS_STATIC= -lXm -lXmu -lXt -lXext -lSM -lICE -lpng16 -lz -lm -ljpeg -lXp -lXft -lfontconfig -lexpat -lfreetype -lbz2 -lX11 -lXau -lxcb -lXdmcp -lXau -lXft -lXrender
-+
++LIBS_STATIC= -lXm -lXmu -lXt -lXext -lSM -lICE -lpng16 -lz -lm -ljpeg -lXft -lfontconfig -lexpat -lfreetype -lbz2 -lX11 -lXau -lxcb -lXdmcp -lXau -lXft -lXrender
++
CFLAGS= ${INCFLAGS} -O
-@@ -39,20 +41,30 @@
+ # For CenterLine CodeCenter
+@@ -39,20 +41,30 @@ SRCS= xforward.c
AUXFILES= README NOTICE Makefile xforward.1
PROGS = xforward