aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-01-21 22:57:14 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-01-21 22:57:14 +0000
commit51b7b4e45f24c850b0508c62af81736ca47b1a16 (patch)
treebfa7e4ff4a3c3ae30d498392636a63923154529d /x11
parent9feea1f72d6c75492872f05ecbe996213dfc54a7 (diff)
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/hs-X11/Makefile10
-rw-r--r--x11/hs-X11/pkg-plist46
-rw-r--r--x11/hs-x11-ghc/Makefile10
-rw-r--r--x11/hs-x11-ghc/pkg-plist46
4 files changed, 90 insertions, 22 deletions
diff --git a/x11/hs-X11/Makefile b/x11/hs-X11/Makefile
index 27f4baab8181..8cde9de08f70 100644
--- a/x11/hs-X11/Makefile
+++ b/x11/hs-X11/Makefile
@@ -6,7 +6,7 @@
PORTNAME= x11
PORTVERSION= 1.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/X11/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -36,8 +36,13 @@ USE_XORG= x11 xext sm
# 'owned' by lang/ghc:
CABALDIR= ${PREFIX}/lib/ghc-${GHC_VERSION}/cabal
CABALCMD= ${LOCALBASE}/bin/runghc Setup.hs
+DOCSDIR= ${PREFIX}/share/doc/X11-${PORTVERSION}
SUBDIR= ${PORTNAME}${PKGNAMESUFFIX}
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+
do-configure:
cd ${WRKSRC} && ${CABALCMD} configure --ghc --prefix=${PREFIX} --libdir=${CABALDIR} \
--libsubdir='' --datasubdir=''
@@ -45,6 +50,9 @@ do-configure:
do-build:
cd ${WRKSRC} && ${CABALCMD} build \
&& ${CABALCMD} --gen-script register
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${CABALCMD} haddock
+.endif
do-install:
cd ${WRKSRC} && ${CABALCMD} install \
diff --git a/x11/hs-X11/pkg-plist b/x11/hs-X11/pkg-plist
index 41a8606032c8..b0679cfa666b 100644
--- a/x11/hs-X11/pkg-plist
+++ b/x11/hs-X11/pkg-plist
@@ -1,31 +1,57 @@
+%%SUBDIR%%/Graphics/X11.hi
+%%SUBDIR%%/Graphics/X11/Types.hi
%%SUBDIR%%/Graphics/X11/Xinerama.hi
-%%SUBDIR%%/Graphics/X11/Xlib/Extras.hi
-%%SUBDIR%%/include/XlibExtras.h
+%%SUBDIR%%/Graphics/X11/Xlib.hi
%%SUBDIR%%/Graphics/X11/Xlib/Atom.hi
%%SUBDIR%%/Graphics/X11/Xlib/Color.hi
%%SUBDIR%%/Graphics/X11/Xlib/Context.hi
%%SUBDIR%%/Graphics/X11/Xlib/Display.hi
%%SUBDIR%%/Graphics/X11/Xlib/Event.hi
+%%SUBDIR%%/Graphics/X11/Xlib/Extras.hi
%%SUBDIR%%/Graphics/X11/Xlib/Font.hi
+%%SUBDIR%%/Graphics/X11/Xlib/Image.hi
%%SUBDIR%%/Graphics/X11/Xlib/Misc.hi
%%SUBDIR%%/Graphics/X11/Xlib/Region.hi
%%SUBDIR%%/Graphics/X11/Xlib/Screen.hi
%%SUBDIR%%/Graphics/X11/Xlib/Types.hi
%%SUBDIR%%/Graphics/X11/Xlib/Window.hi
-%%SUBDIR%%/Graphics/X11/Xlib/Image.hi
-%%SUBDIR%%/Graphics/X11/Types.hi
-%%SUBDIR%%/Graphics/X11/Xlib.hi
-%%SUBDIR%%/Graphics/X11.hi
-%%SUBDIR%%/libHSX11-%%PORTVERSION%%.a
%%SUBDIR%%/HSX11-%%PORTVERSION%%.o
%%SUBDIR%%/include/HsXlib.h
+%%SUBDIR%%/include/XlibExtras.h
+%%SUBDIR%%/libHSX11-%%PORTVERSION%%.a
%%SUBDIR%%/%%PORTNAME%%-register.sh
-share/doc/X11-1.4.1/LICENSE
-@dirrm share/doc/X11-1.4.1
+%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Types.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xinerama.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Atom.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Color.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Context.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Display.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Event.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Extras.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Font.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Image.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Misc.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Region.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Screen.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Types.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Window.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11.html
+%%PORTDOCS%%%%DOCSDIR%%/html/X11.haddock
+%%PORTDOCS%%%%DOCSDIR%%/html/doc-index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/haddock-util.js
+%%PORTDOCS%%%%DOCSDIR%%/html/haddock.css
+%%PORTDOCS%%%%DOCSDIR%%/html/haskell_icon.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/minus.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/plus.gif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+@dirrm %%DOCSDIR%%
+@dirrmtry %%SUBDIR%%/include
@dirrm %%SUBDIR%%/Graphics/X11/Xlib
@dirrm %%SUBDIR%%/Graphics/X11
@dirrmtry %%SUBDIR%%/Graphics
-@dirrmtry %%SUBDIR%%/include
@exec /bin/sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
@unexec %D/bin/ghc-pkg unregister X11
diff --git a/x11/hs-x11-ghc/Makefile b/x11/hs-x11-ghc/Makefile
index 27f4baab8181..8cde9de08f70 100644
--- a/x11/hs-x11-ghc/Makefile
+++ b/x11/hs-x11-ghc/Makefile
@@ -6,7 +6,7 @@
PORTNAME= x11
PORTVERSION= 1.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/X11/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -36,8 +36,13 @@ USE_XORG= x11 xext sm
# 'owned' by lang/ghc:
CABALDIR= ${PREFIX}/lib/ghc-${GHC_VERSION}/cabal
CABALCMD= ${LOCALBASE}/bin/runghc Setup.hs
+DOCSDIR= ${PREFIX}/share/doc/X11-${PORTVERSION}
SUBDIR= ${PORTNAME}${PKGNAMESUFFIX}
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+
do-configure:
cd ${WRKSRC} && ${CABALCMD} configure --ghc --prefix=${PREFIX} --libdir=${CABALDIR} \
--libsubdir='' --datasubdir=''
@@ -45,6 +50,9 @@ do-configure:
do-build:
cd ${WRKSRC} && ${CABALCMD} build \
&& ${CABALCMD} --gen-script register
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${CABALCMD} haddock
+.endif
do-install:
cd ${WRKSRC} && ${CABALCMD} install \
diff --git a/x11/hs-x11-ghc/pkg-plist b/x11/hs-x11-ghc/pkg-plist
index 41a8606032c8..b0679cfa666b 100644
--- a/x11/hs-x11-ghc/pkg-plist
+++ b/x11/hs-x11-ghc/pkg-plist
@@ -1,31 +1,57 @@
+%%SUBDIR%%/Graphics/X11.hi
+%%SUBDIR%%/Graphics/X11/Types.hi
%%SUBDIR%%/Graphics/X11/Xinerama.hi
-%%SUBDIR%%/Graphics/X11/Xlib/Extras.hi
-%%SUBDIR%%/include/XlibExtras.h
+%%SUBDIR%%/Graphics/X11/Xlib.hi
%%SUBDIR%%/Graphics/X11/Xlib/Atom.hi
%%SUBDIR%%/Graphics/X11/Xlib/Color.hi
%%SUBDIR%%/Graphics/X11/Xlib/Context.hi
%%SUBDIR%%/Graphics/X11/Xlib/Display.hi
%%SUBDIR%%/Graphics/X11/Xlib/Event.hi
+%%SUBDIR%%/Graphics/X11/Xlib/Extras.hi
%%SUBDIR%%/Graphics/X11/Xlib/Font.hi
+%%SUBDIR%%/Graphics/X11/Xlib/Image.hi
%%SUBDIR%%/Graphics/X11/Xlib/Misc.hi
%%SUBDIR%%/Graphics/X11/Xlib/Region.hi
%%SUBDIR%%/Graphics/X11/Xlib/Screen.hi
%%SUBDIR%%/Graphics/X11/Xlib/Types.hi
%%SUBDIR%%/Graphics/X11/Xlib/Window.hi
-%%SUBDIR%%/Graphics/X11/Xlib/Image.hi
-%%SUBDIR%%/Graphics/X11/Types.hi
-%%SUBDIR%%/Graphics/X11/Xlib.hi
-%%SUBDIR%%/Graphics/X11.hi
-%%SUBDIR%%/libHSX11-%%PORTVERSION%%.a
%%SUBDIR%%/HSX11-%%PORTVERSION%%.o
%%SUBDIR%%/include/HsXlib.h
+%%SUBDIR%%/include/XlibExtras.h
+%%SUBDIR%%/libHSX11-%%PORTVERSION%%.a
%%SUBDIR%%/%%PORTNAME%%-register.sh
-share/doc/X11-1.4.1/LICENSE
-@dirrm share/doc/X11-1.4.1
+%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Types.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xinerama.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Atom.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Color.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Context.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Display.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Event.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Extras.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Font.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Image.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Misc.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Region.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Screen.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Types.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib-Window.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xlib.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11.html
+%%PORTDOCS%%%%DOCSDIR%%/html/X11.haddock
+%%PORTDOCS%%%%DOCSDIR%%/html/doc-index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/haddock-util.js
+%%PORTDOCS%%%%DOCSDIR%%/html/haddock.css
+%%PORTDOCS%%%%DOCSDIR%%/html/haskell_icon.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/minus.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/plus.gif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+@dirrm %%DOCSDIR%%
+@dirrmtry %%SUBDIR%%/include
@dirrm %%SUBDIR%%/Graphics/X11/Xlib
@dirrm %%SUBDIR%%/Graphics/X11
@dirrmtry %%SUBDIR%%/Graphics
-@dirrmtry %%SUBDIR%%/include
@exec /bin/sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
@unexec %D/bin/ghc-pkg unregister X11