aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-09-04 01:19:53 +0000
committerSteve Wills <swills@FreeBSD.org>2020-09-04 01:19:53 +0000
commit59cefcc21c2ef16858a5ebba6f240a8da414ed45 (patch)
tree6283ecd08d2bdbaaee65481b23b35e86828e63d9 /x11
parent60d66c6a7ae231d9f91e244b5ad489b354eb6dad (diff)
downloadports-59cefcc21c2ef16858a5ebba6f240a8da414ed45.tar.gz
ports-59cefcc21c2ef16858a5ebba6f240a8da414ed45.zip
x11/xob: create port
Lightweight configurable overlay (volume/backlight/ progress/anything) bar for the X Window System (and Wayland compositors with XWayland). Each time a new value is read on the standard input, it is displayed as a tv-like bar over other windows. It then vanishes after a configurable amount of time. A value followed by a bang '!' is displayed using an alternate color to account for special states (e.g. muted audio). There is also support for overflows (when the value exceeds the maximum). WWW: https://github.com/florentc/xob PR: 248231 Submitted by: Lewis Cook <vulcan@wired.sh>
Notes
Notes: svn path=/head/; revision=547493
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xob/Makefile33
-rw-r--r--x11/xob/distinfo3
-rw-r--r--x11/xob/files/patch-Makefile21
-rw-r--r--x11/xob/pkg-descr10
5 files changed, 68 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index c0d4e2c6b69d..02cb780de16c 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -463,6 +463,7 @@
SUBDIR += xmsg
SUBDIR += xmx
SUBDIR += xnee
+ SUBDIR += xob
SUBDIR += xorg
SUBDIR += xorg-apps
SUBDIR += xorg-cf-files
diff --git a/x11/xob/Makefile b/x11/xob/Makefile
new file mode 100644
index 000000000000..ac336bbd3f85
--- /dev/null
+++ b/x11/xob/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= xob
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2
+CATEGORIES= x11
+
+MAINTAINER= vulcan@wired.sh
+COMMENT= Lightweight overlay volume (or anything) bar for the X Window System
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libconfig.so:devel/libconfig
+
+USES= compiler:c11 gmake pkgconfig xorg
+USE_GITHUB= yes
+GH_ACCOUNT= florentc
+USE_XORG= x11
+
+PORTDOCS= CHANGELOG.md CONTRIBUTING.md README.md
+
+OPTIONS_DEFINE= DOCS
+
+PLIST_FILES= ${ETCDIR}/styles.cfg \
+ bin/xob \
+ share/man/man1/xob.1.gz
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11/xob/distinfo b/x11/xob/distinfo
new file mode 100644
index 000000000000..0ea8861d70d0
--- /dev/null
+++ b/x11/xob/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1595542913
+SHA256 (florentc-xob-v0.2_GH0.tar.gz) = 06fb0d9a081546b6b9d1785f6d6fa36f905516eec5df3a567b5d22bd1f8df33a
+SIZE (florentc-xob-v0.2_GH0.tar.gz) = 510814
diff --git a/x11/xob/files/patch-Makefile b/x11/xob/files/patch-Makefile
new file mode 100644
index 000000000000..d96be539ad9d
--- /dev/null
+++ b/x11/xob/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2020-07-23 22:56:39 UTC
++++ Makefile
+@@ -27,12 +27,12 @@ $(PROGRAM): $(OBJECTS)
+ $(CC) $(CFLAGS) -DSYSCONFDIR='"$(sysconfdir)"' -c -o $@ $<
+
+ install: $(PROGRAM) $(MANPAGE) $(SYSCONF)
+- mkdir --parents "$(DESTDIR)$(bindir)"
+- $(INSTALL_PROGRAM) "$(PROGRAM)" -t "$(DESTDIR)$(bindir)"
+- mkdir --parents "$(DESTDIR)$(man1dir)"
+- $(INSTALL_DATA) "$(MANPAGE)" -t "$(DESTDIR)$(man1dir)"
+- mkdir --parents "$(DESTDIR)$(sysconfdir)/$(PROGRAM)"
+- $(INSTALL_DATA) "$(SYSCONF)" -t "$(DESTDIR)$(sysconfdir)/$(PROGRAM)"
++ mkdir -p "$(DESTDIR)$(bindir)"
++ $(BSD_INSTALL_PROGRAM) "$(PROGRAM)" "$(DESTDIR)$(bindir)"
++ mkdir -p "$(DESTDIR)$(man1dir)"
++ $(BSD_INSTALL_DATA) "$(MANPAGE)" "$(DESTDIR)$(man1dir)"
++ mkdir -p "$(DESTDIR)$(sysconfdir)/$(PROGRAM)"
++ $(BSD_INSTALL_DATA) "$(SYSCONF)" "$(DESTDIR)$(sysconfdir)/$(PROGRAM)"
+
+ uninstall:
+ rm -f "$(DESTDIR)$(bindir)/$(PROGRAM)"
diff --git a/x11/xob/pkg-descr b/x11/xob/pkg-descr
new file mode 100644
index 000000000000..64fc2050fffc
--- /dev/null
+++ b/x11/xob/pkg-descr
@@ -0,0 +1,10 @@
+Lightweight configurable overlay (volume/backlight/ progress/anything) bar for
+the X Window System (and Wayland compositors with XWayland).
+
+Each time a new value is read on the standard input, it is displayed as a
+tv-like bar over other windows. It then vanishes after a configurable amount
+of time. A value followed by a bang '!' is displayed using an alternate color
+to account for special states (e.g. muted audio). There is also support for
+overflows (when the value exceeds the maximum).
+
+WWW: https://github.com/florentc/xob